summaryrefslogtreecommitdiffstats
path: root/recipes-security/fail2ban/fail2ban_0.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/fail2ban/fail2ban_0.10.2.bb')
-rw-r--r--recipes-security/fail2ban/fail2ban_0.10.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-security/fail2ban/fail2ban_0.10.2.bb b/recipes-security/fail2ban/fail2ban_0.10.2.bb
new file mode 100644
index 0000000..7e2deba
--- /dev/null
+++ b/recipes-security/fail2ban/fail2ban_0.10.2.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Daemon to ban hosts that cause multiple authentication errors."
2DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \
3many failed login attempts. It does this by updating system firewall rules to reject new \
4connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \
5out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \
6and is easy to configure to read any log file you choose, for any error you choose."
7HOMEPAGE = "http://www.fail2ban.org"
8
9LICENSE = "GPL-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f"
11
12SRCREV ="a45488465e0dd547eb8479c0fa9fd577c1837213"
13SRC_URI = " \
14 git://github.com/fail2ban/fail2ban.git;branch=0.10 \
15 file://initd \
16 file://fail2ban_setup.py \
17"
18
19inherit update-rc.d setuptools
20
21S = "${WORKDIR}/git"
22
23INITSCRIPT_PACKAGES = "${PN}"
24INITSCRIPT_NAME = "fail2ban-server"
25INITSCRIPT_PARAMS = "defaults 25"
26
27do_compile_prepend () {
28 cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py
29}
30
31do_install_append () {
32 install -d ${D}/${sysconfdir}/fail2ban
33 install -d ${D}/${sysconfdir}/init.d
34 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
35}
36
37FILES_${PN} += "/run"
38
39INSANE_SKIP_${PN}_append = "already-stripped"
40
41RDEPENDS_${PN} = "sysklogd iptables sqlite3 python python-pyinotify"