summaryrefslogtreecommitdiffstats
path: root/recipes-security/AppArmor/files/crosscompile_perl_bindings.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/AppArmor/files/crosscompile_perl_bindings.patch')
-rw-r--r--recipes-security/AppArmor/files/crosscompile_perl_bindings.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-security/AppArmor/files/crosscompile_perl_bindings.patch b/recipes-security/AppArmor/files/crosscompile_perl_bindings.patch
new file mode 100644
index 0000000..ef55de7
--- /dev/null
+++ b/recipes-security/AppArmor/files/crosscompile_perl_bindings.patch
@@ -0,0 +1,25 @@
1Upstream-Status: Inappropriate [configuration]
2
3As we're cross-compiling here we need to override CC/LD that MakeMaker has
4stuck in the generated Makefile with our cross tools. In this case, linking is
5done via the compiler rather than the linker directly so pass in CC not LD
6here.
7
8Signed-Off-By: Tom Rini <trini@konsulko.com>
9
10--- a/libraries/libapparmor/swig/perl/Makefile.am.orig 2017-06-13 19:04:43.296676212 -0400
11+++ b/libraries/libapparmor/swig/perl/Makefile.am 2017-06-13 19:05:03.488676693 -0400
12@@ -16,11 +16,11 @@
13
14 LibAppArmor.so: libapparmor_wrap.c Makefile.perl
15 if test ! -f libapparmor_wrap.c; then cp $(srcdir)/libapparmor_wrap.c . ; fi
16- $(MAKE) -fMakefile.perl
17+ $(MAKE) -fMakefile.perl CC='$(CC)' LD='$(CC)'
18 if test $(top_srcdir) != $(top_builddir) ; then rm -f libapparmor_wrap.c ; fi
19
20 install-exec-local: Makefile.perl
21- $(MAKE) -fMakefile.perl install_vendor
22+ $(MAKE) -fMakefile.perl install_vendor CC='$(CC)' LD='$(CC)'
23
24 # sadly there is no make uninstall for perl
25 #uninstall-local: Makefile.perl