summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb')
-rw-r--r--meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb b/meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb
new file mode 100644
index 0000000..866791c
--- /dev/null
+++ b/meta-tpm/recipes-tpm/tpm2simulator/tpm2simulator-native_138.bb
@@ -0,0 +1,22 @@
1SUMMARY = "TPM 2.0 Simulator Extraction Script"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1415f7be284540b81d9d28c67c1a6b8b"
4
5DEPENDS = "python"
6
7SRCREV = "e45324eba268723d39856111e7933c5c76238481"
8SRC_URI = "git://github.com/stwagnr/tpm2simulator.git"
9
10S = "${WORKDIR}/git"
11OECMAKE_SOURCEPATH = "${S}/cmake"
12
13inherit native lib_package cmake
14
15EXTRA_OECMAKE = " \
16 -DCMAKE_BUILD_TYPE=Debug \
17 -DSPEC_VERSION=138 \
18"
19
20do_configure_prepend () {
21 sed -i 's/^SET = False/SET = True/' ${S}/scripts/settings.py
22}