summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb')
-rw-r--r--meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb b/meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb
new file mode 100644
index 0000000..31e90f8
--- /dev/null
+++ b/meta-tpm/recipes-tpm/tpm2-abrmd/tpm2-abrmd_2.0.1.bb
@@ -0,0 +1,54 @@
1SUMMARY = "TPM2 Access Broker & Resource Manager"
2DESCRIPTION = "This is a system daemon implementing the TPM2 access \
3broker (TAB) & Resource Manager (RM) spec from the TCG. The daemon (tpm2-abrmd) \
4is implemented using Glib and the GObject system. In this documentation and \
5in the code we use `tpm2-abrmd` and `tabrmd` interchangeably. \
6"
7SECTION = "security/tpm"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
11
12DEPENDS += "autoconf-archive dbus glib-2.0 pkgconfig tpm2.0-tss glib-2.0-native \
13 libtss2 libtss2-mu libtss2-tcti-device libtss2-tcti-mssim"
14
15SRC_URI = "\
16 git://github.com/01org/tpm2-abrmd.git \
17 file://tpm2-abrmd-init.sh \
18 file://tpm2-abrmd.default \
19"
20SRCREV = "80f8966b90d6394ad568e362d2936b333c2822bb"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig systemd update-rc.d useradd
25
26SYSTEMD_PACKAGES += "${PN}"
27SYSTEMD_SERVICE_${PN} = "tpm2-abrmd.service"
28SYSTEMD_AUTO_ENABLE_${PN} = "disable"
29
30INITSCRIPT_NAME = "${PN}"
31INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 19 0 1 6 ."
32
33USERADD_PACKAGES = "${PN}"
34GROUPADD_PARAM_${PN} = "tss"
35USERADD_PARAM_${PN} = "--system -M -d /var/lib/tpm -s /bin/false -g tss tss"
36
37PACKAGECONFIG ?="udev"
38PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd', '', d)}"
39
40PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --with-systemdsystemunitdir=no"
41
42do_install_append() {
43 install -d "${D}${sysconfdir}/init.d"
44 install -m 0755 "${WORKDIR}/tpm2-abrmd-init.sh" "${D}${sysconfdir}/init.d/tpm2-abrmd"
45
46 install -d "${D}${sysconfdir}/default"
47 install -m 0644 "${WORKDIR}/tpm2-abrmd.default" "${D}${sysconfdir}/default/tpm2-abrmd"
48}
49
50FILES_${PN} += "${libdir}/systemd/system-preset"
51
52RDEPENDS_${PN} += "tpm2.0-tss"
53
54BBCLASSEXTEND = "native"