summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch')
-rw-r--r--meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch b/meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch
index ab5e683..40150af 100644
--- a/meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch
+++ b/meta-tpm/recipes-tpm/tpm-tools/files/tpm-tools-extendpcr.patch
@@ -1,8 +1,8 @@
1Index: tpm-tools-1.3.8/include/tpm_tspi.h 1Index: git/include/tpm_tspi.h
2=================================================================== 2===================================================================
3--- tpm-tools-1.3.8.orig/include/tpm_tspi.h 2011-08-17 08:20:35.000000000 -0400 3--- git.orig/include/tpm_tspi.h
4+++ tpm-tools-1.3.8/include/tpm_tspi.h 2013-01-05 23:26:31.571598217 -0500 4+++ git/include/tpm_tspi.h
5@@ -117,6 +117,10 @@ 5@@ -117,6 +117,10 @@ TSS_RESULT tpmPcrRead(TSS_HTPM a_hTpm, U
6 UINT32 *a_PcrSize, BYTE **a_PcrValue); 6 UINT32 *a_PcrSize, BYTE **a_PcrValue);
7 TSS_RESULT pcrcompositeSetPcrValue(TSS_HPCRS a_hPcrs, UINT32 a_Idx, 7 TSS_RESULT pcrcompositeSetPcrValue(TSS_HPCRS a_hPcrs, UINT32 a_Idx,
8 UINT32 a_PcrSize, BYTE *a_PcrValue); 8 UINT32 a_PcrSize, BYTE *a_PcrValue);
@@ -13,11 +13,11 @@ Index: tpm-tools-1.3.8/include/tpm_tspi.h
13 #ifdef TSS_LIB_IS_12 13 #ifdef TSS_LIB_IS_12
14 TSS_RESULT unloadVersionInfo(UINT64 *offset, BYTE *blob, TPM_CAP_VERSION_INFO *v); 14 TSS_RESULT unloadVersionInfo(UINT64 *offset, BYTE *blob, TPM_CAP_VERSION_INFO *v);
15 TSS_RESULT pcrcompositeSetPcrLocality(TSS_HPCRS a_hPcrs, UINT32 localityValue); 15 TSS_RESULT pcrcompositeSetPcrLocality(TSS_HPCRS a_hPcrs, UINT32 localityValue);
16Index: tpm-tools-1.3.8/lib/tpm_tspi.c 16Index: git/lib/tpm_tspi.c
17=================================================================== 17===================================================================
18--- tpm-tools-1.3.8.orig/lib/tpm_tspi.c 2011-08-17 08:20:35.000000000 -0400 18--- git.orig/lib/tpm_tspi.c
19+++ tpm-tools-1.3.8/lib/tpm_tspi.c 2013-01-05 23:27:37.731593490 -0500 19+++ git/lib/tpm_tspi.c
20@@ -594,6 +594,20 @@ 20@@ -594,6 +594,20 @@ pcrcompositeSetPcrValue(TSS_HPCRS a_hPcr
21 return result; 21 return result;
22 } 22 }
23 23
@@ -38,10 +38,10 @@ Index: tpm-tools-1.3.8/lib/tpm_tspi.c
38 #ifdef TSS_LIB_IS_12 38 #ifdef TSS_LIB_IS_12
39 /* 39 /*
40 * These getPasswd functions will wrap calls to the other functions and check to see if the TSS 40 * These getPasswd functions will wrap calls to the other functions and check to see if the TSS
41Index: tpm-tools-1.3.8/src/cmds/Makefile.am 41Index: git/src/cmds/Makefile.am
42=================================================================== 42===================================================================
43--- tpm-tools-1.3.8.orig/src/cmds/Makefile.am 2011-08-15 13:52:08.000000000 -0400 43--- git.orig/src/cmds/Makefile.am
44+++ tpm-tools-1.3.8/src/cmds/Makefile.am 2013-01-05 23:30:46.223593698 -0500 44+++ git/src/cmds/Makefile.am
45@@ -22,6 +22,7 @@ 45@@ -22,6 +22,7 @@
46 # 46 #
47 47
@@ -50,16 +50,16 @@ Index: tpm-tools-1.3.8/src/cmds/Makefile.am
50 tpm_unsealdata 50 tpm_unsealdata
51 51
52 if TSS_LIB_IS_12 52 if TSS_LIB_IS_12
53@@ -33,4 +34,5 @@ 53@@ -33,4 +34,5 @@ endif
54 LDADD = $(top_builddir)/lib/libtpm_tspi.la -ltspi $(top_builddir)/lib/libtpm_unseal.la -ltpm_unseal -lcrypto 54 LDADD = $(top_builddir)/lib/libtpm_tspi.la -ltspi $(top_builddir)/lib/libtpm_unseal.la -ltpm_unseal -lcrypto @INTLLIBS@
55 55
56 tpm_sealdata_SOURCES = tpm_sealdata.c 56 tpm_sealdata_SOURCES = tpm_sealdata.c
57+tpm_extendpcr_SOURCES = tpm_extendpcr.c 57+tpm_extendpcr_SOURCES = tpm_extendpcr.c
58 tpm_unsealdata_SOURCES = tpm_unsealdata.c 58 tpm_unsealdata_SOURCES = tpm_unsealdata.c
59Index: tpm-tools-1.3.8/src/cmds/tpm_extendpcr.c 59Index: git/src/cmds/tpm_extendpcr.c
60=================================================================== 60===================================================================
61--- /dev/null 1970-01-01 00:00:00.000000000 +0000 61--- /dev/null
62+++ tpm-tools-1.3.8/src/cmds/tpm_extendpcr.c 2013-01-05 23:37:43.403585514 -0500 62+++ git/src/cmds/tpm_extendpcr.c
63@@ -0,0 +1,181 @@ 63@@ -0,0 +1,181 @@
64+/* 64+/*
65+ * The Initial Developer of the Original Code is International 65+ * The Initial Developer of the Original Code is International