diff options
-rw-r--r-- | meta-parsec/README.md | 8 | ||||
-rw-r--r-- | meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb | 10 |
2 files changed, 9 insertions, 9 deletions
diff --git a/meta-parsec/README.md b/meta-parsec/README.md index a2736b6..24958ac 100644 --- a/meta-parsec/README.md +++ b/meta-parsec/README.md | |||
@@ -53,7 +53,7 @@ other layers needed. e.g.: | |||
53 | To include the Parsec service into your image add following into the | 53 | To include the Parsec service into your image add following into the |
54 | local.conf: | 54 | local.conf: |
55 | 55 | ||
56 | IMAGE_INSTALL_append = " parsec-service" | 56 | IMAGE_INSTALL:append = " parsec-service" |
57 | 57 | ||
58 | The Parsec service will be deployed into the image built with all the supported | 58 | The Parsec service will be deployed into the image built with all the supported |
59 | providers and with the default config file from the Parsec repository: | 59 | providers and with the default config file from the Parsec repository: |
@@ -86,7 +86,7 @@ Manual testing with runqemu | |||
86 | This layer also contains a recipe for pasec-tool which can be used for | 86 | This layer also contains a recipe for pasec-tool which can be used for |
87 | manual testing of the Parsec service: | 87 | manual testing of the Parsec service: |
88 | 88 | ||
89 | IMAGE_INSTALL_append += " parsec-tools" | 89 | IMAGE_INSTALL:append += " parsec-tools" |
90 | 90 | ||
91 | There are a series of Parsec Demo videos showing how to use parsec-tool | 91 | There are a series of Parsec Demo videos showing how to use parsec-tool |
92 | to test the Parsec service base functionality: | 92 | to test the Parsec service base functionality: |
@@ -103,7 +103,7 @@ enabled. No changes required for manual testing. | |||
103 | The Software HSM can be used for manual testing of the provider by | 103 | The Software HSM can be used for manual testing of the provider by |
104 | including it into your test image: | 104 | including it into your test image: |
105 | 105 | ||
106 | IMAGE_INSTALL_append += " softhsm" | 106 | IMAGE_INSTALL:append += " softhsm" |
107 | 107 | ||
108 | Inside the running VM: | 108 | Inside the running VM: |
109 | - Stop Parsec | 109 | - Stop Parsec |
@@ -134,7 +134,7 @@ systemctl start parsec | |||
134 | The IBM Software TPM service can be used for manual testing of the provider by | 134 | The IBM Software TPM service can be used for manual testing of the provider by |
135 | including it into your test image: | 135 | including it into your test image: |
136 | 136 | ||
137 | IMAGE_INSTALL_append += " ibmswtpm2 tpm2-tools libtss2 libtss2-tcti-mssim" | 137 | IMAGE_INSTALL:append += " ibmswtpm2 tpm2-tools libtss2 libtss2-tcti-mssim" |
138 | 138 | ||
139 | Inside the running VM: | 139 | Inside the running VM: |
140 | - Stop Parsec | 140 | - Stop Parsec |
diff --git a/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb b/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb index d57a43a..5f7a99b 100644 --- a/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb +++ b/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb | |||
@@ -15,7 +15,7 @@ DEPENDS = "tpm2-tss clang-native" | |||
15 | CARGO_BUILD_FLAGS += " --features all-providers,cryptoki/generate-bindings,tss-esapi/generate-bindings" | 15 | CARGO_BUILD_FLAGS += " --features all-providers,cryptoki/generate-bindings,tss-esapi/generate-bindings" |
16 | 16 | ||
17 | inherit systemd | 17 | inherit systemd |
18 | SYSTEMD_SERVICE_${PN} = "parsec.service" | 18 | SYSTEMD_SERVICE:${PN} = "parsec.service" |
19 | 19 | ||
20 | inherit update-rc.d | 20 | inherit update-rc.d |
21 | INITSCRIPT_NAME = "parsec" | 21 | INITSCRIPT_NAME = "parsec" |
@@ -24,7 +24,7 @@ INITSCRIPT_NAME = "parsec" | |||
24 | # The file should also be included into SRC_URI then | 24 | # The file should also be included into SRC_URI then |
25 | PARSEC_CONFIG ?= "${S}/config.toml" | 25 | PARSEC_CONFIG ?= "${S}/config.toml" |
26 | 26 | ||
27 | do_install_append () { | 27 | do_install:append () { |
28 | # Binaries | 28 | # Binaries |
29 | install -d -m 700 -o parsec -g parsec "${D}${libexecdir}/parsec" | 29 | install -d -m 700 -o parsec -g parsec "${D}${libexecdir}/parsec" |
30 | install -m 700 -o parsec -g parsec "${WORKDIR}/build/target/${CARGO_TARGET_SUBDIR}/parsec" ${D}${libexecdir}/parsec/parsec | 30 | install -m 700 -o parsec -g parsec "${WORKDIR}/build/target/${CARGO_TARGET_SUBDIR}/parsec" ${D}${libexecdir}/parsec/parsec |
@@ -52,10 +52,10 @@ do_install_append () { | |||
52 | 52 | ||
53 | inherit useradd | 53 | inherit useradd |
54 | USERADD_PACKAGES = "${PN}" | 54 | USERADD_PACKAGES = "${PN}" |
55 | USERADD_PARAM_${PN} = "-r -g parsec -s /bin/false -d ${localstatedir}/lib/parsec parsec" | 55 | USERADD_PARAM:${PN} = "-r -g parsec -s /bin/false -d ${localstatedir}/lib/parsec parsec" |
56 | GROUPADD_PARAM_${PN} = "-r parsec" | 56 | GROUPADD_PARAM:${PN} = "-r parsec" |
57 | 57 | ||
58 | FILES_${PN} += " \ | 58 | FILES:${PN} += " \ |
59 | ${sysconfdir}/parsec/config.toml \ | 59 | ${sysconfdir}/parsec/config.toml \ |
60 | ${libexecdir}/parsec/parsec \ | 60 | ${libexecdir}/parsec/parsec \ |
61 | ${systemd_unitdir}/system/parsec.service \ | 61 | ${systemd_unitdir}/system/parsec.service \ |