summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/busybox/busybox/head.cfg1
-rw-r--r--recipes-core/busybox/busybox_%.bbappend3
-rw-r--r--recipes-security/libseccomp/files/regresion_fixup_seq_usage.patch25
-rw-r--r--recipes-security/libseccomp/libseccomp_2.2.0.bb27
4 files changed, 55 insertions, 1 deletions
diff --git a/recipes-core/busybox/busybox/head.cfg b/recipes-core/busybox/busybox/head.cfg
new file mode 100644
index 0000000..16017ea
--- /dev/null
+++ b/recipes-core/busybox/busybox/head.cfg
@@ -0,0 +1 @@
CONFIG_FEATURE_FANCY_HEAD=y
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 0000000..8bb0706
--- /dev/null
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://head.cfg"
diff --git a/recipes-security/libseccomp/files/regresion_fixup_seq_usage.patch b/recipes-security/libseccomp/files/regresion_fixup_seq_usage.patch
new file mode 100644
index 0000000..7832ff8
--- /dev/null
+++ b/recipes-security/libseccomp/files/regresion_fixup_seq_usage.patch
@@ -0,0 +1,25 @@
1Index: git/tests/regression
2===================================================================
3--- git.orig/tests/regression
4+++ git/tests/regression
5@@ -468,13 +468,13 @@ function run_test_bpf_sim() {
6 # and arg ranges and generate/run every combination of requested
7 # tests; if no ranges were specifed, then the single test is
8 # run
9- for sys in $(seq -f "%1.0f" $low_syscall $high_syscall); do
10- for arg0 in $(seq -f "%1.0f" ${low_arg[0]} ${high_arg[0]}); do
11- for arg1 in $(seq -f "%1.0f" ${low_arg[1]} ${high_arg[1]}); do
12- for arg2 in $(seq -f "%1.0f" ${low_arg[2]} ${high_arg[2]}); do
13- for arg3 in $(seq -f "%1.0f" ${low_arg[3]} ${high_arg[3]}); do
14- for arg4 in $(seq -f "%1.0f" ${low_arg[4]} ${high_arg[4]}); do
15- for arg5 in $(seq -f "%1.0f" ${low_arg[5]} ${high_arg[5]}); do
16+ for sys in $(seq $low_syscall $high_syscall); do
17+ for arg0 in $(seq ${low_arg[0]} ${high_arg[0]}); do
18+ for arg1 in $(seq ${low_arg[1]} ${high_arg[1]}); do
19+ for arg2 in $(seq ${low_arg[2]} ${high_arg[2]}); do
20+ for arg3 in $(seq ${low_arg[3]} ${high_arg[3]}); do
21+ for arg4 in $(seq ${low_arg[4]} ${high_arg[4]}); do
22+ for arg5 in $(seq ${low_arg[5]} ${high_arg[5]}); do
23 local -a arg=($arg0 $arg1 $arg2 $arg3 $arg4 $arg5)
24
25 # Get the generated sub-test num string
diff --git a/recipes-security/libseccomp/libseccomp_2.2.0.bb b/recipes-security/libseccomp/libseccomp_2.2.0.bb
index 02cfb39..bd970ed 100644
--- a/recipes-security/libseccomp/libseccomp_2.2.0.bb
+++ b/recipes-security/libseccomp/libseccomp_2.2.0.bb
@@ -8,7 +8,7 @@ SRCREV = "bd10aab13c7248cc0df57512617e33d6743d33a6"
8 8
9PV = "2.2.0+git${SRCPV}" 9PV = "2.2.0+git${SRCPV}"
10 10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;protocol=http \ 11SRC_URI = "git://github.com/seccomp/libseccomp.git \
12 file://0001-arch-add-a-ppc64-syscall-table.patch \ 12 file://0001-arch-add-a-ppc64-syscall-table.patch \
13 file://0002-arch-add-the-basic-initial-support-for-ppc64-to-the-.patch \ 13 file://0002-arch-add-the-basic-initial-support-for-ppc64-to-the-.patch \
14 file://0003-tools-add-ppc64-support.patch \ 14 file://0003-tools-add-ppc64-support.patch \
@@ -20,6 +20,7 @@ SRC_URI = "git://github.com/seccomp/libseccomp.git;protocol=http \
20 file://0009-arch-add-basic-initial-ppc-support-to-the-arch-depen.patch \ 20 file://0009-arch-add-basic-initial-ppc-support-to-the-arch-depen.patch \
21 file://0010-tools-add-ppc-support.patch \ 21 file://0010-tools-add-ppc-support.patch \
22 file://0011-tests-add-ppc-support-to-the-regression-tests.patch \ 22 file://0011-tests-add-ppc-support-to-the-regression-tests.patch \
23 file://regresion_fixup_seq_usage.patch \
23 " 24 "
24 25
25S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
@@ -29,4 +30,28 @@ inherit autotools-brokensep pkgconfig
29PACKAGECONFIG ??= "" 30PACKAGECONFIG ??= ""
30PACKAGECONFIG[python] = "--enable-python, --disable-python, python" 31PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
31 32
33do_compile_appned() {
34 oe_runmake -C tests check-build
35}
36
37do_install_append() {
38 install -d ${D}/${libdir}/${PN}/tests
39 install -d ${D}/${libdir}/${PN}/tools
40 for file in $(find tests/* -executable -type f); do
41 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tests
42 done
43 for file in $(find tests/*.tests -type f); do
44 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tests
45 done
46 for file in $(find tools/* -executable -type f); do
47 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tools
48 done
49}
50
51PACKAGES += " ${PN}-tests"
52FILES_${PN} = "${bindir} ${libdir}/${PN}.so*"
53FILES_${PN}-tests = "${libdir}/${PN}/tools ${libdir}/${PN}/tests"
54FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
55
32RDEPENDS_${PN} = "bash" 56RDEPENDS_${PN} = "bash"
57RDEPENDS_${PN}-tests = "bash"