summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-05-18 15:10:53 +0000
committerArmin Kuster <akuster808@gmail.com>2021-06-05 19:25:19 +0000
commite471ff09268ff1081cf6265543a0be61c128072c (patch)
treedd040181660cf0385bc6aea5998865cabf54a6ae /recipes-security
parenta57799000e0117f24d7e8326657b933a4554d43b (diff)
downloadmeta-security-e471ff09268ff1081cf6265543a0be61c128072c.tar.gz
sssd: update to 2.5.0
Add new depends Drop obsolete patches Signed-off-by: Armin Kuster <akuster808@gmail.com> ---- v2] Fix issue with nsupdate check don't use host bind
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/sssd/files/0001-build-Don-t-use-AC_CHECK_FILE-when-building-manpages.patch34
-rw-r--r--recipes-security/sssd/files/0001-nss-Collision-with-external-nss-symbol.patch78
-rw-r--r--recipes-security/sssd/files/0002-Provide-missing-defines-which-otherwise-are-availabl.patch32
-rw-r--r--recipes-security/sssd/files/drop_ntpdate_chk.patch28
-rw-r--r--recipes-security/sssd/files/fix-ldblibdir.patch25
-rw-r--r--recipes-security/sssd/files/fix_gid.patch27
-rw-r--r--recipes-security/sssd/files/no_gen.patch19
-rw-r--r--recipes-security/sssd/sssd_2.5.0.bb (renamed from recipes-security/sssd/sssd_1.16.5.bb)29
8 files changed, 89 insertions, 183 deletions
diff --git a/recipes-security/sssd/files/0001-build-Don-t-use-AC_CHECK_FILE-when-building-manpages.patch b/recipes-security/sssd/files/0001-build-Don-t-use-AC_CHECK_FILE-when-building-manpages.patch
deleted file mode 100644
index b64670c..0000000
--- a/recipes-security/sssd/files/0001-build-Don-t-use-AC_CHECK_FILE-when-building-manpages.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From d54aa109600bcd02bf72cfe64c01935890a102a1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Jonatan=20P=C3=A5lsson?= <jonatan.p@gmail.com>
3Date: Fri, 21 Aug 2020 14:45:10 +0200
4Subject: [PATCH] build: Don't use AC_CHECK_FILE when building manpages
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9AC_CHECK_FILE does not support cross-compilation, and will only check
10the host rootfs. Replace AC_CHECK_FILE with a 'test -f <FILE>' instead,
11to allow building manpages when cross-compiling.
12
13Upstream-status: Submitted [https://github.com/SSSD/sssd/pull/5289]
14Signed-off-by: Jonatan Pålsson <jonatan.p@gmail.com>
15---
16 src/external/docbook.m4 | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/external/docbook.m4 b/src/external/docbook.m4
20index deb8632fa..acdc89a68 100644
21--- a/src/external/docbook.m4
22+++ b/src/external/docbook.m4
23@@ -18,7 +18,7 @@ dnl Checks if the XML catalog given by FILE exists and
24 dnl if a particular URI appears in the XML catalog
25 AC_DEFUN([CHECK_STYLESHEET],
26 [
27- AC_CHECK_FILE($1, [], [AC_MSG_ERROR([could not find XML catalog])])
28+ AS_IF([test -f "$1"], [], [AC_MSG_ERROR([could not find XML catalog])])
29
30 AC_MSG_CHECKING([for ifelse([$3],,[$2],[$3]) in XML catalog])
31 if AC_RUN_LOG([$XSLTPROC --catalogs --nonet --noout "$2" >&2]); then
32--
332.26.1
34
diff --git a/recipes-security/sssd/files/0001-nss-Collision-with-external-nss-symbol.patch b/recipes-security/sssd/files/0001-nss-Collision-with-external-nss-symbol.patch
deleted file mode 100644
index c319269..0000000
--- a/recipes-security/sssd/files/0001-nss-Collision-with-external-nss-symbol.patch
+++ /dev/null
@@ -1,78 +0,0 @@
1From 05c315100a70d3372e891e9a0ea981a875b2ec90 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Michal=20=C5=BDidek?= <mzidek@redhat.com>
3Date: Thu, 27 Feb 2020 06:50:40 +0100
4Subject: [PATCH] nss: Collision with external nss symbol
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9One of our internal static function names started
10to collide with external nss symbol. Additional
11sss_ suffix was added to avoid the collision.
12
13This is needed to unblock Fedora Rawhide's
14SSSD build.
15
16Reviewed-by: Pavel Březina <pbrezina@redhat.com>
17
18Upstream-Status: Backport [https://github.com/SSSD/sssd.git]
19Signed-off-by: Hongxu.jia@windriver.com
20Signed-off-by: Qi.Chen@windriver.com
21---
22 src/responder/nss/nss_cmd.c | 18 ++++++++++--------
23 1 file changed, 10 insertions(+), 8 deletions(-)
24
25diff --git a/src/responder/nss/nss_cmd.c b/src/responder/nss/nss_cmd.c
26index 25e663ed5..a4d4cfc0b 100644
27--- a/src/responder/nss/nss_cmd.c
28+++ b/src/responder/nss/nss_cmd.c
29@@ -728,11 +728,13 @@ done:
30 talloc_free(cmd_ctx);
31 }
32
33-static void nss_setnetgrent_done(struct tevent_req *subreq);
34+static void sss_nss_setnetgrent_done(struct tevent_req *subreq);
35
36-static errno_t nss_setnetgrent(struct cli_ctx *cli_ctx,
37- enum cache_req_type type,
38- nss_protocol_fill_packet_fn fill_fn)
39+/* This function's name started to collide with external nss symbol,
40+ * so it has additional sss_* prefix unlike other functions here. */
41+static errno_t sss_nss_setnetgrent(struct cli_ctx *cli_ctx,
42+ enum cache_req_type type,
43+ nss_protocol_fill_packet_fn fill_fn)
44 {
45 struct nss_ctx *nss_ctx;
46 struct nss_state_ctx *state_ctx;
47@@ -774,7 +776,7 @@ static errno_t nss_setnetgrent(struct cli_ctx *cli_ctx,
48 goto done;
49 }
50
51- tevent_req_set_callback(subreq, nss_setnetgrent_done, cmd_ctx);
52+ tevent_req_set_callback(subreq, sss_nss_setnetgrent_done, cmd_ctx);
53
54 ret = EOK;
55
56@@ -787,7 +789,7 @@ done:
57 return EOK;
58 }
59
60-static void nss_setnetgrent_done(struct tevent_req *subreq)
61+static void sss_nss_setnetgrent_done(struct tevent_req *subreq)
62 {
63 struct nss_cmd_ctx *cmd_ctx;
64 errno_t ret;
65@@ -1037,8 +1039,8 @@ static errno_t nss_cmd_initgroups_ex(struct cli_ctx *cli_ctx)
66
67 static errno_t nss_cmd_setnetgrent(struct cli_ctx *cli_ctx)
68 {
69- return nss_setnetgrent(cli_ctx, CACHE_REQ_NETGROUP_BY_NAME,
70- nss_protocol_fill_setnetgrent);
71+ return sss_nss_setnetgrent(cli_ctx, CACHE_REQ_NETGROUP_BY_NAME,
72+ nss_protocol_fill_setnetgrent);
73 }
74
75 static errno_t nss_cmd_getnetgrent(struct cli_ctx *cli_ctx)
76--
772.21.0
78
diff --git a/recipes-security/sssd/files/0002-Provide-missing-defines-which-otherwise-are-availabl.patch b/recipes-security/sssd/files/0002-Provide-missing-defines-which-otherwise-are-availabl.patch
deleted file mode 100644
index 1a22332..0000000
--- a/recipes-security/sssd/files/0002-Provide-missing-defines-which-otherwise-are-availabl.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 37a0999e5a9f54e1c61a02a7fbab6fcd04738b3c Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster808@gmail.com>
3Date: Thu, 8 Oct 2020 05:54:13 -0700
4Subject: [PATCH] Provide missing defines which otherwise are available on
5 glibc system headers
6
7Signed-off-by: Armin Kuster <akuster808@gmail.com>
8
9Upsteam-Status: Pending
10
11---
12 src/util/util.h | 4 ++++
13 1 file changed, 4 insertions(+)
14
15diff --git a/src/util/util.h b/src/util/util.h
16index 8a754dbfd..6e55b4bdc 100644
17--- a/src/util/util.h
18+++ b/src/util/util.h
19@@ -76,6 +76,10 @@
20 #define MAX(a, b) (((a) > (b)) ? (a) : (b))
21 #endif
22
23+#ifndef ALLPERMS
24+# define ALLPERMS (S_ISUID|S_ISGID|S_ISVTX|S_IRWXU|S_IRWXG|S_IRWXO)/* 07777 */
25+#endif
26+
27 #define SSSD_MAIN_OPTS SSSD_DEBUG_OPTS
28
29 #define SSSD_SERVER_OPTS(uid, gid) \
30--
312.17.1
32
diff --git a/recipes-security/sssd/files/drop_ntpdate_chk.patch b/recipes-security/sssd/files/drop_ntpdate_chk.patch
new file mode 100644
index 0000000..338af5d
--- /dev/null
+++ b/recipes-security/sssd/files/drop_ntpdate_chk.patch
@@ -0,0 +1,28 @@
1nsupdate path is needed for various exec call
2but don't run natvie tests on it.
3
4
5Upstream-Status: Inappropriate [OE specific]
6Signed-off-by: Armin Kuster <akuster808@gmail.com>
7
8Index: sssd-2.5.0/src/external/nsupdate.m4
9===================================================================
10--- sssd-2.5.0.orig/src/external/nsupdate.m4
11+++ sssd-2.5.0/src/external/nsupdate.m4
12@@ -3,16 +3,4 @@ AC_MSG_CHECKING(for executable nsupdate)
13 if test -x "$NSUPDATE"; then
14 AC_DEFINE_UNQUOTED([NSUPDATE_PATH], ["$NSUPDATE"], [The path to nsupdate])
15 AC_MSG_RESULT(yes)
16-
17- AC_MSG_CHECKING(for nsupdate 'realm' support')
18- if AC_RUN_LOG([echo realm |$NSUPDATE >&2]); then
19- AC_MSG_RESULT([yes])
20- else
21- AC_MSG_RESULT([no])
22- AC_MSG_ERROR([nsupdate does not support 'realm'])
23- fi
24-
25-else
26- AC_MSG_RESULT([no])
27- AC_MSG_ERROR([nsupdate is not available])
28 fi
diff --git a/recipes-security/sssd/files/fix-ldblibdir.patch b/recipes-security/sssd/files/fix-ldblibdir.patch
deleted file mode 100644
index e350baf..0000000
--- a/recipes-security/sssd/files/fix-ldblibdir.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1When calculate value of ldblibdir, it checks whether the directory of
2$ldblibdir exists. If not, it assigns ldblibdir with ${libdir}/ldb. It is not
3suitable for cross compile. Fix it that only re-assign ldblibdir when its value
4is empty.
5
6Upstream-Status: Inappropriate [cross compile specific]
7
8Signed-off-by: Kai Kang <kai.kang@windriver.com>
9---
10 src/external/libldb.m4 | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/external/libldb.m4 b/src/external/libldb.m4
14index c400add..5e5f06d 100644
15--- a/src/external/libldb.m4
16+++ b/src/external/libldb.m4
17@@ -19,7 +19,7 @@ if test x"$with_ldb_lib_dir" != x; then
18 ldblibdir=$with_ldb_lib_dir
19 else
20 ldblibdir="`$PKG_CONFIG --variable=modulesdir ldb`"
21- if ! test -d $ldblibdir; then
22+ if test -z $ldblibdir; then
23 ldblibdir="${libdir}/ldb"
24 fi
25 fi
diff --git a/recipes-security/sssd/files/fix_gid.patch b/recipes-security/sssd/files/fix_gid.patch
new file mode 100644
index 0000000..9b481cc
--- /dev/null
+++ b/recipes-security/sssd/files/fix_gid.patch
@@ -0,0 +1,27 @@
1from ../sssd-2.5.0/src/util/sss_pam_data.c:27:
2| ../sssd-2.5.0/src/util/debug.h:88:44: error: unknown type name 'uid_t'; did you mean 'uint_t'?
3| 88 | int chown_debug_file(const char *filename, uid_t uid, gid_t gid);
4| | ^~~~~
5| | uint_t
6| ../sssd-2.5.0/src/util/debug.h:88:55: error: unknown type name 'gid_t'
7| 88 | int chown_debug_file(const char *filename, uid_t uid, gid_t gid);
8| | ^~~~~
9| make[2]: *** [Makefile:22529: src/util/libsss_iface_la-sss_pam_data.lo] Error 1
10| make[2]: *** Waiting for unfinished jobs....
11
12Upstream-Status: Pending
13Signed-off-by: Armin Kuster <akuster808@gmail.com>
14
15Index: sssd-2.5.0/src/util/debug.h
16===================================================================
17--- sssd-2.5.0.orig/src/util/debug.h
18+++ sssd-2.5.0/src/util/debug.h
19@@ -24,6 +24,8 @@
20 #include "config.h"
21
22 #include <stdio.h>
23+#include <unistd.h>
24+#include <sys/types.h>
25 #include <stdbool.h>
26
27 #include "util/util_errors.h"
diff --git a/recipes-security/sssd/files/no_gen.patch b/recipes-security/sssd/files/no_gen.patch
new file mode 100644
index 0000000..5c83777
--- /dev/null
+++ b/recipes-security/sssd/files/no_gen.patch
@@ -0,0 +1,19 @@
1don't run generate-sbus-code
2
3Upstream-Status: Inappropriate [OE Specific]
4
5Signed-off-by: Armin Kuster <akuster808@gmail.com>
6
7Index: sssd-2.5.0/Makefile.am
8===================================================================
9--- sssd-2.5.0.orig/Makefile.am
10+++ sssd-2.5.0/Makefile.am
11@@ -1033,8 +1033,6 @@ generate-sbus-code:
12
13 .PHONY: generate-sbus-code
14
15-BUILT_SOURCES += generate-sbus-code
16-
17 EXTRA_DIST += \
18 sbus_generate.sh.in \
19 src/sbus/codegen/dbus.xml \
diff --git a/recipes-security/sssd/sssd_1.16.5.bb b/recipes-security/sssd/sssd_2.5.0.bb
index 9784ec7..4c92519 100644
--- a/recipes-security/sssd/sssd_1.16.5.bb
+++ b/recipes-security/sssd/sssd_2.5.0.bb
@@ -5,8 +5,8 @@ SECTION = "base"
5LICENSE = "GPLv3+" 5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7 7
8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive" 8DEPENDS = "acl attr openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive"
9DEPENDS_append = " libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent" 9DEPENDS_append = " libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent bind p11-kit"
10 10
11DEPENDS_append_libc-musl = " musl-nscd" 11DEPENDS_append_libc-musl = " musl-nscd"
12 12
@@ -15,16 +15,14 @@ DEPENDS_append_libc-musl = " musl-nscd"
15DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'nss', '', \ 15DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'nss', '', \
16 bb.utils.contains('PACKAGECONFIG', 'crypto', '', 'nss', d), d)}" 16 bb.utils.contains('PACKAGECONFIG', 'crypto', '', 'nss', d), d)}"
17 17
18SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz \ 18SRC_URI = "https://github.com/SSSD/sssd/releases/download/2.5.0/sssd-2.5.0.tar.gz \
19 file://sssd.conf \ 19 file://sssd.conf \
20 file://volatiles.99_sssd \ 20 file://volatiles.99_sssd \
21 file://fix-ldblibdir.patch \ 21 file://no_gen.patch \
22 file://0001-build-Don-t-use-AC_CHECK_FILE-when-building-manpages.patch \ 22 file://fix_gid.patch \
23 file://0001-nss-Collision-with-external-nss-symbol.patch \ 23 file://drop_ntpdate_chk.patch \
24 file://0002-Provide-missing-defines-which-otherwise-are-availabl.patch \
25 " 24 "
26 25SRC_URI[sha256sum] = "afa62d7d8d23fca3aba093abe4ec0d14e7d9346c5b28ceb7c2c624bed98caa06"
27SRC_URI[sha256sum] = "2e1a7bf036b583f686d35164f2d79bdf4857b98f51fe8b0d17aa0fa756e4d0c0"
28 26
29inherit autotools pkgconfig gettext python3-dir features_check systemd 27inherit autotools pkgconfig gettext python3-dir features_check systemd
30 28
@@ -34,7 +32,7 @@ SSSD_UID ?= "root"
34SSSD_GID ?= "root" 32SSSD_GID ?= "root"
35 33
36CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \ 34CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
37 ac_cv_path_NSUPDATE=${bindir} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \ 35 ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
38 " 36 "
39 37
40PACKAGECONFIG ?="nss nscd autofs sudo infopipe" 38PACKAGECONFIG ?="nss nscd autofs sudo infopipe"
@@ -42,13 +40,13 @@ PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux',
42PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 40PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
43 41
44PACKAGECONFIG[autofs] = "--with-autofs, --with-autofs=no" 42PACKAGECONFIG[autofs] = "--with-autofs, --with-autofs=no"
45PACKAGECONFIG[crypto] = "--with-crypto=libcrypto, , libcrypto" 43PACKAGECONFIG[crypto] = ", , libcrypto"
46PACKAGECONFIG[curl] = "--with-kcm, --without-kcm, curl jansson" 44PACKAGECONFIG[curl] = "--with-kcm, --without-kcm, curl jansson"
47PACKAGECONFIG[infopipe] = "--with-infopipe, --with-infopipe=no, " 45PACKAGECONFIG[infopipe] = "--with-infopipe, --with-infopipe=no, "
48PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no, libxslt-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native" 46PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no, libxslt-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
49PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl" 47PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl"
50PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no " 48PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no "
51PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss," 49PACKAGECONFIG[nss] = ", ,nss,"
52PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings" 50PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
53PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba" 51PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba"
54PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux" 52PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux"
@@ -75,6 +73,9 @@ do_configure_prepend() {
75 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4 73 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4
76} 74}
77 75
76do_compile_prepend () {
77 echo '#define NSUPDATE_PATH "${bindir}"' >> ${B}/config.h
78}
78do_install () { 79do_install () {
79 oe_runmake install DESTDIR="${D}" 80 oe_runmake install DESTDIR="${D}"
80 rmdir --ignore-fail-on-non-empty "${D}/${bindir}" 81 rmdir --ignore-fail-on-non-empty "${D}/${bindir}"
@@ -119,10 +120,10 @@ SYSTEMD_SERVICE_${PN} = " \
119" 120"
120SYSTEMD_AUTO_ENABLE = "disable" 121SYSTEMD_AUTO_ENABLE = "disable"
121 122
122FILES_${PN} += "${libdir} ${datadir} ${base_libdir}/security/pam_sss.so" 123FILES_${PN} += "${libdir} ${datadir} ${base_libdir}/security/pam_sss*.so"
123FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la" 124FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la"
124 125
125# The package contains symlinks that trip up insane 126# The package contains symlinks that trip up insane
126INSANE_SKIP_${PN} = "dev-so" 127INSANE_SKIP_${PN} = "dev-so"
127 128
128RDEPENDS_${PN} = "bind dbus libldb libpam" 129RDEPENDS_${PN} = "bind bind-utils dbus libldb libpam"