summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-05-08 18:55:44 -0700
committerArmin Kuster <akuster808@gmail.com>2017-05-14 07:56:52 -0700
commite0e46368e9275f25ff48a878133c3f5493e92b33 (patch)
tree7965f3cc4cf2516ab9fc3c64d9ee62ca486819d9 /recipes-security
parent1671f7d7e2111082609247558d17da4deb171b2a (diff)
downloadmeta-security-e0e46368e9275f25ff48a878133c3f5493e92b33.tar.gz
sssd: update SRC_URI as git.fedorahosted.org shut down
build fixes too Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/sssd/sssd_1.13.3.bb20
1 files changed, 9 insertions, 11 deletions
diff --git a/recipes-security/sssd/sssd_1.13.3.bb b/recipes-security/sssd/sssd_1.13.3.bb
index fd4f2a2..07abb93 100644
--- a/recipes-security/sssd/sssd_1.13.3.bb
+++ b/recipes-security/sssd/sssd_1.13.3.bb
@@ -5,25 +5,23 @@ SECTION = "base"
5LICENSE = "GPLv3+" 5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7 7
8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5" 8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive"
9DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent" 9DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent"
10 10
11SRCREV = "70862d81a9a1228ad27ad35c9e99cc24b77940c6" 11SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz\
12
13PV = "1.13.3+git${SRCPV}"
14
15SRC_URI = "git://git.fedorahosted.org/git/sssd.git;branch='sssd-1-13' \
16 file://sssd.conf " 12 file://sssd.conf "
17 13
18S = "${WORKDIR}/git" 14SRC_URI[md5sum] = "38bbb24ea9139508cc1d6e402e253244"
15SRC_URI[sha256sum] = "3fd8fe8e6ee9f50b33eecd1bcccfaa44791f30d4e5f3113ba91457ba5f411f85"
19 16
20inherit autotools pkgconfig gettext update-rc.d python-dir 17inherit autotools pkgconfig gettext update-rc.d python-dir
21 18
22CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \ 19CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
20 ac_cv_path_NSUPDATE=${bindir} \
23 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \ 21 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
24 " 22 "
25 23
26PACKAGECONFIG ?="nss" 24PACKAGECONFIG ?="nss nscd"
27PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" 25PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
28 26
29PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, " 27PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, "
@@ -32,14 +30,14 @@ PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no,
32PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no" 30PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no"
33PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings" 31PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings"
34PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings" 32PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
35PACKAGECONFIG[nss] = "--with-crypto=nss, , nss" 33PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss,"
36PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto" 34PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto"
37PACKAGECONFIG[nscd] = "--with-nscd=, --without-nscd, " 35PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no "
38PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl" 36PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl"
39PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir=" 37PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir="
40PACKAGECONFIG[systemd] = "--with-systemdconfdir=${systemd_unitdir}/system/, --with-systemdconfdir=" 38PACKAGECONFIG[systemd] = "--with-systemdconfdir=${systemd_unitdir}/system/, --with-systemdconfdir="
41 39
42EXTRA_OECONF += "--disable-rpath --disable-config-lib --disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab" 40EXTRA_OECONF += "--disable-config-lib --disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab"
43 41
44do_configure_prepend() { 42do_configure_prepend() {
45 mkdir -p ${AUTOTOOLS_AUXDIR}/build 43 mkdir -p ${AUTOTOOLS_AUXDIR}/build