summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-05-30 15:46:28 +0000
committerArmin Kuster <akuster808@gmail.com>2021-06-05 19:25:24 +0000
commitbb06a7cbda5b8144e628ee5c1888d533d2fb59ce (patch)
tree2b82afe23a2a044cbeedd6931059fd869fcc6d71 /recipes-security
parentf40fdc7e6da5bd9d4ad81bec5ed30f8e7b38da09 (diff)
downloadmeta-security-bb06a7cbda5b8144e628ee5c1888d533d2fb59ce.tar.gz
python3-scapy: drop , now in meta-python
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/scapy/files/run-ptest4
-rw-r--r--recipes-security/scapy/python3-scapy_2.4.5.bb30
2 files changed, 0 insertions, 34 deletions
diff --git a/recipes-security/scapy/files/run-ptest b/recipes-security/scapy/files/run-ptest
deleted file mode 100644
index 797d8ec..0000000
--- a/recipes-security/scapy/files/run-ptest
+++ /dev/null
@@ -1,4 +0,0 @@
1#!/bin/sh
2UTscapy3 -t regression.uts -f text -l -C \
3 -o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \
4 2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/'
diff --git a/recipes-security/scapy/python3-scapy_2.4.5.bb b/recipes-security/scapy/python3-scapy_2.4.5.bb
deleted file mode 100644
index 8f36520..0000000
--- a/recipes-security/scapy/python3-scapy_2.4.5.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. It is able to forge or decode packets of a wide number of protocols, send them on the wire, capture them, match requests and replies, and much more. It can easily handle most classical tasks like scanning, tracerouting, probing, unit tests, attacks or network discovery (it can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very well at a lot of other specific tasks that most other tools can't handle, like sending invalid frames, injecting your own 802.11 frames, combining technics (VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
3SECTION = "security"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRCREV = "32cd7eb0f620d9adf171c48d55514e8326a538d7"
9SRC_URI = "git://github.com/secdev/scapy.git \
10 file://run-ptest"
11
12S = "${WORKDIR}/git"
13
14UPSTREAM_CHECK_COMMITS = "1"
15
16inherit setuptools3 ptest
17
18do_install_append() {
19 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
20 mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
21}
22
23do_install_ptest() {
24 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
25 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
26}
27
28RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
29 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
30 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"