summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-04-24 20:00:55 +0000
committerArmin Kuster <akuster808@gmail.com>2021-04-26 14:33:01 +0000
commitbaca6133f9c7f77a12dc137fe5b90723fbb4c15b (patch)
treeeed5f630577cc7c7c71aad8b853e0e03c1dcf0b7 /recipes-security
parentf1f517c919bcf50cdbcacc00779e801c17dec3b7 (diff)
downloadmeta-security-baca6133f9c7f77a12dc137fe5b90723fbb4c15b.tar.gz
libseccomp: drop recipe. In core now
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/libseccomp/files/run-ptest4
-rw-r--r--recipes-security/libseccomp/libseccomp_2.5.1.bb47
2 files changed, 0 insertions, 51 deletions
diff --git a/recipes-security/libseccomp/files/run-ptest b/recipes-security/libseccomp/files/run-ptest
deleted file mode 100644
index 54b4a63..0000000
--- a/recipes-security/libseccomp/files/run-ptest
+++ /dev/null
@@ -1,4 +0,0 @@
1#!/bin/sh
2
3cd tests
4./regression -a
diff --git a/recipes-security/libseccomp/libseccomp_2.5.1.bb b/recipes-security/libseccomp/libseccomp_2.5.1.bb
deleted file mode 100644
index 40ac1a8..0000000
--- a/recipes-security/libseccomp/libseccomp_2.5.1.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7DEPENDS += "gperf-native"
8
9SRCREV = "4bf70431a339a2886ab8c82e9a45378f30c6e6c7"
10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \
12 file://run-ptest \
13 "
14
15COMPATIBLE_HOST_riscv32 = "null"
16
17S = "${WORKDIR}/git"
18
19inherit autotools-brokensep pkgconfig ptest
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
23
24DISABLE_STATIC = ""
25
26do_compile_ptest() {
27 oe_runmake -C tests check-build
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 install -d ${D}${PTEST_PATH}/tools
33 for file in $(find tests/* -executable -type f); do
34 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
35 done
36 for file in $(find tests/*.tests -type f); do
37 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
38 done
39 for file in $(find tools/* -executable -type f); do
40 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
41 done
42}
43
44FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
45FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
46
47RDEPENDS_${PN}-ptest = "coreutils bash"