summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-10-07 12:29:21 -0700
committerArmin Kuster <akuster808@gmail.com>2020-10-10 16:21:48 -0700
commitb3f10d2285fa68da210c03aaecb21a739a1afd96 (patch)
tree7e038e8dd4575fc52ad5128def58f51e81f06b13 /recipes-security
parent11dd919372837814c4c499b4034a7df15fc00bfe (diff)
downloadmeta-security-b3f10d2285fa68da210c03aaecb21a739a1afd96.tar.gz
ecryptfs-utils: fix musl build
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb1
-rw-r--r--recipes-security/ecryptfs-utils/files/define_musl_sword_type.patch15
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb b/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
index d8cd06f..4a99b5a 100644
--- a/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
+++ b/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
@@ -16,6 +16,7 @@ SRC_URI = "\
16 file://ecryptfs-utils-CVE-2016-6224.patch \ 16 file://ecryptfs-utils-CVE-2016-6224.patch \
17 file://0001-avoid-race-condition.patch \ 17 file://0001-avoid-race-condition.patch \
18 file://ecryptfs.service \ 18 file://ecryptfs.service \
19 file://define_musl_sword_type.patch \
19 " 20 "
20 21
21SRC_URI[md5sum] = "83513228984f671930752c3518cac6fd" 22SRC_URI[md5sum] = "83513228984f671930752c3518cac6fd"
diff --git a/recipes-security/ecryptfs-utils/files/define_musl_sword_type.patch b/recipes-security/ecryptfs-utils/files/define_musl_sword_type.patch
new file mode 100644
index 0000000..3b29be0
--- /dev/null
+++ b/recipes-security/ecryptfs-utils/files/define_musl_sword_type.patch
@@ -0,0 +1,15 @@
1Index: ecryptfs-utils-111/src/utils/mount.ecryptfs_private.c
2===================================================================
3--- ecryptfs-utils-111.orig/src/utils/mount.ecryptfs_private.c
4+++ ecryptfs-utils-111/src/utils/mount.ecryptfs_private.c
5@@ -45,6 +45,10 @@
6 #include <values.h>
7 #include "../include/ecryptfs.h"
8
9+#ifndef __SWORD_TYPE
10+typedef __typeof__( ((struct statfs *)0)->f_type ) __SWORD_TYPE;
11+#endif
12+
13 /* Perhaps a future version of this program will allow these to be configurable
14 * by the system administrator (or user?) at run time. For now, these are set
15 * to reasonable values to reduce the burden of input validation.