summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-10-16 00:57:27 -0700
committerArmin Kuster <akuster808@gmail.com>2016-11-01 09:03:15 -0700
commit9fb87c6c739c9a7180e7afd8079bbfe937b035ca (patch)
tree4fdfa1feb43adb0d0754cb3383f0db26cc951e0d /recipes-security
parent2431acfc957b98f74bc164a7c7e313dbdd38a267 (diff)
downloadmeta-security-9fb87c6c739c9a7180e7afd8079bbfe937b035ca.tar.gz
images: add a client and server image
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/images/security-client-image.bb17
-rw-r--r--recipes-security/images/security-server-image.bb20
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-security/images/security-client-image.bb b/recipes-security/images/security-client-image.bb
new file mode 100644
index 0000000..1a92479
--- /dev/null
+++ b/recipes-security/images/security-client-image.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "A Client side Security example"
2
3IMAGE_INSTALL = "\
4 packagegroup-base \
5 packagegroup-core-boot \
6 os-release \
7 samhain-client \
8 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "packagegroup-xfce-base", "", d)} \
9 ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
10
11IMAGE_LINGUAS ?= " "
12
13LICENSE = "MIT"
14
15inherit core-image
16
17export IMAGE_BASENAME = "security-client-image"
diff --git a/recipes-security/images/security-server-image.bb b/recipes-security/images/security-server-image.bb
new file mode 100644
index 0000000..502b5c1
--- /dev/null
+++ b/recipes-security/images/security-server-image.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "A Serve side image for Security example "
2
3IMAGE_FEATURES += "ssh-server-openssh"
4
5IMAGE_INSTALL = "\
6 packagegroup-base \
7 packagegroup-core-boot \
8 samhain-server \
9 os-release \
10 ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
11
12IMAGE_LINGUAS ?= " "
13
14LICENSE = "MIT"
15
16inherit core-image
17
18export IMAGE_BASENAME = "security-server-image"
19
20IMAGE_ROOTFS_EXTRA_SPACE = "5242880"