summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-08-20 09:44:05 -0700
committerArmin Kuster <akuster808@gmail.com>2016-10-11 01:39:29 -0700
commit217e06badb146539122732ab0eb27fd17cce09e5 (patch)
tree3c6f39a137d05d4a43272788272b52d781efd5b7 /recipes-security
parentd49df5e37c9f3c72cbfdb95bea771d888969d31d (diff)
downloadmeta-security-217e06badb146539122732ab0eb27fd17cce09e5.tar.gz
clamav: fix gcc 6.x build failure.
./llvm/include/llvm/Support/AlignOf.h:57:24: error: expected unqualified-id before 'alignof' static inline unsigned alignof() { return AlignOf<T>::Alignment; } ^~~~~~~ configure --with-system-llvm --with-llvm-linking=dynamic. define use with meta-oe LLVM3.3 via config option Fix typo for systemd PACKAGECONFIG Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/clamav/clamav_0.99.2.bb22
1 files changed, 18 insertions, 4 deletions
diff --git a/recipes-security/clamav/clamav_0.99.2.bb b/recipes-security/clamav/clamav_0.99.2.bb
index 184d605..a2bab6d 100644
--- a/recipes-security/clamav/clamav_0.99.2.bb
+++ b/recipes-security/clamav/clamav_0.99.2.bb
@@ -8,7 +8,9 @@ DEPENDS = "libtool db libmspack chrpath-replacement-native"
8 8
9LIC_FILES_CHKSUM = "file://COPYING.LGPL;beginline=2;endline=3;md5=4b89c05acc71195e9a06edfa2fa7d092" 9LIC_FILES_CHKSUM = "file://COPYING.LGPL;beginline=2;endline=3;md5=4b89c05acc71195e9a06edfa2fa7d092"
10 10
11SRC_URI = "http://www.clamav.net/downloads/production/${BPN}-${PV}.tar.gz \ 11SRCREV = "5ceae552829ee65c9ecff8ff303b1f2ddfd11576"
12
13SRC_URI = "git://github.com/vrtadmin/clamav-devel;branch=${PV} \
12 file://clamd.conf \ 14 file://clamd.conf \
13 file://freshclam.conf \ 15 file://freshclam.conf \
14 file://volatiles.03_clamav \ 16 file://volatiles.03_clamav \
@@ -17,6 +19,8 @@ SRC_URI = "http://www.clamav.net/downloads/production/${BPN}-${PV}.tar.gz \
17SRC_URI[md5sum] = "61b51a04619aeafd965892a53f86d192" 19SRC_URI[md5sum] = "61b51a04619aeafd965892a53f86d192"
18SRC_URI[sha256sum] = "167bd6a13e05ece326b968fdb539b05c2ffcfef6018a274a10aeda85c2c0027a" 20SRC_URI[sha256sum] = "167bd6a13e05ece326b968fdb539b05c2ffcfef6018a274a10aeda85c2c0027a"
19 21
22S = "${WORKDIR}/git"
23
20LEAD_SONAME = "libclamav.so" 24LEAD_SONAME = "libclamav.so"
21SO_VER = "7.1.1" 25SO_VER = "7.1.1"
22 26
@@ -27,9 +31,20 @@ inherit autotools-brokensep pkgconfig useradd systemd
27UID = "clamav" 31UID = "clamav"
28GID = "clamav" 32GID = "clamav"
29 33
30PACKAGECONFIG ?= "ncurses openssl bz2 zlib " 34# Clamav has a built llvm version 2 but does not build with gcc 6.x,
35# disable the internal one. This is a known issue
36# If you want LLVM support, use meta-oe llvm3.3 to build for GCC 6.X,
37# as defined below
38
39CLAMAV_LLVM ?= "oellvm"
40CLAMAV_LLVM_RELEASE ?= "3.3"
41
42PACKAGECONFIG ?= "ncurses openssl bz2 zlib ${CLAMAV_LLVM}"
31PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" 43PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
32PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 44PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
45
46PACKAGECONFIG[oellvm] = "--with-system-llvm --with-llvm-linking=dynamic --disable-llvm, ,llvm${CLAMAV_LLVM_RELEASE}"
47
33PACKAGECONFIG[pcre] = "--with-pcre=${STAGING_LIBDIR}, --without-pcre, libpcre" 48PACKAGECONFIG[pcre] = "--with-pcre=${STAGING_LIBDIR}, --without-pcre, libpcre"
34PACKAGECONFIG[xml] = "--with-xml=${STAGING_LIBDIR}/.., --with-xml=no, libxml2," 49PACKAGECONFIG[xml] = "--with-xml=${STAGING_LIBDIR}/.., --with-xml=no, libxml2,"
35PACKAGECONFIG[json] = "--with-libjson=${STAGING_LIBDIR}, --without-libjson, json," 50PACKAGECONFIG[json] = "--with-libjson=${STAGING_LIBDIR}, --without-libjson, json,"
@@ -39,8 +54,7 @@ PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr, --without-open
39PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_DIR_HOST}/usr, --without-zlib, zlib, " 54PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_DIR_HOST}/usr, --without-zlib, zlib, "
40PACKAGECONFIG[bz2] = "--with-libbz2-prefix=${STAGING_LIBDIR}/.., --without-libbz2-prefix, " 55PACKAGECONFIG[bz2] = "--with-libbz2-prefix=${STAGING_LIBDIR}/.., --without-libbz2-prefix, "
41PACKAGECONFIG[ncurses] = "--with-libncurses-prefix=${STAGING_LIBDIR}/.., --without-libncurses-prefix, ncurses, " 56PACKAGECONFIG[ncurses] = "--with-libncurses-prefix=${STAGING_LIBDIR}/.., --without-libncurses-prefix, ncurses, "
42 57PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', "
43PACKAGECONFI[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', "
44 58
45EXTRA_OECONF += " --with-user=${UID} --with-group=${GID} \ 59EXTRA_OECONF += " --with-user=${UID} --with-group=${GID} \
46 --without-libcheck-prefix --disable-unrar \ 60 --without-libcheck-prefix --disable-unrar \