summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-07-29 16:31:12 -0700
committerArmin Kuster <akuster808@gmail.com>2021-08-01 08:47:08 -0700
commit11a67b861af74d59ccfd609d6d943e966ccff731 (patch)
treece619cf42798050439a4c04ed471ed293f17ede4 /recipes-security
parentd3a484abf81fc196389480df89cf5c82d13e6381 (diff)
downloadmeta-security-11a67b861af74d59ccfd609d6d943e966ccff731.tar.gz
meta-security: Convert to new override syntax
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/aircrack-ng/aircrack-ng_1.6.bb6
-rw-r--r--recipes-security/bastille/bastille_3.2.1.bb6
-rw-r--r--recipes-security/bastille/files/AccountPermission.pm16
-rw-r--r--recipes-security/bastille/files/FileContent.pm16
-rw-r--r--recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb12
-rw-r--r--recipes-security/fail2ban/python3-fail2ban_0.11.2.bb16
-rw-r--r--recipes-security/fscryptctl/fscryptctl_1.0.0.bb2
-rw-r--r--recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.08.bb2
-rw-r--r--recipes-security/libest/libest_3.2.0.bb6
-rw-r--r--recipes-security/libgssglue/libgssglue_0.4.bb4
-rw-r--r--recipes-security/mfa/python3-privacyidea_3.5.2.bb40
-rw-r--r--recipes-security/ncrack/ncrack_0.7.bb2
-rw-r--r--recipes-security/nikto/nikto_2.1.6.bb2
-rw-r--r--recipes-security/opendnssec/opendnssec_2.1.9.bb4
-rw-r--r--recipes-security/paxctl/paxctl_0.9.bb4
-rw-r--r--recipes-security/redhat-security/redhat-security_1.0.bb2
-rw-r--r--recipes-security/sssd/sssd_2.5.1.bb22
17 files changed, 81 insertions, 81 deletions
diff --git a/recipes-security/aircrack-ng/aircrack-ng_1.6.bb b/recipes-security/aircrack-ng/aircrack-ng_1.6.bb
index 8d3b531..f76f1df 100644
--- a/recipes-security/aircrack-ng/aircrack-ng_1.6.bb
+++ b/recipes-security/aircrack-ng/aircrack-ng_1.6.bb
@@ -29,8 +29,8 @@ do_install () {
29 make DESTDIR=${D} ${OEMAKE_EXTRA} ext_scripts=true install 29 make DESTDIR=${D} ${OEMAKE_EXTRA} ext_scripts=true install
30} 30}
31 31
32FILES_${PN} += "${libdir}/*.so" 32FILES:${PN} += "${libdir}/*.so"
33FILES_SOLIBSDEV = "" 33FILES_SOLIBSDEV = ""
34INSANE_SKIP_${PN} += "dev-so" 34INSANE_SKIP:${PN} += "dev-so"
35 35
36RDEPENDS_${PN} = "libpcap" 36RDEPENDS:${PN} = "libpcap"
diff --git a/recipes-security/bastille/bastille_3.2.1.bb b/recipes-security/bastille/bastille_3.2.1.bb
index 0290cae..72281c5 100644
--- a/recipes-security/bastille/bastille_3.2.1.bb
+++ b/recipes-security/bastille/bastille_3.2.1.bb
@@ -6,8 +6,8 @@ LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" 6LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
7# Bash is needed for set +o privileged (check busybox), might also need ncurses 7# Bash is needed for set +o privileged (check busybox), might also need ncurses
8DEPENDS = "virtual/kernel" 8DEPENDS = "virtual/kernel"
9RDEPENDS_${PN} = "perl bash tcl perl-module-getopt-long perl-module-text-wrap lib-perl perl-module-file-path perl-module-mime-base64 perl-module-file-find perl-module-errno perl-module-file-glob perl-module-tie-hash-namedcapture perl-module-file-copy perl-module-english perl-module-exporter perl-module-cwd libcurses-perl coreutils" 9RDEPENDS:${PN} = "perl bash tcl perl-module-getopt-long perl-module-text-wrap lib-perl perl-module-file-path perl-module-mime-base64 perl-module-file-find perl-module-errno perl-module-file-glob perl-module-tie-hash-namedcapture perl-module-file-copy perl-module-english perl-module-exporter perl-module-cwd libcurses-perl coreutils"
10FILES_${PN} += "/run/lock/subsys/bastille" 10FILES:${PN} += "/run/lock/subsys/bastille"
11 11
12SRC_URI = "http://sourceforge.net/projects/bastille-linux/files/bastille-linux/3.2.1/Bastille-3.2.1.tar.bz2 \ 12SRC_URI = "http://sourceforge.net/projects/bastille-linux/files/bastille-linux/3.2.1/Bastille-3.2.1.tar.bz2 \
13 file://AccountPermission.pm \ 13 file://AccountPermission.pm \
@@ -150,4 +150,4 @@ do_install () {
150 ln -s RevertBastille ${D}${sbindir}/UndoBastille 150 ln -s RevertBastille ${D}${sbindir}/UndoBastille
151} 151}
152 152
153FILES_${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*" 153FILES:${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*"
diff --git a/recipes-security/bastille/files/AccountPermission.pm b/recipes-security/bastille/files/AccountPermission.pm
index cfbaab1..132b30c 100644
--- a/recipes-security/bastille/files/AccountPermission.pm
+++ b/recipes-security/bastille/files/AccountPermission.pm
@@ -16,7 +16,7 @@ B_chgrp
16B_chgrp_link 16B_chgrp_link
17B_userdel 17B_userdel
18B_groupdel 18B_groupdel
19B_remove_user_from_group 19B:remove_user_from_group
20B_check_owner_group 20B_check_owner_group
21B_is_unowned_file 21B_is_unowned_file
22B_is_ungrouped_file 22B_is_ungrouped_file
@@ -28,7 +28,7 @@ B_is_suid
28B_is_sgid 28B_is_sgid
29B_get_user_list 29B_get_user_list
30B_get_group_list 30B_get_group_list
31B_remove_suid 31B:remove_suid
32); 32);
33our @EXPORT = @EXPORT_OK; 33our @EXPORT = @EXPORT_OK;
34 34
@@ -74,7 +74,7 @@ sub B_chmod($$) {
74 if ($new_perm =~ /([ugo]+)([+-]{1})([rwxst]+)/) { 74 if ($new_perm =~ /([ugo]+)([+-]{1})([rwxst]+)/) {
75 $symbolic = 1; 75 $symbolic = 1;
76 $chmod_noun = $1; 76 $chmod_noun = $1;
77 $add_remove = $2; 77 $add:remove = $2;
78 $capability = $3; 78 $capability = $3;
79 } 79 }
80 80
@@ -466,7 +466,7 @@ sub B_chgrp_link($$) {
466# 466#
467# In the future, we may also choose to make a B_lock_account routine. 467# In the future, we may also choose to make a B_lock_account routine.
468# 468#
469# This routine depends on B_remove_user_from_group. 469# This routine depends on B:remove_user_from_group.
470########################################################################### 470###########################################################################
471 471
472sub B_userdel($) { 472sub B_userdel($) {
@@ -506,7 +506,7 @@ sub B_userdel($) {
506 506
507 # 507 #
508 # Next find out what groups the user is in, so we can call 508 # Next find out what groups the user is in, so we can call
509 # B_remove_user_from_group($user,$group) 509 # B:remove_user_from_group($user,$group)
510 # 510 #
511 # TODO: add this to the helper functions for the test suite. 511 # TODO: add this to the helper functions for the test suite.
512 # 512 #
@@ -586,7 +586,7 @@ sub B_groupdel($) {
586 586
587 587
588########################################################################### 588###########################################################################
589# B_remove_user_from_group($user,$group) removes $user from $group, 589# B:remove_user_from_group($user,$group) removes $user from $group,
590# by modifying $group's /etc/group line, pulling the user out. This 590# by modifying $group's /etc/group line, pulling the user out. This
591# uses B_chunk_replace thrice to replace these patterns: 591# uses B_chunk_replace thrice to replace these patterns:
592# 592#
@@ -595,7 +595,7 @@ sub B_groupdel($) {
595# 595#
596########################################################################### 596###########################################################################
597 597
598sub B_remove_user_from_group($$) { 598sub B:remove_user_from_group($$) {
599 599
600 my ($user_to_remove,$group) = @_; 600 my ($user_to_remove,$group) = @_;
601 601
@@ -1022,7 +1022,7 @@ sub B_get_group_list()
1022# 1022#
1023########################################################################### 1023###########################################################################
1024 1024
1025sub B_remove_suid($) { 1025sub B:remove_suid($) {
1026 my $file_expr = $_[0]; 1026 my $file_expr = $_[0];
1027 1027
1028 &B_log("ACTION","Removing SUID bit from \"$file_expr\"."); 1028 &B_log("ACTION","Removing SUID bit from \"$file_expr\".");
diff --git a/recipes-security/bastille/files/FileContent.pm b/recipes-security/bastille/files/FileContent.pm
index 0a5d609..1ef89dd 100644
--- a/recipes-security/bastille/files/FileContent.pm
+++ b/recipes-security/bastille/files/FileContent.pm
@@ -10,8 +10,8 @@ B_blank_file
10B_insert_line_after 10B_insert_line_after
11B_insert_line_before 11B_insert_line_before
12B_insert_line 12B_insert_line
13B_append_line 13B:append_line
14B_prepend_line 14B:prepend_line
15B_replace_line 15B_replace_line
16B_replace_lines 16B_replace_lines
17B_replace_pattern 17B_replace_pattern
@@ -262,7 +262,7 @@ sub B_insert_line($$$$) {
262# 262#
263# Additionally, if $pattern is set equal to "", the line is always appended. 263# Additionally, if $pattern is set equal to "", the line is always appended.
264# 264#
265# B_append_line uses B_open_plus and B_close_plus, so that the file 265# B:append_line uses B_open_plus and B_close_plus, so that the file
266# modified is backed up... 266# modified is backed up...
267# 267#
268# Here's examples of where you might use this: 268# Here's examples of where you might use this:
@@ -273,7 +273,7 @@ sub B_insert_line($$$$) {
273# 273#
274########################################################################### 274###########################################################################
275 275
276sub B_append_line($$$) { 276sub B:append_line($$$) {
277 277
278 my ($filename,$pattern,$line_to_append) = @_; 278 my ($filename,$pattern,$line_to_append) = @_;
279 279
@@ -308,11 +308,11 @@ sub B_append_line($$$) {
308 308
309########################################################################### 309###########################################################################
310# &B_prepend_line ($filename,$pattern,$line_to_prepend) modifies $filename, 310# &B_prepend_line ($filename,$pattern,$line_to_prepend) modifies $filename,
311# pre-pending $line_to_prepend unless one or more lines in the file matches 311# pre-pending $line_to:prepend unless one or more lines in the file matches
312# $pattern. This is an enhancement to the prepend_line_if_no_such_line_exists 312# $pattern. This is an enhancement to the prepend_line_if_no_such_line_exists
313# idea. 313# idea.
314# 314#
315# B_prepend_line uses B_open_plus and B_close_plus, so that the file 315# B:prepend_line uses B_open_plus and B_close_plus, so that the file
316# modified is backed up... 316# modified is backed up...
317# 317#
318# Here's examples of where you might use this: 318# Here's examples of where you might use this:
@@ -322,7 +322,7 @@ sub B_append_line($$$) {
322# 322#
323########################################################################### 323###########################################################################
324 324
325sub B_prepend_line($$$) { 325sub B:prepend_line($$$) {
326 326
327 my ($filename,$pattern,$line_to_prepend) = @_; 327 my ($filename,$pattern,$line_to_prepend) = @_;
328 328
@@ -348,7 +348,7 @@ sub B_prepend_line($$$) {
348 348
349 # Log the action 349 # Log the action
350 &B_log("ACTION","Pre-pended the following line to $filename:\n"); 350 &B_log("ACTION","Pre-pended the following line to $filename:\n");
351 &B_log("ACTION","$line_to_prepend"); 351 &B_log("ACTION","$line_to:prepend");
352 } 352 }
353 else { 353 else {
354 $retval=0; 354 $retval=0;
diff --git a/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb b/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
index 4a99b5a..9aefc32 100644
--- a/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
+++ b/recipes-security/ecryptfs-utils/ecryptfs-utils_111.bb
@@ -25,7 +25,7 @@ SRC_URI[sha256sum] = "112cb3e37e81a1ecd8e39516725dec0ce55c5f3df6284e0f4cc0f11875
25inherit autotools pkgconfig systemd 25inherit autotools pkgconfig systemd
26 26
27SYSTEMD_PACKAGES = "${PN}" 27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "ecryptfs.service" 28SYSTEMD_SERVICE:${PN} = "ecryptfs.service"
29 29
30EXTRA_OECONF = "\ 30EXTRA_OECONF = "\
31 --libdir=${base_libdir} \ 31 --libdir=${base_libdir} \
@@ -41,7 +41,7 @@ PACKAGECONFIG ??= "nss \
41PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss," 41PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss,"
42PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam," 42PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam,"
43 43
44do_configure_prepend() { 44do_configure:prepend() {
45 export NSS_CFLAGS="-I${STAGING_INCDIR}/nspr -I${STAGING_INCDIR}/nss3" 45 export NSS_CFLAGS="-I${STAGING_INCDIR}/nspr -I${STAGING_INCDIR}/nss3"
46 export NSS_LIBS="-L${STAGING_BASELIBDIR} -lssl3 -lsmime3 -lnss3 -lsoftokn3 -lnssutil3" 46 export NSS_LIBS="-L${STAGING_BASELIBDIR} -lssl3 -lsmime3 -lnss3 -lsoftokn3 -lnssutil3"
47 export KEYUTILS_CFLAGS="-I${STAGING_INCDIR}" 47 export KEYUTILS_CFLAGS="-I${STAGING_INCDIR}"
@@ -49,7 +49,7 @@ do_configure_prepend() {
49 sed -i -e "s;rootsbindir=\"/sbin\";rootsbindir=\"\${base_sbindir}\";g" ${S}/configure.ac 49 sed -i -e "s;rootsbindir=\"/sbin\";rootsbindir=\"\${base_sbindir}\";g" ${S}/configure.ac
50} 50}
51 51
52do_install_append() { 52do_install:append() {
53 chmod 4755 ${D}${base_sbindir}/mount.ecryptfs_private 53 chmod 4755 ${D}${base_sbindir}/mount.ecryptfs_private
54 # ${base_libdir} is identical to ${libdir} when usrmerge enabled 54 # ${base_libdir} is identical to ${libdir} when usrmerge enabled
55 if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then 55 if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
@@ -64,7 +64,7 @@ do_install_append() {
64 fi 64 fi
65} 65}
66 66
67FILES_${PN} += "${base_libdir}/security/* ${base_libdir}/ecryptfs/*" 67FILES:${PN} += "${base_libdir}/security/* ${base_libdir}/ecryptfs/*"
68 68
69RDEPENDS_${PN} += "cryptsetup" 69RDEPENDS:${PN} += "cryptsetup"
70RRECOMMENDS_${PN} = "gettext-runtime" 70RRECOMMENDS:${PN} = "gettext-runtime"
diff --git a/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb b/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
index b480c76..ed75a0e 100644
--- a/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
+++ b/recipes-security/fail2ban/python3-fail2ban_0.11.2.bb
@@ -20,34 +20,34 @@ inherit update-rc.d ptest setuptools3
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23do_compile_prepend () { 23do_compile:prepend () {
24 cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py 24 cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py
25 cd ${S} 25 cd ${S}
26 ./fail2ban-2to3 26 ./fail2ban-2to3
27} 27}
28 28
29do_install_append () { 29do_install:append () {
30 install -d ${D}/${sysconfdir}/fail2ban 30 install -d ${D}/${sysconfdir}/fail2ban
31 install -d ${D}/${sysconfdir}/init.d 31 install -d ${D}/${sysconfdir}/init.d
32 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server 32 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
33 chown -R root:root ${D}/${bindir} 33 chown -R root:root ${D}/${bindir}
34} 34}
35 35
36do_install_ptest_append () { 36do_install_ptest:append () {
37 install -d ${D}${PTEST_PATH} 37 install -d ${D}${PTEST_PATH}
38 install -d ${D}${PTEST_PATH}/bin 38 install -d ${D}${PTEST_PATH}/bin
39 sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest 39 sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest
40 install -D ${S}/bin/* ${D}${PTEST_PATH}/bin 40 install -D ${S}/bin/* ${D}${PTEST_PATH}/bin
41} 41}
42 42
43FILES_${PN} += "/run" 43FILES:${PN} += "/run"
44 44
45INITSCRIPT_PACKAGES = "${PN}" 45INITSCRIPT_PACKAGES = "${PN}"
46INITSCRIPT_NAME = "fail2ban-server" 46INITSCRIPT_NAME = "fail2ban-server"
47INITSCRIPT_PARAMS = "defaults 25" 47INITSCRIPT_PARAMS = "defaults 25"
48 48
49INSANE_SKIP_${PN}_append = "already-stripped" 49INSANE_SKIP:${PN}:append = "already-stripped"
50 50
51RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog} iptables sqlite3 python3-core python3-pyinotify" 51RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog} iptables sqlite3 python3-core python3-pyinotify"
52RDEPENDS_${PN} += " python3-logging python3-fcntl python3-json" 52RDEPENDS:${PN} += " python3-logging python3-fcntl python3-json"
53RDEPENDS_${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban" 53RDEPENDS:${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban"
diff --git a/recipes-security/fscryptctl/fscryptctl_1.0.0.bb b/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
index df76a3d..26f549b 100644
--- a/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
+++ b/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
@@ -18,7 +18,7 @@ do_install() {
18 oe_runmake DESTDIR=${D} PREFIX=/usr install 18 oe_runmake DESTDIR=${D} PREFIX=/usr install
19} 19}
20 20
21RRECOMMENDS_${PN} += "\ 21RRECOMMENDS:${PN} += "\
22 keyutils \ 22 keyutils \
23 kernel-module-cbc \ 23 kernel-module-cbc \
24 kernel-module-cts \ 24 kernel-module-cts \
diff --git a/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.08.bb b/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.08.bb
index f9ca092..4ab8374 100644
--- a/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.08.bb
+++ b/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.08.bb
@@ -18,6 +18,6 @@ REQUIRED_DISTRO_FEATURES = "pam"
18EXTRA_OECONF = "--libdir=${base_libdir}" 18EXTRA_OECONF = "--libdir=${base_libdir}"
19 19
20PACKAGES += "pam-google-authenticator" 20PACKAGES += "pam-google-authenticator"
21FILES_pam-google-authenticator = "${base_libdir}/security/pam_google_authenticator.so" 21FILES:pam-google-authenticator = "${base_libdir}/security/pam_google_authenticator.so"
22 22
23RDEPNEDS_pam-google-authenticator = "libpam" 23RDEPNEDS_pam-google-authenticator = "libpam"
diff --git a/recipes-security/libest/libest_3.2.0.bb b/recipes-security/libest/libest_3.2.0.bb
index 5b6dc99..fda2df4 100644
--- a/recipes-security/libest/libest_3.2.0.bb
+++ b/recipes-security/libest/libest_3.2.0.bb
@@ -11,17 +11,17 @@ SRC_URI = "git://github.com/cisco/libest;branch=main"
11DEPENDS = "openssl" 11DEPENDS = "openssl"
12 12
13#fatal error: execinfo.h: No such file or directory 13#fatal error: execinfo.h: No such file or directory
14DEPENDS_append_libc-musl = " libexecinfo" 14DEPENDS:append:libc-musl = " libexecinfo"
15 15
16inherit autotools-brokensep 16inherit autotools-brokensep
17 17
18EXTRA_OECONF = "--disable-pthreads --with-ssl-dir=${STAGING_LIBDIR}" 18EXTRA_OECONF = "--disable-pthreads --with-ssl-dir=${STAGING_LIBDIR}"
19 19
20CFLAGS += "-fcommon" 20CFLAGS += "-fcommon"
21LDFLAGS_append_libc-musl = " -lexecinfo" 21LDFLAGS:append:libc-musl = " -lexecinfo"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25PACKAGES = "${PN} ${PN}-dbg ${PN}-dev" 25PACKAGES = "${PN} ${PN}-dbg ${PN}-dev"
26 26
27FILES_${PN} = "${bindir}/* ${libdir}/libest-3.2.0p.so" 27FILES:${PN} = "${bindir}/* ${libdir}/libest-3.2.0p.so"
diff --git a/recipes-security/libgssglue/libgssglue_0.4.bb b/recipes-security/libgssglue/libgssglue_0.4.bb
index 88c58ed..3085ee6 100644
--- a/recipes-security/libgssglue/libgssglue_0.4.bb
+++ b/recipes-security/libgssglue/libgssglue_0.4.bb
@@ -33,11 +33,11 @@ SRC_URI[md5sum] = "5ce81940965fa68c7635c42dcafcddfe"
33SRC_URI[sha256sum] = "bb47b2de78409f461811d0db8595c66e6631a9879c3621a35e4434b104ee52f5" 33SRC_URI[sha256sum] = "bb47b2de78409f461811d0db8595c66e6631a9879c3621a35e4434b104ee52f5"
34 34
35# gssglue can use krb5, spkm3... as gssapi library, configurable 35# gssglue can use krb5, spkm3... as gssapi library, configurable
36RRECOMMENDS_${PN} += "krb5" 36RRECOMMENDS:${PN} += "krb5"
37 37
38inherit autotools 38inherit autotools
39 39
40do_install_append() { 40do_install:append() {
41 # install some docs 41 # install some docs
42 install -d -m 0755 ${D}${docdir}/${BPN} 42 install -d -m 0755 ${D}${docdir}/${BPN}
43 install -m 0644 ${S}/AUTHORS ${S}/ChangeLog ${S}/NEWS ${S}/README ${D}${docdir}/${BPN} 43 install -m 0644 ${S}/AUTHORS ${S}/ChangeLog ${S}/NEWS ${S}/README ${D}${docdir}/${BPN}
diff --git a/recipes-security/mfa/python3-privacyidea_3.5.2.bb b/recipes-security/mfa/python3-privacyidea_3.5.2.bb
index cd0acf8..a4ab59d 100644
--- a/recipes-security/mfa/python3-privacyidea_3.5.2.bb
+++ b/recipes-security/mfa/python3-privacyidea_3.5.2.bb
@@ -10,31 +10,31 @@ SRC_URI[sha256sum] = "26aeb0d353af1f212c4df476202516953c20f7f31566cfe0b67cbb553d
10 10
11inherit pypi setuptools3 11inherit pypi setuptools3
12 12
13do_install_append () { 13do_install:append () {
14 #install ${D}/var/log/privacyidea 14 #install ${D}/var/log/privacyidea
15 15
16 rm -fr ${D}${libdir}/${PYTHON_DIR}/site-packages/tests 16 rm -fr ${D}${libdir}/${PYTHON_DIR}/site-packages/tests
17} 17}
18 18
19USERADD_PACKAGES = "${PN}" 19USERADD_PACKAGES = "${PN}"
20GROUPADD_PARAM_${PN} = "--system privacyidea" 20GROUPADD_PARAM:${PN} = "--system privacyidea"
21USERADD_PARAM_${PN} = "--system -g privacyidea -o -r -d /opt/${BPN} \ 21USERADD_PARAM:${PN} = "--system -g privacyidea -o -r -d /opt/${BPN} \
22 --shell /bin/false privacyidea" 22 --shell /bin/false privacyidea"
23 23
24FILES_${PN} += " ${datadir}/etc/privacyidea/* ${datadir}/lib/privacyidea/*" 24FILES:${PN} += " ${datadir}/etc/privacyidea/* ${datadir}/lib/privacyidea/*"
25 25
26RDEPENDS_${PN} += " bash perl freeradius-mysql freeradius-utils" 26RDEPENDS:${PN} += " bash perl freeradius-mysql freeradius-utils"
27 27
28RDEPENDS_${PN} += "python3 python3-alembic python3-babel python3-backports-functools-lru-cache python3-bcrypt" 28RDEPENDS:${PN} += "python3 python3-alembic python3-babel python3-backports-functools-lru-cache python3-bcrypt"
29RDEPENDS_${PN} += "python3-beautifulsoup4 python3-cbor2 python3-certifi python3-cffi python3-chardet" 29RDEPENDS:${PN} += "python3-beautifulsoup4 python3-cbor2 python3-certifi python3-cffi python3-chardet"
30RDEPENDS_${PN} += "python3-click python3-configobj python3-croniter python3-cryptography python3-defusedxml" 30RDEPENDS:${PN} += "python3-click python3-configobj python3-croniter python3-cryptography python3-defusedxml"
31RDEPENDS_${PN} += "python3-ecdsa python3-flask python3-flask-babel python3-flask-migrate" 31RDEPENDS:${PN} += "python3-ecdsa python3-flask python3-flask-babel python3-flask-migrate"
32RDEPENDS_${PN} += "python3-flask-script python3-flask-sqlalchemy python3-flask-versioned" 32RDEPENDS:${PN} += "python3-flask-script python3-flask-sqlalchemy python3-flask-versioned"
33RDEPENDS_${PN} += "python3-future python3-httplib2 python3-huey python3-idna python3-ipaddress" 33RDEPENDS:${PN} += "python3-future python3-httplib2 python3-huey python3-idna python3-ipaddress"
34RDEPENDS_${PN} += "python3-itsdangerous python3-jinja2 python3-ldap python3-lxml python3-mako" 34RDEPENDS:${PN} += "python3-itsdangerous python3-jinja2 python3-ldap python3-lxml python3-mako"
35RDEPENDS_${PN} += "python3-markupsafe python3-netaddr python3-oauth2client python3-passlib python3-pillow" 35RDEPENDS:${PN} += "python3-markupsafe python3-netaddr python3-oauth2client python3-passlib python3-pillow"
36RDEPENDS_${PN} += "python3-pyasn1 python3-pyasn1-modules python3-pycparser python3-pyjwt python3-pymysql" 36RDEPENDS:${PN} += "python3-pyasn1 python3-pyasn1-modules python3-pycparser python3-pyjwt python3-pymysql"
37RDEPENDS_${PN} += "python3-pyopenssl python3-pyrad python3-dateutil python3-editor python3-gnupg" 37RDEPENDS:${PN} += "python3-pyopenssl python3-pyrad python3-dateutil python3-editor python3-gnupg"
38RDEPENDS_${PN} += "python3-pytz python3-pyyaml python3-qrcode python3-redis python3-requests python3-rsa" 38RDEPENDS:${PN} += "python3-pytz python3-pyyaml python3-qrcode python3-redis python3-requests python3-rsa"
39RDEPENDS_${PN} += "python3-six python3-smpplib python3-soupsieve python3-soupsieve " 39RDEPENDS:${PN} += "python3-six python3-smpplib python3-soupsieve python3-soupsieve "
40RDEPENDS_${PN} += "python3-sqlalchemy python3-sqlsoup python3-urllib3 python3-werkzeug" 40RDEPENDS:${PN} += "python3-sqlalchemy python3-sqlsoup python3-urllib3 python3-werkzeug"
diff --git a/recipes-security/ncrack/ncrack_0.7.bb b/recipes-security/ncrack/ncrack_0.7.bb
index ba26965..8b221e5 100644
--- a/recipes-security/ncrack/ncrack_0.7.bb
+++ b/recipes-security/ncrack/ncrack_0.7.bb
@@ -15,4 +15,4 @@ inherit autotools-brokensep
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18INSANE_SKIP_${PN} = "already-stripped" 18INSANE_SKIP:${PN} = "already-stripped"
diff --git a/recipes-security/nikto/nikto_2.1.6.bb b/recipes-security/nikto/nikto_2.1.6.bb
index 615cc30..242f3ac 100644
--- a/recipes-security/nikto/nikto_2.1.6.bb
+++ b/recipes-security/nikto/nikto_2.1.6.bb
@@ -111,7 +111,7 @@ do_install() {
111 install -m 0644 docs/nikto_manual.html ${D}${datadir}/doc/nikto 111 install -m 0644 docs/nikto_manual.html ${D}${datadir}/doc/nikto
112} 112}
113 113
114RDEPENDS_${PN} = "perl libnet-ssleay-perl libwhisker2-perl \ 114RDEPENDS:${PN} = "perl libnet-ssleay-perl libwhisker2-perl \
115 perl-module-getopt-long perl-module-time-local \ 115 perl-module-getopt-long perl-module-time-local \
116 perl-module-io-socket perl-module-overloading \ 116 perl-module-io-socket perl-module-overloading \
117 perl-module-base perl-module-b perl-module-bytes" 117 perl-module-base perl-module-b perl-module-bytes"
diff --git a/recipes-security/opendnssec/opendnssec_2.1.9.bb b/recipes-security/opendnssec/opendnssec_2.1.9.bb
index 2b79609..8e36812 100644
--- a/recipes-security/opendnssec/opendnssec_2.1.9.bb
+++ b/recipes-security/opendnssec/opendnssec_2.1.9.bb
@@ -27,8 +27,8 @@ PACKAGECONFIG[mysql] = "--with-mysql=yes, , mariadb, mariadb"
27PACKAGECONFIG[readline] = "--with-readline, --without-readline, readline" 27PACKAGECONFIG[readline] = "--with-readline, --without-readline, readline"
28PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind" 28PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind"
29 29
30do_install_append () { 30do_install:append () {
31 rm -rf ${D}${localstatedir}/run 31 rm -rf ${D}${localstatedir}/run
32} 32}
33 33
34RDEPENDS_${PN} = "softhsm" 34RDEPENDS:${PN} = "softhsm"
diff --git a/recipes-security/paxctl/paxctl_0.9.bb b/recipes-security/paxctl/paxctl_0.9.bb
index 3c04141..55a0dca 100644
--- a/recipes-security/paxctl/paxctl_0.9.bb
+++ b/recipes-security/paxctl/paxctl_0.9.bb
@@ -24,7 +24,7 @@ do_install() {
24# install: cannot change ownership of '.../sbin/paxctl': \ 24# install: cannot change ownership of '.../sbin/paxctl': \
25# Operation not permitted 25# Operation not permitted
26# Drop '--owner 0 --group 0' to fix the issue. 26# Drop '--owner 0 --group 0' to fix the issue.
27do_install_class-native() { 27do_install:class-native() {
28 local PROG=paxctl 28 local PROG=paxctl
29 install -d ${D}${base_sbindir} 29 install -d ${D}${base_sbindir}
30 install -d ${D}${mandir}/man1 30 install -d ${D}${mandir}/man1
@@ -33,6 +33,6 @@ do_install_class-native() {
33} 33}
34 34
35# Avoid QA Issue: No GNU_HASH in the elf binary 35# Avoid QA Issue: No GNU_HASH in the elf binary
36INSANE_SKIP_${PN} = "ldflags" 36INSANE_SKIP:${PN} = "ldflags"
37 37
38BBCLASSEXTEND = "native" 38BBCLASSEXTEND = "native"
diff --git a/recipes-security/redhat-security/redhat-security_1.0.bb b/recipes-security/redhat-security/redhat-security_1.0.bb
index 0d70dc6..d6d4cea 100644
--- a/recipes-security/redhat-security/redhat-security_1.0.bb
+++ b/recipes-security/redhat-security/redhat-security_1.0.bb
@@ -37,4 +37,4 @@ do_install() {
37 install -m 0755 ${WORKDIR}/selinux-ls-unconfined.sh ${D}${bindir} 37 install -m 0755 ${WORKDIR}/selinux-ls-unconfined.sh ${D}${bindir}
38} 38}
39 39
40RDEPENDS_${PN} = "file libcap-ng procps findutils" 40RDEPENDS:${PN} = "file libcap-ng procps findutils"
diff --git a/recipes-security/sssd/sssd_2.5.1.bb b/recipes-security/sssd/sssd_2.5.1.bb
index 9205843..1c77480 100644
--- a/recipes-security/sssd/sssd_2.5.1.bb
+++ b/recipes-security/sssd/sssd_2.5.1.bb
@@ -6,9 +6,9 @@ LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7 7
8DEPENDS = "acl attr openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive" 8DEPENDS = "acl attr openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive"
9DEPENDS_append = " libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent bind p11-kit" 9DEPENDS:append = " libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent bind p11-kit"
10 10
11DEPENDS_append_libc-musl = " musl-nscd" 11DEPENDS:append:libc-musl = " musl-nscd"
12 12
13# If no crypto has been selected, default to DEPEND on nss, since that's what 13# If no crypto has been selected, default to DEPEND on nss, since that's what
14# sssd will pick if no active choice is made during configure 14# sssd will pick if no active choice is made during configure
@@ -69,7 +69,7 @@ EXTRA_OECONF += " \
69 --with-pid-path=/run \ 69 --with-pid-path=/run \
70" 70"
71 71
72do_configure_prepend() { 72do_configure:prepend() {
73 mkdir -p ${AUTOTOOLS_AUXDIR}/build 73 mkdir -p ${AUTOTOOLS_AUXDIR}/build
74 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/ 74 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/
75 75
@@ -77,7 +77,7 @@ do_configure_prepend() {
77 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4 77 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4
78} 78}
79 79
80do_compile_prepend () { 80do_compile:prepend () {
81 echo '#define NSUPDATE_PATH "${bindir}"' >> ${B}/config.h 81 echo '#define NSUPDATE_PATH "${bindir}"' >> ${B}/config.h
82} 82}
83do_install () { 83do_install () {
@@ -98,18 +98,18 @@ do_install () {
98 rm -f ${D}${systemd_system_unitdir}/sssd-secrets.* 98 rm -f ${D}${systemd_system_unitdir}/sssd-secrets.*
99} 99}
100 100
101pkg_postinst_ontarget_${PN} () { 101pkg_postinst_ontarget:${PN} () {
102if [ -e /etc/init.d/populate-volatile.sh ] ; then 102if [ -e /etc/init.d/populate-volatile.sh ] ; then
103 ${sysconfdir}/init.d/populate-volatile.sh update 103 ${sysconfdir}/init.d/populate-volatile.sh update
104fi 104fi
105 chown ${SSSD_UID}:${SSSD_GID} ${sysconfdir}/${BPN}/${BPN}.conf 105 chown ${SSSD_UID}:${SSSD_GID} ${sysconfdir}/${BPN}/${BPN}.conf
106} 106}
107 107
108CONFFILES_${PN} = "${sysconfdir}/${BPN}/${BPN}.conf" 108CONFFILES:${PN} = "${sysconfdir}/${BPN}/${BPN}.conf"
109 109
110INITSCRIPT_NAME = "sssd" 110INITSCRIPT_NAME = "sssd"
111INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ." 111INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
112SYSTEMD_SERVICE_${PN} = " \ 112SYSTEMD_SERVICE:${PN} = " \
113 ${@bb.utils.contains('PACKAGECONFIG', 'autofs', 'sssd-autofs.service sssd-autofs.socket', '', d)} \ 113 ${@bb.utils.contains('PACKAGECONFIG', 'autofs', 'sssd-autofs.service sssd-autofs.socket', '', d)} \
114 ${@bb.utils.contains('PACKAGECONFIG', 'curl', 'sssd-kcm.service sssd-kcm.socket', '', d)} \ 114 ${@bb.utils.contains('PACKAGECONFIG', 'curl', 'sssd-kcm.service sssd-kcm.socket', '', d)} \
115 ${@bb.utils.contains('PACKAGECONFIG', 'infopipe', 'sssd-ifp.service ', '', d)} \ 115 ${@bb.utils.contains('PACKAGECONFIG', 'infopipe', 'sssd-ifp.service ', '', d)} \
@@ -124,10 +124,10 @@ SYSTEMD_SERVICE_${PN} = " \
124" 124"
125SYSTEMD_AUTO_ENABLE = "disable" 125SYSTEMD_AUTO_ENABLE = "disable"
126 126
127FILES_${PN} += "${libdir} ${datadir} ${base_libdir}/security/pam_sss*.so" 127FILES:${PN} += "${libdir} ${datadir} ${base_libdir}/security/pam_sss*.so"
128FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la" 128FILES:${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la"
129 129
130# The package contains symlinks that trip up insane 130# The package contains symlinks that trip up insane
131INSANE_SKIP_${PN} = "dev-so" 131INSANE_SKIP:${PN} = "dev-so"
132 132
133RDEPENDS_${PN} = "bind bind-utils dbus libldb libpam" 133RDEPENDS:${PN} = "bind bind-utils dbus libldb libpam"