summaryrefslogtreecommitdiffstats
path: root/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-08-31 15:10:11 +0800
committerArmin Kuster <akuster808@gmail.com>2018-09-01 10:34:02 -0700
commit9449ba75eabdba9f8cc9703c273792b70263ff9a (patch)
tree1ed0792affda1aa6749050bcaeb399c80583ab64 /recipes-security/xmlsec1/xmlsec1_1.2.25.bb
parent108cb736d9f37e534944b3d18bbc48ecaeae484a (diff)
downloadmeta-security-9449ba75eabdba9f8cc9703c273792b70263ff9a.tar.gz
xmlsec1: upgrade 1.2.25 -> 1.2.26
Drop patch xmlsec1-fix-a-typo-in-examples-verify3.c.patch since the issue had been fixed upstream. Rebase patch change-finding-path-of-nss.patch Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/xmlsec1/xmlsec1_1.2.25.bb')
-rw-r--r--recipes-security/xmlsec1/xmlsec1_1.2.25.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/recipes-security/xmlsec1/xmlsec1_1.2.25.bb b/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
deleted file mode 100644
index 341ca08..0000000
--- a/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1SUMMARY = "XML Security Library is a C library based on LibXML2"
2DESCRIPTION = "\
3 XML Security Library is a C library based on \
4 LibXML2 and OpenSSL. The library was created with a goal to support major \
5 XML security standards "XML Digital Signature" and "XML Encryption". \
6 "
7HOMEPAGE = "http://www.aleksey.com/xmlsec/"
8DEPENDS = "libtool libxml2 libxslt openssl zlib libgcrypt gnutls nss nspr libgpg-error"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=352791d62092ea8104f085042de7f4d0"
12
13SECTION = "libs"
14
15SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \
16 file://fix-ltmain.sh.patch \
17 file://change-finding-path-of-nss.patch \
18 file://makefile-ptest.patch \
19 file://xmlsec1-examples-allow-build-in-separate-dir.patch \
20 file://xmlsec1-fix-a-typo-in-examples-verify3.c.patch \
21 file://run-ptest \
22 "
23
24SRC_URI[md5sum] = "dbbef1efc69e61bc4629650205a05b41"
25SRC_URI[sha256sum] = "967ca83edf25ccb5b48a3c4a09ad3405a63365576503bf34290a42de1b92fcd2"
26
27inherit autotools-brokensep ptest pkgconfig
28
29CFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
30CPPFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
31
32EXTRA_OECONF = "\
33 --with-nss=${STAGING_LIBDIR}/../.. --with-nspr=${STAGING_LIBDIR}/../.. \
34 "
35
36FILES_${PN}-dev += "${libdir}/xmlsec1Conf.sh"
37FILES_${PN}-dbg += "${PTEST_PATH}/.debug/*"
38
39RDEPENDS_${PN}-ptest += "${PN}-dev"
40INSANE_SKIP_${PN}-ptest += "dev-deps"
41
42PTEST_EXTRA_ARGS = "top_srcdir=${S} top_builddir=${B}"
43
44do_compile_ptest () {
45 oe_runmake -C ${S}/examples ${PTEST_EXTRA_ARGS} all
46}
47
48do_install_append() {
49 for i in ${bindir}/xmlsec1-config ${libdir}/xmlsec1Conf.sh \
50 ${libdir}/pkgconfig/xmlsec1-openssl.pc; do
51 sed -i -e "s@${RECIPE_SYSROOT}@@g" ${D}$i
52 done
53}
54
55do_install_ptest () {
56 oe_runmake -C ${S}/examples DESTDIR=${D}${PTEST_PATH} ${PTEST_EXTRA_ARGS} install-ptest
57}