summaryrefslogtreecommitdiffstats
path: root/recipes-security/sssd
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-04-14 08:22:18 -0700
committerArmin Kuster <akuster808@gmail.com>2016-04-23 08:03:42 -0700
commitae256956d8037532c6d7ed3f752c2707053687a5 (patch)
treefc3d9156ade262dc31b7270c558483852d4c19b0 /recipes-security/sssd
parentb27f894dc9153dcd1af9225231ac725ff005fcf3 (diff)
downloadmeta-security-ae256956d8037532c6d7ed3f752c2707053687a5.tar.gz
sssd: add new package
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/sssd')
-rw-r--r--recipes-security/sssd/files/sssd.conf8
-rw-r--r--recipes-security/sssd/sssd_1.13.3.bb72
2 files changed, 80 insertions, 0 deletions
diff --git a/recipes-security/sssd/files/sssd.conf b/recipes-security/sssd/files/sssd.conf
new file mode 100644
index 0000000..1709a7a
--- /dev/null
+++ b/recipes-security/sssd/files/sssd.conf
@@ -0,0 +1,8 @@
1[sssd]
2services = nss, pam
3config_file_version = 2
4
5[nss]
6
7[pam]
8
diff --git a/recipes-security/sssd/sssd_1.13.3.bb b/recipes-security/sssd/sssd_1.13.3.bb
new file mode 100644
index 0000000..d538af3
--- /dev/null
+++ b/recipes-security/sssd/sssd_1.13.3.bb
@@ -0,0 +1,72 @@
1SUMMARY = "system security services daemon"
2DESCRIPTION = "SSSD is a system security services daemon"
3HOMEPAGE = "https://fedorahosted.org/sssd/"
4SECTION = "base"
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5"
9DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent"
10
11SRCREV = "70862d81a9a1228ad27ad35c9e99cc24b77940c6"
12
13PV = "1.13.3+git${SRCPV}"
14
15SRC_URI = "git://git.fedorahosted.org/git/sssd.git;branch='sssd-1-13' \
16 file://sssd.conf "
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig gettext update-rc.d python-dir
21
22CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
23 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
24 "
25
26PACKAGECONFIG ?="nss"
27PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
28
29PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, "
30PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba"
31PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux"
32PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no"
33PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings"
34PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
35PACKAGECONFIG[nss] = "--with-crypto=nss, , nss"
36PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto"
37PACKAGECONFIG[nscd] = "--with-nscd=, --without-nscd, "
38PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl"
39PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir="
40PACKAGECONFIG[systemd] = "--with-systemdconfdir=${systemd_unitdir}/system/, --with-systemdconfdir="
41
42EXTRA_OECONF += "--disable-rpath --disable-config-lib --disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab"
43
44do_configure_prepend() {
45 mkdir -p ${AUTOTOOLS_AUXDIR}/build
46 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/
47
48 # libresove has host path, remove it
49 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4
50}
51
52do_install () {
53 oe_runmake install DESTDIR="${D}"
54 rmdir --ignore-fail-on-non-empty "${D}/${bindir}"
55 install -d ${D}/${sysconfdir}/${BPN}
56 install -m 600 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}
57}
58
59CONFFILES_${PN} = "${sysconfdir}/${BPN}/${BPN}.conf"
60
61INITSCRIPT_NAME = "sssd"
62INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
63SYSTEMD_SERVICE_${PN} = "${BPN}.service"
64SYSTEMD_AUTO_ENABLE = "disable"
65
66FILES_${PN} += "${libdir} ${datadir} /run ${libdir}/*.so* "
67FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la"
68
69# The package contains symlinks that trip up insane
70INSANE_SKIP_${PN} = "dev-so"
71
72RDEPENDS_${PN} += "bind dbus"