summaryrefslogtreecommitdiffstats
path: root/recipes-security/nmap/nmap_7.31.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-10-31 11:02:43 -0700
committerArmin Kuster <akuster808@gmail.com>2016-11-10 13:34:46 -0800
commit2c5b79c3e8eec6a9bf96d5a6ba2e3f8a2ca8e8a8 (patch)
tree904da169b8e188a57898452c000005e4918b5d43 /recipes-security/nmap/nmap_7.31.bb
parentd322b32a4ef7a19abae053edddf2dee9ae9d8e0a (diff)
downloadmeta-security-2c5b79c3e8eec6a9bf96d5a6ba2e3f8a2ca8e8a8.tar.gz
nmap: Upgrade package to 7.31
LIC_FILES_CHKSUM change do to yr going from 2015 to 2016 in file. Added "no update" config option. Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/nmap/nmap_7.31.bb')
-rw-r--r--recipes-security/nmap/nmap_7.31.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-security/nmap/nmap_7.31.bb b/recipes-security/nmap/nmap_7.31.bb
new file mode 100644
index 0000000..c50b240
--- /dev/null
+++ b/recipes-security/nmap/nmap_7.31.bb
@@ -0,0 +1,51 @@
1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=bce7593e567a4b12f60c6a04f9b8c1e5"
7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2"
9
10SRC_URI[md5sum] = "f2f6660142a777862342a58cc54258ea"
11SRC_URI[sha256sum] = "cb9f4e03c0771c709cd47dc8fc6ac3421eadbdd313f0aae52276829290583842"
12
13inherit autotools-brokensep pkgconfig python-dir distro_features_check
14
15PACKAGECONFIG ?= "ncat nping ndiff pcap"
16PACKAGECONFIG += " ${@bb.utils.contains('IMAGE_FEATURES', 'x11-base', 'zenmap', '', d)}"
17
18PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
19PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre"
20PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
21
22#disable/enable packages
23PACKAGECONFIG[nping] = ",--without-nping,"
24PACKAGECONFIG[ncat] = ",--without-ncat,"
25PACKAGECONFIG[ndiff] = ",--without-ndiff,"
26PACKAGECONFIG[update] = ",--without-nmap-update,"
27
28#Add gui
29PACKAGECONFIG[zenmap] = "--with-zenmap, --without-zenmap, gtk+ python-core python-codecs python-io python-logging python-unittest python-xml python-netclient python-doctest python-subprocess python-pygtk, python-core python-codecs python-io python-logging python-netclient python-xml python-unittest python-doctest python-subprocess python-pygtk gtk+"
30
31EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
32
33do_configure() {
34 # strip hard coded python2#
35 sed -i -e 's=python2\.*=python=g' ${S}/configure.ac
36 sed -i -e 's=python2\.*=python=g' ${S}/configure
37 autoconf
38 oe_runconf
39}
40
41do_install_append () {
42 # remove python dir, its not used or installed
43 rm -fr ${D}/${libdir}
44}
45
46PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'zenmap', '${PN}-zenmap', '', d)}"
47
48FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${PYTHON_SITEPACKAGES_DIR}/radialnet/* ${PYTHON_SITEPACKAGES_DIR}/zenmap*", "", d)}"
49
50RDEPENDS_${PN} = "python"
51RDEPENDS_${PN}-zenmap = "nmap"