summaryrefslogtreecommitdiffstats
path: root/recipes-security/keynote/keynote_2.3.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-07-26 16:11:44 +0800
committerArmin Kuster <akuster808@gmail.com>2017-08-13 08:26:14 -0700
commit91467868aa1c697d71bbc38660ed34a44f04d306 (patch)
treeda6b3eaea367e3f6ea65f5171024e0ebb531087c /recipes-security/keynote/keynote_2.3.bb
parent16a1725766baf90b312ebba631d6979a6766dc59 (diff)
downloadmeta-security-91467868aa1c697d71bbc38660ed34a44f04d306.tar.gz
keynote: add new recipe
KeyNote is a simple and flexible trust-management system designed to work well for a variety of large- and small- scale Internet-based applications Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/keynote/keynote_2.3.bb')
-rw-r--r--recipes-security/keynote/keynote_2.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-security/keynote/keynote_2.3.bb b/recipes-security/keynote/keynote_2.3.bb
new file mode 100644
index 0000000..b1df880
--- /dev/null
+++ b/recipes-security/keynote/keynote_2.3.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Keynote tool and library"
2DESCRIPTION = "KeyNote is a simple and flexible trust-management \
3 system designed to work well for a variety of large- and small- \
4 scale Internet-based applications. \
5"
6HOMEPAGE = "http://www.cs.columbia.edu/~angelos/keynote.html"
7SECTION = "security"
8
9LICENSE = "ISC"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3a265095c549c1808686a676f2699c98"
11
12SRC_URI = "http://www.cs.columbia.edu/~angelos/Code/${BPN}.tar.gz \
13 file://configure-remove-hardcode-path.patch \
14 file://makefile-add-ldflags.patch \
15 file://run-ptest \
16"
17
18inherit autotools-brokensep ptest
19
20SRC_URI[md5sum] = "ba58a0297c421dc6aa671e6b753ef695"
21SRC_URI[sha256sum] = "62f7a9d57ceb6bcdd47b604b637a7ac8ed337cef0ab02f1fa28b7e61c9b15821"
22
23DEPENDS = "flex openssl"
24
25EXTRA_OEMAKE += "test-sample -j1"
26
27do_install() {
28 install -D -m 0755 ${S}/keynote ${D}${bindir}/keynote
29 install -D -m 0644 ${S}/libkeynote.a ${D}${libdir}/libkeynote.a
30 install -D -m 0644 ${S}/keynote.h ${D}${includedir}/keynote.h
31}
32
33do_install_ptest() {
34 install -D -m 0755 ${S}/sample-app ${D}${PTEST_PATH}
35 cp -r ${S}/testsuite ${D}${PTEST_PATH}
36 sed -i 's|@PTEST_PATH@|${PTEST_PATH}|' ${D}${PTEST_PATH}/run-ptest
37}