summaryrefslogtreecommitdiffstats
path: root/recipes-security/images
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-10-14 23:09:20 -0700
committerArmin Kuster <akuster808@gmail.com>2016-11-01 09:03:15 -0700
commit2d9a16062b27138976dfd6ac7e2624d0915d234e (patch)
tree272fb5624ec41c64a4e6cb203fe206c80213d6df /recipes-security/images
parentdbf381e349e3c6fe75b13255062e44438cc636e1 (diff)
downloadmeta-security-2d9a16062b27138976dfd6ac7e2624d0915d234e.tar.gz
image: at image to help test builds
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/images')
-rw-r--r--recipes-security/images/security-build-image.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-security/images/security-build-image.bb b/recipes-security/images/security-build-image.bb
new file mode 100644
index 0000000..6745338
--- /dev/null
+++ b/recipes-security/images/security-build-image.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "A small image for building meta-security packages"
2
3IMAGE_FEATURES += "ssh-server-openssh"
4
5IMAGE_INSTALL = "\
6 packagegroup-base \
7 packagegroup-core-boot \
8 packagegroup-core-security \
9 os-release \
10 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "packagegroup-xfce-base", "", d)} \
11 ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
12
13IMAGE_LINGUAS ?= " "
14
15LICENSE = "MIT"
16
17inherit core-image
18
19export IMAGE_BASENAME = "security-build-image"
20
21IMAGE_ROOTFS_EXTRA_SPACE = "5242880"