summaryrefslogtreecommitdiffstats
path: root/recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-08-28 08:44:31 -0700
committerArmin Kuster <akuster808@gmail.com>2019-08-28 20:29:11 -0700
commitc83f0682e400475fdd53e4cabda0d6112016eebc (patch)
tree1cbc88c66bbb3e4769e2353da139bc595fbb2b42 /recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb
parent9e40485f6e8ae7858ca857c5f73054db1d2e6c28 (diff)
downloadmeta-security-c83f0682e400475fdd53e4cabda0d6112016eebc.tar.gz
fail2ban: remove Py2 and updatewip
remove patch included in update fix issues do to python3 fix init file Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb')
-rw-r--r--recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb53
1 files changed, 48 insertions, 5 deletions
diff --git a/recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb b/recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb
index 23ef027..7a278b4 100644
--- a/recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb
+++ b/recipes-security/fail2ban/python3-fail2ban_0.10.4.0.bb
@@ -1,8 +1,51 @@
1inherit setuptools3 1SUMMARY = "Daemon to ban hosts that cause multiple authentication errors."
2require python-fail2ban.inc 2DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \
3many failed login attempts. It does this by updating system firewall rules to reject new \
4connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \
5out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \
6and is easy to configure to read any log file you choose, for any error you choose."
7HOMEPAGE = "http://www.fail2ban.org"
3 8
4RDEPENDS_${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban" 9LICENSE = "GPL-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f"
5 11
6SRC_URI += " \ 12SRCREV ="822f8adb6a59c37698232580cb66236b51c2721f"
7 file://0001-To-fix-build-error-of-xrang.patch \ 13SRC_URI = " \
14 git://github.com/fail2ban/fail2ban.git;branch=0.11 \
15 file://initd \
16 file://fail2ban_setup.py \
17 file://run-ptest \
18 file://0001-fail2ban-update-to-work-with-python-3.7.patch \
8" 19"
20
21inherit setuptools3 update-rc.d ptest
22
23S = "${WORKDIR}/git"
24
25INITSCRIPT_PACKAGES = "${PN}"
26INITSCRIPT_NAME = "fail2ban-server"
27INITSCRIPT_PARAMS = "defaults 25"
28
29do_compile_prepend () {
30 cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py
31}
32
33do_install_append () {
34 install -d ${D}/${sysconfdir}/fail2ban
35 install -d ${D}/${sysconfdir}/init.d
36 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
37 chown -R root:root ${D}/${bindir}
38}
39
40do_install_ptest_append () {
41 install -d ${D}${PTEST_PATH}
42 sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest
43 install -D ${S}/bin/fail2ban-testcases ${D}${PTEST_PATH}
44}
45
46FILES_${PN} += "/run"
47
48INSANE_SKIP_${PN}_append = "already-stripped"
49
50RDEPENDS_${PN} = "sysklogd iptables sqlite3 python3-core python3-pyinotify"
51RDEPENDS_${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban"