summaryrefslogtreecommitdiffstats
path: root/recipes-perl/perl/files
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-12-26 18:44:50 -0800
committerArmin Kuster <akuster808@gmail.com>2015-01-03 21:21:11 -0800
commitb80abbf51d2ba65c8563c09d8b958174b1c5ea88 (patch)
tree113331d0b04ff9dadde29e43c61e2bd71d4e8d2a /recipes-perl/perl/files
parent424473d61eeb28c93dcdfc89ce0a5644367c7aa1 (diff)
downloadmeta-security-b80abbf51d2ba65c8563c09d8b958174b1c5ea88.tar.gz
perl: reorg recipes to match meta-perl.
move security perl recipes to a more standardized recipes-perl layout. Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-perl/perl/files')
-rw-r--r--recipes-perl/perl/files/libwhisker2.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-perl/perl/files/libwhisker2.patch b/recipes-perl/perl/files/libwhisker2.patch
new file mode 100644
index 0000000..c066366
--- /dev/null
+++ b/recipes-perl/perl/files/libwhisker2.patch
@@ -0,0 +1,73 @@
1From 34698c7f561fb575293a1c991a71e1b4ddc5ae73 Mon Sep 17 00:00:00 2001
2From: Andrei Dinu <andrei.adrianx.dinu@intel.com>
3Date: Fri, 5 Jul 2013 11:56:58 +0300
4Subject: [PATCH] Mandir and perl install dir were overwritten with faulty
5 information in the Makefile. Now the Mandir and perl
6 install dir are sent via paramters from the recipe.
7
8Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
9---
10 Makefile.pl | 12 +++++++-----
11 1 file changed, 7 insertions(+), 5 deletions(-)
12
13diff --git a/Makefile.pl b/Makefile.pl
14index 9ca5602..8776e18 100644
15--- a/Makefile.pl
16+++ b/Makefile.pl
17@@ -131,6 +131,8 @@ foreach (keys %MODULES){
18
19 # adjust DESTDIR, if needed
20 $DESTDIR = $ENV{DESTDIR} if(defined $ENV{DESTDIR});
21+$MANDIR = $ENV{MANDIR} if(defined $ENV{MANDIR});
22+$INSTALLDIR = $ENV{INSTALLDIR} if(defined $ENV{INSTALLDIR});
23
24 # parse command line build options
25 while($COMMAND = shift @ARGV){
26@@ -171,7 +173,7 @@ sub command_install_pod {
27 command_build() if(!-e $TARGET);
28 die("Can not install without Config.pm") if($MODULES{Config}==0);
29 $CWD=&cwd if($MODULES{Cwd}>0);
30- my $where=$DESTDIR . $Config{'man3direxp'};
31+ my $where=$DESTDIR . $MANDIR;
32 my $t = $TARGET;
33 if($LIBRARY){
34 $t="$PACKAGE.3pm";
35@@ -219,7 +221,7 @@ sub command_install_pod {
36 sub command_uninstall_pod {
37 die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
38 $CWD=&cwd if($MODULES{Cwd}>0);
39- my $where=$DESTDIR . $Config{'man3direxp'};
40+ my $where=$DESTDIR . $MANDIR;
41 my $t = $TARGET;
42 if($LIBRARY){
43 $t="$PACKAGE.3pm";
44@@ -243,7 +245,7 @@ sub command_install_library {
45 command_build() if(!-e $TARGET);
46 die("Can not install without Config.pm") if($MODULES{Config}==0);
47 $CWD=&cwd if($MODULES{Cwd}>0);
48- my $where=$DESTDIR . $Config{'installsitelib'};
49+ my $where=$DESTDIR . $INSTALLDIR;
50 if(!-e $where){
51 print STDOUT "WARNING!\n\n",
52 "The local perl site directory does not exist:\n",
53@@ -271,7 +273,7 @@ sub command_install_library {
54 sub command_uninstall_library {
55 die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
56 $CWD=&cwd if($MODULES{Cwd}>0);
57- my $where=$DESTDIR . $Config{'installsitelib'};
58+ my $where=$DESTDIR . $INSTALLDIR;
59 chdir($where);
60 if(-e $TARGET){
61 unlink $TARGET;
62@@ -401,7 +403,7 @@ sub command_socket_diag {
63 sub command_install_compat {
64 die("Can not install without Config.pm") if($MODULES{Config}==0);
65 $CWD=&cwd if($MODULES{Cwd}>0);
66- my $where=$DESTDIR . $Config{'installsitelib'};
67+ my $where=$DESTDIR . $INSTALLDIR;
68 if(!-e $where){
69 print STDOUT "WARNING!\n\n",
70 "The local perl site directory does not exist:\n",
71--
721.7.9.5
73