summaryrefslogtreecommitdiffstats
path: root/recipes-ids
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-07-22 06:02:11 -0700
committerArmin Kuster <akuster808@gmail.com>2021-07-28 18:21:25 -0700
commitc1714b299cd042cead697d7a1630c5ca04ba1ff6 (patch)
treee513dd4c89e82115f88b64f5f19f251cef5d60c0 /recipes-ids
parent9cceed4cdbe36d9618f694575422b28cf494c66f (diff)
downloadmeta-security-c1714b299cd042cead697d7a1630c5ca04ba1ff6.tar.gz
crowdsec: add pkg
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-ids')
-rw-r--r--recipes-ids/crowdsec/crowdsec_1.1.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-ids/crowdsec/crowdsec_1.1.1.bb b/recipes-ids/crowdsec/crowdsec_1.1.1.bb
new file mode 100644
index 0000000..1243a3c
--- /dev/null
+++ b/recipes-ids/crowdsec/crowdsec_1.1.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "CrowdSec is a free, modern & collaborative behavior detection engine, coupled with a global IP reputation network."
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=105e75b680b2ab82fa5718661b41f3bf"
5
6SRC_URI = "git://github.com/crowdsecurity/crowdsec.git;branch=master"
7SRCREV = "73e0bbaf93070f4a640eb5a22212b5dcf26699de"
8
9DEPENDS = "jq-native"
10
11GO_IMPORT = "import"
12
13inherit go
14
15S = "${WORKDIR}/git"
16
17do_compile() {
18 export GOARCH="${TARGET_GOARCH}"
19 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
20
21 # Pass the needed cflags/ldflags so that cgo
22 # can find the needed headers files and libraries
23 export CGO_ENABLED="1"
24 export CFLAGS=""
25 export LDFLAGS=""
26 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
27 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
28
29 cd ${S}/src/import
30 oe_runmake release
31}
32
33do_install_ () {
34 chmod +x -R --silent ${B}/pkg
35}
36
37
38INSANE_SKIP_${PN} = "already-stripped"
39INSANE_SKIP_${PN}-dev = "ldflags"
40
41RDEPENDS_${PN} = "go"
42RDEPENDS_${PN}-dev = "bash"