summaryrefslogtreecommitdiffstats
path: root/recipes-forensic
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-02-08 20:01:54 -0800
committerArmin Kuster <akuster808@gmail.com>2015-02-13 17:28:37 -0800
commit7c475c26afb6ea40cc4b96e020fd629694275900 (patch)
tree82bb0ea02dfba0eee5b0ed572775a8efda5e66a0 /recipes-forensic
parent3e12ea17ffea5d9ce39fddd90ec75927ba4e4d3d (diff)
downloadmeta-security-7c475c26afb6ea40cc4b96e020fd629694275900.tar.gz
sleuth: add sleuthkit
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-forensic')
-rw-r--r--recipes-forensic/sleuth/files/fix_host_poison.patch23
-rw-r--r--recipes-forensic/sleuth/sleuthkit_4.1.3.bb28
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-forensic/sleuth/files/fix_host_poison.patch b/recipes-forensic/sleuth/files/fix_host_poison.patch
new file mode 100644
index 0000000..03b1fb9
--- /dev/null
+++ b/recipes-forensic/sleuth/files/fix_host_poison.patch
@@ -0,0 +1,23 @@
1Upstream-Status: Inappropriate [configuration]
2
3Don't use host include or lib paths in *FLAGS
4
5Signed-off-by: Armin Kuster <akuster808@gmail.com>
6
7Index: configure.ac
8===================================================================
9--- a/configure.ac
10+++ b/configure.ac
11@@ -84,12 +84,6 @@ AX_PTHREAD([
12 LDFLAGS="$LDFLAGS $PTHREAD_CFLAGS"
13 CC="$PTHREAD_CC"],[])
14
15-dnl Not all compilers include /usr/local in the include and link path
16-if test -d /usr/local/include; then
17- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
18- LDFLAGS="$LDFLAGS -L/usr/local/lib"
19-fi
20-
21 dnl Add enable/disable option
22 AC_ARG_ENABLE([java],
23 [AS_HELP_STRING([--disable-java], [Do not build the java bindings or jar file])])
diff --git a/recipes-forensic/sleuth/sleuthkit_4.1.3.bb b/recipes-forensic/sleuth/sleuthkit_4.1.3.bb
new file mode 100644
index 0000000..4b82616
--- /dev/null
+++ b/recipes-forensic/sleuth/sleuthkit_4.1.3.bb
@@ -0,0 +1,28 @@
1SUMMARY = "The Sleuth Kit (TSK) is a library and collection of command line tools that allow you to investigate disk images."
2HOMEPAGE = "http://www.sleuthkit.org/sleuthkit/"
3LICENSE = "IPL-1.0 & GPLv2 & CPL-1.0"
4LIC_FILES_CHKSUM = "file://licenses/GNU-COPYING;startline=4;endline=5;md5=475b4784903850b579dc6e6310bd5f08\
5 file://licenses/IBM-LICENSE;startline=1;endline=2;md5=1fc3300388b0d6e6216825dd89c2e3a2\
6 file://licenses/cpl1.0.txt;startline=1;endline=2;md5=9e58c878202c73a4e3ed4be72598fb92"
7
8DEPENDS = "libtool"
9
10SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/s/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
11 file://fix_host_poison.patch \
12 "
13SRC_URI[orig.md5sum] = "139a12f06952d8a40bbe07884994cf5d"
14SRC_URI[orig.sha256sum] = "67f9d2a31a8884d58698d6122fc1a1bfa9bf238582bde2b49228ec9b899f0327"
15
16inherit autotools-brokensep pkgconfig gettext
17
18PACKAGECONFIG ??= "aff zlib ewf"
19PACKAGECONFIG[aff] = "--with-afflib=${STAGING_DIR_HOST}/usr, --without-afflib, afflib"
20PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_DIR_HOST}/usr, --without-zlib, zlib"
21PACKAGECONFIG[ewf] = "--with-libewf=${STAGING_DIR_HOST}/usr, --without-libewf, libewf"
22
23#--with-gnu-ld
24EXTRA_OECONF += "--enable-static=no --disable-java LIBS='-L${STAGING_LIBDIR}' LDFLAGS='-L${STAGING_LIBDIR}' CPPFLAGS='-I${STAGING_INCDIR}'"
25
26FILES_${PN} += " ${datadir}/tsk"
27
28RDEPENDS_${PN} += " perl"