summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-06-07 11:21:01 -0700
committerArmin Kuster <akuster808@gmail.com>2015-06-25 07:16:05 -0700
commitda6d34655de52f314bbd569b10cb964ba64e2c22 (patch)
tree550256024b0605555ebf35b7771c512a953e1099 /recipes-devtools
parente2573826256a13ba1c2037d51947b7933c436408 (diff)
downloadmeta-security-da6d34655de52f314bbd569b10cb964ba64e2c22.tar.gz
python-pycrypto: add new package
adding crypto package for use by scampy. I will remove once it is moved to meta-python Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--recipes-devtools/python/python-pycrypto_2.6.1.bb33
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/recipes-devtools/python/python-pycrypto/cross-compiling.patch
new file mode 100644
index 0000000..712f3e8
--- /dev/null
+++ b/recipes-devtools/python/python-pycrypto/cross-compiling.patch
@@ -0,0 +1,23 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23
diff --git a/recipes-devtools/python/python-pycrypto_2.6.1.bb b/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 0000000..a2ad4d1
--- /dev/null
+++ b/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
6
7SRCNAME = "pycrypto"
8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10 file://cross-compiling.patch"
11
12SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
13SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19export STAGING_INCDIR
20export STAGING_LIBDIR
21export BUILD_SYS
22export HOST_SYS
23
24inherit autotools autotools-brokensep distutils
25
26DEPENDS += " gmp"
27
28# We explicitly call distutils_do_install, since we want it to run, but
29# *don't* want the autotools install to run, since this package doesn't
30# provide a "make install" target.
31do_install() {
32 distutils_do_install
33}