summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-10-17 16:52:41 -0700
committerArmin Kuster <akuster808@gmail.com>2016-11-01 09:03:15 -0700
commit5d545800ba69e877b5ca93b6d32e6b2b085cc01f (patch)
tree9fc16d524b64a4f6c18581b25be128219ea063fb /recipes-devtools
parentb68613ae0671abb84eef50cae2639e22d6bfac47 (diff)
downloadmeta-security-5d545800ba69e877b5ca93b6d32e6b2b085cc01f.tar.gz
python-pycrypto: simplify to use pypi class
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pycrypto_2.6.1.bb22
1 files changed, 5 insertions, 17 deletions
diff --git a/recipes-devtools/python/python-pycrypto_2.6.1.bb b/recipes-devtools/python/python-pycrypto_2.6.1.bb
index 8036158..acc8325 100644
--- a/recipes-devtools/python/python-pycrypto_2.6.1.bb
+++ b/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -1,29 +1,17 @@
1DESCRIPTION = "Cryptographic modules for Python." 1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/" 2HOMEPAGE = "http://www.pycrypto.org/"
3SECTION = "devel/python"
4LICENSE = "PSFv2" 3LICENSE = "PSFv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" 4LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
6 5
7SRCNAME = "pycrypto" 6DEPENDS += " gmp"
7PYPI_PACKAGE = "pycrypto"
8 8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ 9SRC_URI = "file://cross-compiling.patch"
10 file://cross-compiling.patch"
11 10
12SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" 11SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
13SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" 12SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
14 13
15S = "${WORKDIR}/${SRCNAME}-${PV}" 14inherit pypi autotools-brokensep distutils
16
17inherit setuptools
18
19export STAGING_INCDIR
20export STAGING_LIBDIR
21export BUILD_SYS
22export HOST_SYS
23
24inherit autotools autotools-brokensep distutils
25
26DEPENDS += " gmp"
27 15
28do_compile[noexec] = "1" 16do_compile[noexec] = "1"
29 17
@@ -31,5 +19,5 @@ do_compile[noexec] = "1"
31# *don't* want the autotools install to run, since this package doesn't 19# *don't* want the autotools install to run, since this package doesn't
32# provide a "make install" target. 20# provide a "make install" target.
33do_install() { 21do_install() {
34 distutils_do_install 22 distutils_do_install
35} 23}