summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2020-09-10 16:17:56 +0000
committerArmin Kuster <akuster808@gmail.com>2020-09-12 08:55:28 -0700
commit1d21cec5fda489f9ed7c1132b0abc18db3af6d41 (patch)
tree55cc786b4c06dacd3bd0e3de1cec2b03725c8d5d /recipes-core
parent45e8b20cd022eb7b20d72c23db9fcc6824f08c7a (diff)
downloadmeta-security-1d21cec5fda489f9ed7c1132b0abc18db3af6d41.tar.gz
dm-verity-initramfs-image: Cosmetic improvements
- revise declaration ordering as suggested by oe-stylize.py - sort PACKAGE_INSTALL entries in alphabetic order - split long command line in deploy_verity_hash() Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/dm-verity-image-initramfs.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/recipes-core/images/dm-verity-image-initramfs.bb b/recipes-core/images/dm-verity-image-initramfs.bb
index 6a1058d..0fdb46c 100644
--- a/recipes-core/images/dm-verity-image-initramfs.bb
+++ b/recipes-core/images/dm-verity-image-initramfs.bb
@@ -1,19 +1,21 @@
1DESCRIPTION = "Simple initramfs image for mounting the rootfs over the verity device mapper." 1DESCRIPTION = "Simple initramfs image for mounting the rootfs over the verity device mapper."
2 2
3# We want a clean, minimal image. 3inherit core-image
4IMAGE_FEATURES = ""
5 4
6PACKAGE_INSTALL = " \ 5PACKAGE_INSTALL = " \
7 initramfs-module-dmverity \
8 initramfs-module-udev \
9 base-files \ 6 base-files \
10 busybox \ 7 busybox \
11 util-linux-mount \
12 udev \
13 cryptsetup \ 8 cryptsetup \
9 initramfs-module-dmverity \
10 initramfs-module-udev \
14 lvm2-udevrules \ 11 lvm2-udevrules \
12 udev \
13 util-linux-mount \
15" 14"
16 15
16# We want a clean, minimal image.
17IMAGE_FEATURES = ""
18
17# Can we somehow inspect reverse dependencies to avoid these variables? 19# Can we somehow inspect reverse dependencies to avoid these variables?
18do_image[depends] += "${DM_VERITY_IMAGE}:do_image_${DM_VERITY_IMAGE_TYPE}" 20do_image[depends] += "${DM_VERITY_IMAGE}:do_image_${DM_VERITY_IMAGE_TYPE}"
19 21
@@ -22,9 +24,9 @@ do_image[nostamp] = "1"
22 24
23IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 25IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
24 26
25inherit core-image
26
27deploy_verity_hash() { 27deploy_verity_hash() {
28 install -D -m 0644 ${STAGING_VERITY_DIR}/${DM_VERITY_IMAGE}.${DM_VERITY_IMAGE_TYPE}.verity.env ${IMAGE_ROOTFS}${datadir}/misc/dm-verity.env 28 install -D -m 0644 \
29 ${STAGING_VERITY_DIR}/${DM_VERITY_IMAGE}.${DM_VERITY_IMAGE_TYPE}.verity.env \
30 ${IMAGE_ROOTFS}${datadir}/misc/dm-verity.env
29} 31}
30IMAGE_PREPROCESS_COMMAND += "deploy_verity_hash;" 32IMAGE_PREPROCESS_COMMAND += "deploy_verity_hash;"