summaryrefslogtreecommitdiffstats
path: root/meta-tpm
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-09-15 17:17:20 +0800
committerArmin Kuster <akuster808@gmail.com>2017-09-15 08:01:07 -0700
commite180062c708483a55390a6adc1efd9e60d2681c5 (patch)
treebdc3638ef505875cc648fe21272a29ee828dad23 /meta-tpm
parent738dad9d91b523bf56ba708f8ac214a7e85fa05a (diff)
downloadmeta-security-e180062c708483a55390a6adc1efd9e60d2681c5.tar.gz
packagegroups: fix invalid license file
Use '${COMMON_LICENSE_DIR}/MIT' for MIT License to fix the warning: | WARNING: packagegroup-core-security do_populate_lic: ${COREBASE}/LICENSE is not a valid license file, please use '${COMMON_LICENSE_DIR}/MIT' for a MIT License file in LIC_FILES_CHKSUM. This will become an error in the future Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-tpm')
-rw-r--r--meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm-i2c.bb2
-rw-r--r--meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm.bb2
-rw-r--r--meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb2
-rw-r--r--meta-tpm/recipes-core/packagegroup/packagegroup-security-vtpm.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm-i2c.bb b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm-i2c.bb
index 2d93aca..3b9d271 100644
--- a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm-i2c.bb
+++ b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm-i2c.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Security packagegroup for TPM i2c support" 1DESCRIPTION = "Security packagegroup for TPM i2c support"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 5
6inherit packagegroup 6inherit packagegroup
diff --git a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm.bb b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm.bb
index 2db8521..25126ef 100644
--- a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm.bb
+++ b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Security packagegroup for Poky" 1DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 5
6inherit packagegroup 6inherit packagegroup
diff --git a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
index 57b0722..13b505f 100644
--- a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
+++ b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Security packagegroup for Poky" 1DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 5
6inherit packagegroup 6inherit packagegroup
diff --git a/meta-tpm/recipes-core/packagegroup/packagegroup-security-vtpm.bb b/meta-tpm/recipes-core/packagegroup/packagegroup-security-vtpm.bb
index f7eee7c..2e9394f 100644
--- a/meta-tpm/recipes-core/packagegroup/packagegroup-security-vtpm.bb
+++ b/meta-tpm/recipes-core/packagegroup/packagegroup-security-vtpm.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Security packagegroup for Poky" 1DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 5
6inherit packagegroup 6inherit packagegroup