summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@eng.windriver.com>2024-04-13 21:25:24 +0800
committerArmin Kuster <akuster808@gmail.com>2024-04-16 09:43:15 -0400
commitfb28801eeeef53cb6cc0096d1938a93bea323597 (patch)
tree7597e6423129411c24a4de7e3496289b74fd5588 /meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb
parentd1522af21da8d799a8f397aef6359b5ed4dc07fe (diff)
downloadmeta-security-fb28801eeeef53cb6cc0096d1938a93bea323597.tar.gz
ibmswtpm2: upgrade 164-2020-192.1 -> 183-2024-03-27
Remove '-DALG_CAMELLIA=ALG_NO' from CFLAGS to fix compile error: | TpmProfile_Common.h:109: error: "ALG_CAMELLIA" redefined [-Werror] | 109 | #define ALG_CAMELLIA ALG_YES | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb')
-rw-r--r--meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb b/meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb
new file mode 100644
index 0000000..7ed9569
--- /dev/null
+++ b/meta-tpm/recipes-tpm2/ibmswtpm2/ibmswtpm2_183-2024-03-27.bb
@@ -0,0 +1,37 @@
1SUMMARY = "IBM's Software TPM 2.0"
2DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \
3education, and virtualization. \
4\
5The intent is that an application can be developed using the software TPM. \
6The application should then run using a hardware TPM without changes. \
7Advantages of this approach: \
8* In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \
9* Application software errors are easily reversed by simply removing the TPM state and starting over. \
10* Difficult crypto errors are quickly debugged by looking inside the TPM."
11HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
12LICENSE = "BSD-2-Clause"
13SECTION = "securty/tpm"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f"
15LIC_FILES_CHKSUM += "file://LICENSE;md5=c75e465155c42c14154bf6a2acb7347b"
16
17DEPENDS = "openssl"
18
19SRC_URI = "git://git.code.sf.net/p/ibmswtpm2/tpm2;protocol=https;branch=master \
20 file://tune-makefile.patch \
21 "
22SRCREV = "c37c74438429e1d5fe465232e7bf894b239a2cd4"
23
24UPSTREAM_CHECK_GITTAGREGEX = "rev(?P<pver>\d+(\-\d+)+)"
25
26S = "${WORKDIR}/git/src"
27
28CFLAGS += "-Wno-error=maybe-uninitialized"
29
30do_compile () {
31 make CC='${CC}'
32}
33
34do_install () {
35 install -d ${D}/${bindir}
36 install -m 0755 tpm_server ${D}/${bindir}
37}