summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-05-07 22:48:26 -0700
committerArmin Kuster <akuster808@gmail.com>2017-05-14 07:56:52 -0700
commitf8973e152a17920cdef65640ab3a31d73bf9cb7e (patch)
treeb218b97e233598188ab899322f63f4d7a6e282a7 /meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
parenta07aa7e93e8831c9c9fe75088385c08b601fbbcd (diff)
downloadmeta-security-f8973e152a17920cdef65640ab3a31d73bf9cb7e.tar.gz
tpm packagegroups: split into logical units
this should help mitgate the need to pull in too many layers if swtpm in not wanted Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb')
-rw-r--r--meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
new file mode 100644
index 0000000..1c96cbe
--- /dev/null
+++ b/meta-tpm/recipes-core/packagegroup/packagegroup-security-tpm2.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6inherit packagegroup
7
8PACKAGES = "packagegroup-security-tpm2"
9
10SUMMARY_packagegroup-security-tpm2 = "Security TPM 2.0 support"
11RDEPENDS_packagegroup-security-tpm2 = " \
12 tpm2.0-tools \
13 libtss2 \
14 libtctidevice \
15 libtctisocket \
16 resourcemgr \
17 kernel-module-tpm-crb \
18 "