summaryrefslogtreecommitdiffstats
path: root/meta-security-compliance
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-07-04 10:53:20 -0700
committerArmin Kuster <akuster808@gmail.com>2019-07-17 16:56:39 -0700
commita64348d0df2f6e3df805638020888c8286478e82 (patch)
treed35e5281004828de0ce712fd317ec014c670c532 /meta-security-compliance
parent90ccc8b4f5e8362c3436575e0ef60ec6e26bc2da (diff)
downloadmeta-security-a64348d0df2f6e3df805638020888c8286478e82.tar.gz
scap-security-guide: update to 0.1.44
create a PV version to track upstream git version includes OE changes Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-security-compliance')
-rw-r--r--meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc47
-rw-r--r--meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_0.1.44.bb8
-rw-r--r--meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_git.bb63
3 files changed, 63 insertions, 55 deletions
diff --git a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc
new file mode 100644
index 0000000..ed70c18
--- /dev/null
+++ b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc
@@ -0,0 +1,47 @@
1# Copyright (C) 2017 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMARRY = "SCAP content for various platforms"
5HOME_URL = "https://www.open-scap.org/security-policies/scap-security-guide/"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=97662e4486d9a1d09f358851d9f41a1a"
7LICENSE = "LGPL-2.1"
8
9DEPENDS = "openscap-native python3 python3-pyyaml-native python3-jinja2-native libxml2-native"
10
11S = "${WORKDIR}/git"
12
13inherit cmake pkgconfig python3native
14
15#PARALLEL_MAKE = ""
16
17STAGING_OSCAP_BUILDDIR = "${TMPDIR}/work-shared/openscap/oscap-build-artifacts"
18
19OECMAKE_GENERATOR = "Unix Makefiles"
20
21EXTRA_OECMAKE += "-DENABLE_PYTHON_COVERAGE=OFF"
22
23do_configure_prepend () {
24 sed -i -e 's:NAMES\ sed:NAMES\ ${HOSTTOOLS_DIR}/sed:g' ${S}/CMakeLists.txt
25 sed -i 's:/usr/share/openscap/:${STAGING_OSCAP_BUILDDIR}${datadir_native}/openscap/:g' ${S}/cmake/SSGCommon.cmake
26}
27
28do_compile () {
29 cd ${S}/build
30 cmake ../
31 # oddly rhel7 needs to build first
32 make rhel7
33}
34
35do_install () {
36 cd ${S}/build
37 make DESTDIR=${D} install
38}
39
40localdatadir = "${prefix}/local/share"
41localmandir = "${localdatadir}/man"
42localdocdir = "${localdatadir}/doc"
43localxmldir = "${localdatadir}/xml"
44
45FILES_${PN} += "${localdatadir} ${localxmldir}"
46FILES_${PN}-doc += "${localmandir} ${localdocdir}"
47RDEPNEDS_${PN} = "openscap"
diff --git a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_0.1.44.bb b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_0.1.44.bb
new file mode 100644
index 0000000..d80ecd7
--- /dev/null
+++ b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_0.1.44.bb
@@ -0,0 +1,8 @@
1SUMARRY = "SCAP content for various platforms, upstream version"
2
3SRCREV = "8cb2d0f351faff5440742258782281164953b0a6"
4SRC_URI = "git://github.com/ComplianceAsCode/content.git"
5
6DEFAULT_PREFERENCE = "-1"
7
8require scap-security-guide.inc
diff --git a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_git.bb b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_git.bb
index 3f76038..cb21fed 100644
--- a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_git.bb
+++ b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide_git.bb
@@ -1,60 +1,13 @@
1# Copyright (C) 2017 Armin Kuster <akuster808@gmail.com> 1SUMARRY = "SCAP content for various platforms, OE changes"
2# Released under the MIT license (see COPYING.MIT for the terms)
3 2
4SUMARRY = "SCAP content for various platforms" 3SRCREV = "5fdfdcb2e95afbd86ace555beca5d20cbf1043ed"
5HOME_URL = "https://www.open-scap.org/security-policies/scap-security-guide/" 4SRC_URI = "git://github.com/akuster/scap-security-guide.git;branch=oe-0.1.44;"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=236e81befc8154d18c93c848185d7e52" 5PV = "v0.1.44+git${SRCPV}"
7LICENSE = "LGPL-2.1"
8 6
9DEPENDS = "openscap-native" 7require scap-security-guide.inc
10 8
11SRCREV = "423d9f40021a03abd018bef7818a3a9fe91a083c" 9do_compile_append () {
12SRC_URI = "git://github.com/akuster/scap-security-guide.git;branch=oe;" 10 make openembedded
13PV = "v0.1.33+git${SRCPV}"
14
15inherit cmake
16
17PARALLEL_MAKE = ""
18
19S = "${WORKDIR}/git"
20
21STAGING_OSCAP_BUILDDIR = "${TMPDIR}/work-shared/openscap/oscap-build-artifacts"
22
23OECMAKE_GENERATOR = "Unix Makefiles"
24
25EXTRA_OECMAKE += "-DSSG_PRODUCT_CHROMIUM:BOOL=OFF"
26EXTRA_OECMAKE += "-DSSG_PRODUCT_DEBIAN8:BOOL=OFF"
27EXTRA_OECMAKE += "-DSSG_PRODUCT_FEDORA:BOOL=OFF"
28EXTRA_OECMAKE += "-DSSG_PRODUCT_FIREFOX:BOOL=OFF"
29EXTRA_OECMAKE += "-DSSG_PRODUCT_JBOSS_EAP5:BOOL=OFF"
30EXTRA_OECMAKE += "-DSSG_PRODUCT_JBOSS_FUSE6:BOOL=OFF"
31EXTRA_OECMAKE += "-DSSG_PRODUCT_JRE:BOOL=OFF"
32EXTRA_OECMAKE += "-DSSG_PRODUCT_OPENSUSE:BOOL=OFF"
33EXTRA_OECMAKE += "-DSSG_PRODUCT_OSP7:BOOL=OFF"
34EXTRA_OECMAKE += "-DSSG_PRODUCT_RHEL5:BOOL=OFF"
35EXTRA_OECMAKE += "-DSSG_PRODUCT_RHEL6:BOOL=OFF"
36EXTRA_OECMAKE += "-DSSG_PRODUCT_RHEL7:BOOL=OFF"
37EXTRA_OECMAKE += "-DSSG_PRODUCT_RHEV3:BOOL=OFF"
38EXTRA_OECMAKE += "-DSSG_PRODUCT_SUSE11:BOOL=OFF"
39EXTRA_OECMAKE += "-DSSG_PRODUCT_SUSE12:BOOL=OFF"
40EXTRA_OECMAKE += "-DSSG_PRODUCT_UBUNTU1404:BOOL=OFF"
41EXTRA_OECMAKE += "-DSSG_PRODUCT_UBUNTU1604:BOOL=OFF"
42EXTRA_OECMAKE += "-DSSG_PRODUCT_WRLINUX:BOOL=OFF"
43EXTRA_OECMAKE += "-DSSG_PRODUCT_WEBMIN:BOOL=OFF"
44
45do_configure_prepend () {
46 sed -i -e 's:NAMES\ sed:NAMES\ ${HOSTTOOLS_DIR}/sed:g' ${S}/CMakeLists.txt
47 sed -i 's:/usr/share/openscap/:${STAGING_OSCAP_BUILDDIR}${datadir_native}/openscap/:g' ${S}/cmake/SSGCommon.cmake
48} 11}
49 12
50do_compile () { 13EXTRA_OECMAKE += "-DSSG_PRODUCT_OPENEMBEDDED=ON"
51 cd ${B}
52 make openembedded
53}
54
55do_install () {
56 cd ${B}
57 make DESTDIR=${D} install
58}
59FILES_${PN} += "${datadir}/xml"
60RDEPNEDS_${PN} = "openscap"