summaryrefslogtreecommitdiffstats
path: root/meta-security-compliance
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-09-04 00:21:34 +0000
committerArmin Kuster <akuster808@gmail.com>2019-09-07 08:34:22 -0700
commit303800de96ec3ed3971f316cf0308f409761336c (patch)
treed3723b9be57e639b893305740e87ba16cc04f970 /meta-security-compliance
parenta6a431f6adc33f91f4df5bfde024f69399fea7f5 (diff)
downloadmeta-security-303800de96ec3ed3971f316cf0308f409761336c.tar.gz
scap-security-guide: add depends on openscap-native do_install
This ensures openscap-native does install the needed patches security guilde needs to build Minor recipe cleanup too Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-security-compliance')
-rw-r--r--meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc
index 341721a..3212310 100644
--- a/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc
+++ b/meta-security-compliance/recipes-openscap/scap-security-guide/scap-security-guide.inc
@@ -7,14 +7,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=97662e4486d9a1d09f358851d9f41a1a"
7LICENSE = "LGPL-2.1" 7LICENSE = "LGPL-2.1"
8 8
9DEPENDS = "openscap-native python3 python3-pyyaml-native python3-jinja2-native libxml2-native" 9DEPENDS = "openscap-native python3 python3-pyyaml-native python3-jinja2-native libxml2-native"
10RDEPENDS_${PN} = "openscap"
11 10
12S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
13 12
14inherit cmake pkgconfig python3native 13inherit cmake pkgconfig python3native
15 14
16#PARALLEL_MAKE = ""
17
18STAGING_OSCAP_BUILDDIR = "${TMPDIR}/work-shared/openscap/oscap-build-artifacts" 15STAGING_OSCAP_BUILDDIR = "${TMPDIR}/work-shared/openscap/oscap-build-artifacts"
19 16
20OECMAKE_GENERATOR = "Unix Makefiles" 17OECMAKE_GENERATOR = "Unix Makefiles"
@@ -23,9 +20,13 @@ EXTRA_OECMAKE += "-DENABLE_PYTHON_COVERAGE=OFF"
23 20
24B = "${S}/build" 21B = "${S}/build"
25 22
23do_configure[depends] += "openscap-native:do_install"
24
26do_configure_prepend () { 25do_configure_prepend () {
27 sed -i -e 's:NAMES\ sed:NAMES\ ${HOSTTOOLS_DIR}/sed:g' ${S}/CMakeLists.txt 26 sed -i -e 's:NAMES\ sed:NAMES\ ${HOSTTOOLS_DIR}/sed:g' ${S}/CMakeLists.txt
28 sed -i -e 's:NAMES\ grep:NAMES\ ${HOSTTOOLS_DIR}/grep:g' ${S}/CMakeLists.txt 27 sed -i -e 's:NAMES\ grep:NAMES\ ${HOSTTOOLS_DIR}/grep:g' ${S}/CMakeLists.txt
29} 28}
30 29
31FILES_${PN} += "${datadir}/xml" 30FILES_${PN} += "${datadir}/xml"
31
32RDEPENDS_${PN} = "openscap"