diff options
author | Armin Kuster <akuster808@gmail.com> | 2020-07-20 02:34:18 +0000 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2020-07-25 08:58:38 -0700 |
commit | 6a8ad0efe73e2ec19df3c665b246db49fa9f17da (patch) | |
tree | 35e2994462ad1880d681a6c715ed60be76fb70bb /meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb | |
parent | 066a04425c318dd20dfe7806a5aa976e377a39a5 (diff) | |
download | meta-security-6a8ad0efe73e2ec19df3c665b246db49fa9f17da.tar.gz |
lynis: update to 3.0.0
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb')
-rw-r--r-- | meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb b/meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb new file mode 100644 index 0000000..2d59623 --- /dev/null +++ b/meta-security-compliance/recipes-auditors/lynis/lynis_3.0.0.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | # Copyright (C) 2017 Armin Kuster <akuster808@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Lynis is a free and open source security and auditing tool." | ||
5 | HOMEDIR = "https://cisofy.com/" | ||
6 | LICENSE = "GPL-3.0" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1" | ||
8 | |||
9 | SRC_URI = "https://cisofy.com/files/${BPN}-${PV}.tar.gz" | ||
10 | |||
11 | SRC_URI[sha256sum] = "3cc165f9007ba41de6d0b693a1167dbaf0179085f9506dcba64b4b8e37e1bda2" | ||
12 | |||
13 | S = "${WORKDIR}/${BPN}" | ||
14 | |||
15 | inherit autotools-brokensep | ||
16 | |||
17 | do_compile[noexec] = "1" | ||
18 | do_configure[noexec] = "1" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}/${bindir} | ||
22 | install -d ${D}/${sysconfdir}/lynis | ||
23 | install -m 555 ${S}/lynis ${D}/${bindir} | ||
24 | |||
25 | install -d ${D}/${datadir}/lynis/db | ||
26 | install -d ${D}/${datadir}/lynis/plugins | ||
27 | install -d ${D}/${datadir}/lynis/include | ||
28 | install -d ${D}/${datadir}/lynis/extras | ||
29 | |||
30 | cp -r ${S}/db/* ${D}/${datadir}/lynis/db/. | ||
31 | cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/. | ||
32 | cp -r ${S}/include/* ${D}/${datadir}/lynis/include/. | ||
33 | cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/. | ||
34 | cp ${S}/*.prf ${D}/${sysconfdir}/lynis | ||
35 | } | ||
36 | |||
37 | FILES_${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf" | ||
38 | FILES_${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md" | ||
39 | |||
40 | RDEPENDS_${PN} += "procps findutils" | ||