summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJinliang Li <jinliang.li@linux.alibaba.com>2018-06-06 22:06:53 +0800
committerArmin Kuster <akuster808@gmail.com>2018-06-11 10:57:43 -0700
commitf9c5e2022b54097474e46d9efb54080bd0e4d606 (patch)
treed61ffe3170871623c01d133e50011ef736484f1c
parentb38f027b9352b4beb123caef80cb19a354b72ead (diff)
downloadmeta-security-f9c5e2022b54097474e46d9efb54080bd0e4d606.tar.gz
Fix build issue for apparmor when systemd is used
When systemd is used as system init manager, there is a build issue complains "can't found apparmor.service". This patch fix it. Signed-off-by: Jinliang Li <jinliang.li@linux.alibaba.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/AppArmor/apparmor_2.11.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-security/AppArmor/apparmor_2.11.0.bb b/recipes-security/AppArmor/apparmor_2.11.0.bb
index a83c2c3..fc9b614 100644
--- a/recipes-security/AppArmor/apparmor_2.11.0.bb
+++ b/recipes-security/AppArmor/apparmor_2.11.0.bb
@@ -104,6 +104,11 @@ do_install () {
104 104
105 install ${WORKDIR}/apparmor ${D}/${INIT_D_DIR}/apparmor 105 install ${WORKDIR}/apparmor ${D}/${INIT_D_DIR}/apparmor
106 install ${WORKDIR}/functions ${D}/lib/apparmor 106 install ${WORKDIR}/functions ${D}/lib/apparmor
107 if [ "${VIRTUAL-RUNTIME_init_manager}" = "systemd" ]; then
108 install -d ${D}${systemd_system_unitdir}
109 install ${WORKDIR}/apparmor.service \
110 ${D}${systemd_system_unitdir}
111 fi
107} 112}
108 113
109do_compile_ptest () { 114do_compile_ptest () {