summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2023-07-03 11:10:25 -0400
committerArmin Kuster <akuster808@gmail.com>2023-07-31 06:18:52 -0400
commitc56573730f87888d8c62bba6b3e0dade6114fdb4 (patch)
tree713482999d162ed16858a6cb8672d71b29c3fb17
parent1dd076d3a76f19cb73f5d40e708a042c9a58319a (diff)
downloadmeta-security-c56573730f87888d8c62bba6b3e0dade6114fdb4.tar.gz
python3-tpm2-pytss: add python tss2 support
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm2/tpm2-pytss/python3-tpm2-pytss_2.1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm2/tpm2-pytss/python3-tpm2-pytss_2.1.0.bb b/meta-tpm/recipes-tpm2/tpm2-pytss/python3-tpm2-pytss_2.1.0.bb
new file mode 100644
index 0000000..c98d4ab
--- /dev/null
+++ b/meta-tpm/recipes-tpm2/tpm2-pytss/python3-tpm2-pytss_2.1.0.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU), TCTI Loader (TCTILdr), TCTIs, policy, and RC Decoding (rcdecode) libraries"
2HOMEPAGE = "https://github.com/tpm2-software/tpm2-pytss"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
5
6SRC_URI[sha256sum] = "5b5b4b1456fdc1aeef3d2c3970beaa078c8f7f2648c97a69bcf60c5a2f95c897"
7
8PYPI_PACKAGE = "tpm2-pytss"
9
10DEPENDS = "python3-pkgconfig-native python3-pycparser-native python3-asn1crypto-native"
11DEPENDS:append = " python3-cryptography-native tpm2-tss"
12
13inherit autotools pkgconfig pypi setuptools3_legacy
14
15RDEPENDS:${PN} = "libtss2"