summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-10-14 22:35:58 -0700
committerArmin Kuster <akuster808@gmail.com>2019-10-14 22:45:18 -0700
commitc55721b15e85d8e103f54ff5d2722a106a91f3eb (patch)
tree7f03536af45cd03c9dde6d12289690c62ab7c08d
parent0e612d4c4d4411b3396ba3b4a7bcb29ec5a87258 (diff)
downloadmeta-security-c55721b15e85d8e103f54ff5d2722a106a91f3eb.tar.gz
checksec: add missing rdepends to readelf
update test to check for depends Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--lib/oeqa/runtime/cases/checksec.py1
-rw-r--r--recipes-security/checksec/checksec_2.1.0.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/lib/oeqa/runtime/cases/checksec.py b/lib/oeqa/runtime/cases/checksec.py
index ff6d2f3..e46744c 100644
--- a/lib/oeqa/runtime/cases/checksec.py
+++ b/lib/oeqa/runtime/cases/checksec.py
@@ -24,6 +24,7 @@ class CheckSecTest(OERuntimeTestCase):
24 self.assertEqual(status, 0, msg = msg) 24 self.assertEqual(status, 0, msg = msg)
25 25
26 @OETestDepends(['checksec.CheckSecTest.test_checksec_xml']) 26 @OETestDepends(['checksec.CheckSecTest.test_checksec_xml'])
27 @OEHasPackage(['binutils'])
27 def test_checksec_fortify(self): 28 def test_checksec_fortify(self):
28 status, output = self.target.run('checksec --fortify-proc 1') 29 status, output = self.target.run('checksec --fortify-proc 1')
29 match = re.search('FORTIFY_SOURCE support:', output) 30 match = re.search('FORTIFY_SOURCE support:', output)
diff --git a/recipes-security/checksec/checksec_2.1.0.bb b/recipes-security/checksec/checksec_2.1.0.bb
index 5c6528e..b67c98b 100644
--- a/recipes-security/checksec/checksec_2.1.0.bb
+++ b/recipes-security/checksec/checksec_2.1.0.bb
@@ -16,4 +16,4 @@ do_install() {
16 install -m 0755 ${S}/checksec ${D}${bindir} 16 install -m 0755 ${S}/checksec ${D}${bindir}
17} 17}
18 18
19RDEPENDS_${PN} = "bash openssl-bin" 19RDEPENDS_${PN} = "bash openssl-bin binutils"