summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWurm, Stephan <Stephan.Wurm@a-eberle.de>2023-07-21 08:44:05 +0000
committerArmin Kuster <akuster808@gmail.com>2023-08-06 11:31:18 -0400
commita94674c5bc380580d9219d2bc470c408c1779de6 (patch)
treed3debfeeb6157b0d9637653e219bd8a24ca358bc
parentd47553303c77002c8a55a68d05a5bdf9ed7eb4d1 (diff)
downloadmeta-security-a94674c5bc380580d9219d2bc470c408c1779de6.tar.gz
dm-verity-image-initramfs: Allow compressed image types
Using <DM_VERITY_IMAGE_TYPE> in the depends variable does not work for compressed image types like squashfs-zst, as the resulting task dependency still contains the incompatible dash. Replacing the dash by an underscore resolves this issue. Signed-off-by: Stephan Wurm <stephan.wurm@a-eberle.de> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-core/images/dm-verity-image-initramfs.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-core/images/dm-verity-image-initramfs.bb b/recipes-core/images/dm-verity-image-initramfs.bb
index 187aeae..78f7b49 100644
--- a/recipes-core/images/dm-verity-image-initramfs.bb
+++ b/recipes-core/images/dm-verity-image-initramfs.bb
@@ -19,7 +19,14 @@ IMAGE_FEATURES = ""
19IMAGE_LINGUAS = "" 19IMAGE_LINGUAS = ""
20 20
21# Can we somehow inspect reverse dependencies to avoid these variables? 21# Can we somehow inspect reverse dependencies to avoid these variables?
22do_image[depends] += "${DM_VERITY_IMAGE}:do_image_${DM_VERITY_IMAGE_TYPE}" 22python __anonymous() {
23 verity_image = d.getVar('DM_VERITY_IMAGE')
24 verity_type = d.getVar('DM_VERITY_IMAGE_TYPE')
25
26 if verity_image and verity_type:
27 dep = ' %s:do_image_%s' % (verity_image, verity_type.replace('-', '_'))
28 d.appendVarFlag('do_image', 'depends', dep)
29}
23 30
24# Ensure dm-verity.env is updated also when rebuilding DM_VERITY_IMAGE 31# Ensure dm-verity.env is updated also when rebuilding DM_VERITY_IMAGE
25do_image[nostamp] = "1" 32do_image[nostamp] = "1"