summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-09-29 13:38:56 +0800
committerArmin Kuster <akuster808@gmail.com>2016-10-11 01:39:29 -0700
commit793d60e5fa513b9f2f55f684470120d9a4b26103 (patch)
treeb6bca083d5473be9021ea694efe95cba7dc0b235
parentf41ed27588289eb1c0d556764ab3dc72f4f9d33c (diff)
downloadmeta-security-793d60e5fa513b9f2f55f684470120d9a4b26103.tar.gz
scapy: upgrade to 2.3.2
* update the SRC_URI since it's been moved from bitbucket to github. * add ptest support Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rwxr-xr-xrecipes-security/scapy/scapy/run-ptest4
-rw-r--r--recipes-security/scapy/scapy_2.3.2.bb (renamed from recipes-security/scapy/scapy_2.3.1.bb)15
2 files changed, 15 insertions, 4 deletions
diff --git a/recipes-security/scapy/scapy/run-ptest b/recipes-security/scapy/scapy/run-ptest
new file mode 100755
index 0000000..91b29f9
--- /dev/null
+++ b/recipes-security/scapy/scapy/run-ptest
@@ -0,0 +1,4 @@
1#!/bin/sh
2UTscapy -t regression.uts -f text -l -C \
3 -o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \
4 2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/'
diff --git a/recipes-security/scapy/scapy_2.3.1.bb b/recipes-security/scapy/scapy_2.3.2.bb
index d8c731b..0a42ad9 100644
--- a/recipes-security/scapy/scapy_2.3.1.bb
+++ b/recipes-security/scapy/scapy_2.3.2.bb
@@ -5,12 +5,19 @@ LICENSE = "GPLv2"
5 5
6LIC_FILES_CHKSUM = "file://bin/scapy;beginline=9;endline=13;md5=1d5249872cc54cd4ca3d3879262d0c69" 6LIC_FILES_CHKSUM = "file://bin/scapy;beginline=9;endline=13;md5=1d5249872cc54cd4ca3d3879262d0c69"
7 7
8SRC_URI = "https://bitbucket.org/secdev/${PN}/downloads/${BP}.zip" 8SRC_URI = "https://github.com/secdev/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
9 file://run-ptest \
10"
9 11
10SRC_URI[md5sum] = "a30d828e59801d1d092219b349f1da9e" 12SRC_URI[md5sum] = "00f11df3d6b46fe6ac306efd757486f9"
11SRC_URI[sha256sum] = "8972c02e39a826a10c02c2bdd5025f7251dce9589c57befd9bb55c65f02e4934" 13SRC_URI[sha256sum] = "1b8a86d687feb8ed01114c0c016b428674cbfec04e3eb6f5249a018c427c4f6a"
12 14
13inherit setuptools 15inherit setuptools ptest
16
17do_install_ptest() {
18 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
19 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
20}
14 21
15RDEPENDS_${PN} = "tcpdump python-subprocess python-compression python-netclient \ 22RDEPENDS_${PN} = "tcpdump python-subprocess python-compression python-netclient \
16 python-netserver python-pydoc python-pkgutil python-shell \ 23 python-netserver python-pydoc python-pkgutil python-shell \