summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-10-17 08:24:04 -0700
committerArmin Kuster <akuster808@gmail.com>2020-10-17 08:24:04 -0700
commit71fb4e16b33b139b5ec1ce38e8cfc5b383efa714 (patch)
tree1074c48d5a9dfcb139e7031b90ea676f8be2068d
parenta8340f10ead7d36d2dd06e0e17a9025bd4d4cc7d (diff)
downloadmeta-security-71fb4e16b33b139b5ec1ce38e8cfc5b383efa714.tar.gz
apparmor: fix issue with older use of shell in make
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-mac/AppArmor/apparmor_2.13.4.bb1
-rw-r--r--recipes-mac/AppArmor/files/0001-tests-regression-fix-failure-on-older-versions-of-Ma.patch40
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-mac/AppArmor/apparmor_2.13.4.bb b/recipes-mac/AppArmor/apparmor_2.13.4.bb
index 6ba1ea8..c1f038f 100644
--- a/recipes-mac/AppArmor/apparmor_2.13.4.bb
+++ b/recipes-mac/AppArmor/apparmor_2.13.4.bb
@@ -24,6 +24,7 @@ SRC_URI = " \
24 file://0001-Makefile.am-suppress-perllocal.pod.patch \ 24 file://0001-Makefile.am-suppress-perllocal.pod.patch \
25 file://run-ptest \ 25 file://run-ptest \
26 file://0001-regression-tests-Don-t-build-syscall_sysctl-if-missi.patch \ 26 file://0001-regression-tests-Don-t-build-syscall_sysctl-if-missi.patch \
27 file://0001-tests-regression-fix-failure-on-older-versions-of-Ma.patch \
27 " 28 "
28 29
29SRCREV = "df0ac742f7a1146181d8734d03334494f2015134" 30SRCREV = "df0ac742f7a1146181d8734d03334494f2015134"
diff --git a/recipes-mac/AppArmor/files/0001-tests-regression-fix-failure-on-older-versions-of-Ma.patch b/recipes-mac/AppArmor/files/0001-tests-regression-fix-failure-on-older-versions-of-Ma.patch
new file mode 100644
index 0000000..a23d889
--- /dev/null
+++ b/recipes-mac/AppArmor/files/0001-tests-regression-fix-failure-on-older-versions-of-Ma.patch
@@ -0,0 +1,40 @@
1From bf8c4ca570c27cf58e882e03680b40357223e6e7 Mon Sep 17 00:00:00 2001
2From: John Johansen <john.johansen@canonical.com>
3Date: Wed, 30 Sep 2020 13:36:23 -0700
4Subject: [PATCH] tests regression: fix failure on older versions of Make
5
6Older versions of Make will choke on the # character in the $(shell
7expression, treating it as the beginning of a comment. Resulting in
8the following error
9
10make unterminated call to function 'shell': missing ')'. Stop.
11
12MR: https://gitlab.com/apparmor/apparmor/-/merge_requests/639
13Signed-off-by: John Johansen <john.johansen@canonical.com>
14Acked-by: Steve Beattie <steve.beattie@canonical.com>
15(cherry picked from commit 8cf3534a5b11643c5913e5eb74e491f2f014d792)
16
17Upstream-Status: Backport
18[Minor fixup]
19Signed-off-by: Armin Kuster <akuster808@gmail.com>
20---
21 tests/regression/apparmor/Makefile | 3 ++-
22 1 file changed, 2 insertions(+), 1 deletion(-)
23
24diff --git a/tests/regression/apparmor/Makefile b/tests/regression/apparmor/Makefile
25index c3d0cfb7..1d55547c 100644
26--- a/tests/regression/apparmor/Makefile
27+++ b/tests/regression/apparmor/Makefile
28@@ -69,7 +69,8 @@ endif # USE_SYSTEM
29
30 CFLAGS += -g -O0 -Wall -Wstrict-prototypes
31
32-USE_SYSCTL:=$(shell echo "#include <sys/sysctl.h>" | cpp -dM >/dev/null 2>/dev/null && echo true)
33+SYSCTL_INCLUDE="\#include <sys/sysctl.h>"
34+USE_SYSCTL:=$(shell echo $(SYSCTL_INCLUDE) | cpp -dM >/dev/null 2>/dev/null && echo true)
35
36
37 SRC=access.c \
38--
392.17.1
40