summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-08 08:05:52 -0700
committerArmin Kuster <akuster808@gmail.com>2017-10-10 07:24:59 -0700
commit5ada70014f01d71ec855a6a31fda9f03d0670988 (patch)
treed4de354bace86d0810d0524fb0b7d5791ac5a2ed
parent1c56da015d82d37762399a58d4c276d59fe22e75 (diff)
downloadmeta-security-5ada70014f01d71ec855a6a31fda9f03d0670988.tar.gz
pcr-extend: add new package
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb b/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb
new file mode 100644
index 0000000..0cc4f63
--- /dev/null
+++ b/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Command line utility to extend hash of arbitrary data into a TPMs PCR."
2HOMEPAGE = "https://github.com/flihp/pcr-extend"
3SECTION = "security/tpm"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "libtspi"
8
9PV = "0.1+git${SRCPV}"
10SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316"
11
12SRC_URI = "git://github.com/flihp/pcr-extend.git "
13
14inherit autotools
15
16S = "${WORKDIR}/git"
17
18do_compile() {
19 oe_runmake -C ${S}/src
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 oe_runmake -C ${S}/src DESTDIR="${D}" install
25}