summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-09-09 12:08:35 -0700
committerArmin Kuster <akuster808@gmail.com>2018-09-17 21:08:19 -0700
commit561d0806a9d4e6a954bc19bf951dc69f4e40d3eb (patch)
tree1d108db6d40d7c31785fbd82e86e0dfc855608e2
parent32def3971b6f55863dce96b1c32358277a337092 (diff)
downloadmeta-security-561d0806a9d4e6a954bc19bf951dc69f4e40d3eb.tar.gz
scapy: update to 2.4.0 and covert
convert package to python standard Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rwxr-xr-xrecipes-security/scapy/files/run-ptest (renamed from recipes-security/scapy/scapy/run-ptest)0
-rw-r--r--recipes-security/scapy/python-scapy.inc (renamed from recipes-security/scapy/scapy_2.3.3.bb)16
-rw-r--r--recipes-security/scapy/python-scapy_2.4.0.bb6
-rw-r--r--recipes-security/scapy/python3-scapy_2.4.0.bb4
4 files changed, 16 insertions, 10 deletions
diff --git a/recipes-security/scapy/scapy/run-ptest b/recipes-security/scapy/files/run-ptest
index 91b29f9..91b29f9 100755
--- a/recipes-security/scapy/scapy/run-ptest
+++ b/recipes-security/scapy/files/run-ptest
diff --git a/recipes-security/scapy/scapy_2.3.3.bb b/recipes-security/scapy/python-scapy.inc
index 1c8685b..5abe7db 100644
--- a/recipes-security/scapy/scapy_2.3.3.bb
+++ b/recipes-security/scapy/python-scapy.inc
@@ -5,20 +5,16 @@ LICENSE = "GPLv2"
5 5
6LIC_FILES_CHKSUM = "file://bin/scapy;beginline=9;endline=13;md5=1d5249872cc54cd4ca3d3879262d0c69" 6LIC_FILES_CHKSUM = "file://bin/scapy;beginline=9;endline=13;md5=1d5249872cc54cd4ca3d3879262d0c69"
7 7
8SRC_URI = "https://github.com/secdev/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ 8SRC_URI[md5sum] = "d7d3c4294f5a718e234775d38dbeb7ec"
9 file://run-ptest \ 9SRC_URI[sha256sum] = "452f714f5c2eac6fd0a6146b1dbddfc24dd5f4103f3ed76227995a488cfb2b73"
10"
11 10
12SRC_URI[md5sum] = "336d6832110efcf79ad30c9856ef5842" 11inherit pypi ptest
13SRC_URI[sha256sum] = "67642cf7b806e02daeddd588577588caebddc3426db7904e7999a0b0334a63b5"
14
15inherit setuptools ptest
16 12
17do_install_ptest() { 13do_install_ptest() {
18 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH} 14 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
19 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest 15 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
20} 16}
21 17
22RDEPENDS_${PN} = "tcpdump python-subprocess python-compression python-netclient \ 18RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-netclient \
23 python-netserver python-pydoc python-pkgutil python-shell \ 19 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
24 python-threading python-numbers python-pycrypto" 20 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"
diff --git a/recipes-security/scapy/python-scapy_2.4.0.bb b/recipes-security/scapy/python-scapy_2.4.0.bb
new file mode 100644
index 0000000..98db1fd
--- /dev/null
+++ b/recipes-security/scapy/python-scapy_2.4.0.bb
@@ -0,0 +1,6 @@
1inherit setuptools
2require python-scapy.inc
3
4SRC_URI += "file://run-ptest"
5
6RDEPENDS_${PN} += "${PYTHON_PN}-subprocess"
diff --git a/recipes-security/scapy/python3-scapy_2.4.0.bb b/recipes-security/scapy/python3-scapy_2.4.0.bb
new file mode 100644
index 0000000..93ca7be
--- /dev/null
+++ b/recipes-security/scapy/python3-scapy_2.4.0.bb
@@ -0,0 +1,4 @@
1inherit setuptools3
2require python-scapy.inc
3
4SRC_URI += "file://run-ptest"