summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2023-06-22 06:51:02 -0400
committerArmin Kuster <akuster808@gmail.com>2023-06-25 15:05:28 -0400
commit53c6324c5f2fef67ce5ee6e0d850d693885bf28f (patch)
tree92c3a62672ad23e2f81e9954ca5064c94726b0d6
parentf1591a1579c44ea8127678e5cd0f89b22ecdc495 (diff)
downloadmeta-security-53c6324c5f2fef67ce5ee6e0d850d693885bf28f.tar.gz
scap-security-guide: Add Poky
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-compliance/scap-security-guide/files/0001-scap-security-guide-add-Poky-support.patch91
-rw-r--r--recipes-compliance/scap-security-guide/scap-security-guide_0.1.67.bb1
2 files changed, 92 insertions, 0 deletions
diff --git a/recipes-compliance/scap-security-guide/files/0001-scap-security-guide-add-Poky-support.patch b/recipes-compliance/scap-security-guide/files/0001-scap-security-guide-add-Poky-support.patch
new file mode 100644
index 0000000..355f954
--- /dev/null
+++ b/recipes-compliance/scap-security-guide/files/0001-scap-security-guide-add-Poky-support.patch
@@ -0,0 +1,91 @@
1From 23a224203a73688567f500380644e5cf30c8ed99 Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster808@gmail.com>
3Date: Thu, 22 Jun 2023 06:19:26 -0400
4Subject: [PATCH] scap-security-guide: add Poky support
5
6Signed-off-by: Armin Kuster <akuster808@gmail.com>
7
8Upstream-Status: Pending
9Signed-off-by: Armin Kuster <akuster808@gmail.com>
10
11---
12 products/openembedded/product.yml | 7 +++-
13 .../openembedded/transforms/constants.xslt | 4 +--
14 shared/checks/oval/installed_OS_is_poky.xml | 33 +++++++++++++++++++
15 3 files changed, 41 insertions(+), 3 deletions(-)
16 create mode 100644 shared/checks/oval/installed_OS_is_poky.xml
17
18diff --git a/products/openembedded/product.yml b/products/openembedded/product.yml
19index 9f2f12d737..a495e197c0 100644
20--- a/products/openembedded/product.yml
21+++ b/products/openembedded/product.yml
22@@ -14,6 +14,11 @@ init_system: "systemd"
23 cpes_root: "../../shared/applicability"
24 cpes:
25 - openembedded:
26- name: "cpe:/o:openembedded"
27+ name: "cpe:/o:openembedded:nodistro:"
28 title: "OpenEmbedded nodistro"
29 check_id: installed_OS_is_openembedded
30+
31+ - poky:
32+ name: "cpe:/o:openembedded:poky:"
33+ title: "OpenEmbedded Poky reference distribution"
34+ check_id: installed_OS_is_poky
35diff --git a/products/openembedded/transforms/constants.xslt b/products/openembedded/transforms/constants.xslt
36index 85e812a7c1..8901def2f9 100644
37--- a/products/openembedded/transforms/constants.xslt
38+++ b/products/openembedded/transforms/constants.xslt
39@@ -2,8 +2,8 @@
40
41 <xsl:include href="../../../shared/transforms/shared_constants.xslt"/>
42
43-<xsl:variable name="product_long_name">OpenEmbedded nodistro</xsl:variable>
44-<xsl:variable name="product_short_name">OE nodistro</xsl:variable>
45+<xsl:variable name="product_long_name">OpenEmbedded based distribution</xsl:variable>
46+<xsl:variable name="product_short_name">OE distros</xsl:variable>
47 <xsl:variable name="product_stig_id_name">empty</xsl:variable>
48 <xsl:variable name="prod_type">openembedded</xsl:variable>
49
50diff --git a/shared/checks/oval/installed_OS_is_poky.xml b/shared/checks/oval/installed_OS_is_poky.xml
51new file mode 100644
52index 0000000000..9c41acd786
53--- /dev/null
54+++ b/shared/checks/oval/installed_OS_is_poky.xml
55@@ -0,0 +1,33 @@
56+<def-group>
57+ <definition class="inventory" id="installed_OS_is_poky" version="1">
58+ <metadata>
59+ <title>Poky</title>
60+ <affected family="unix">
61+ <platform>multi_platform_all</platform>
62+ </affected>
63+ <description>The operating system installed is a Poky referenece based System</description>
64+ </metadata>
65+ <criteria comment="System is Poky reference distribution" operator="AND">
66+ <extend_definition comment="Installed OS is part of the Unix family" definition_ref="installed_OS_is_part_of_Unix_family" />
67+ <criterion comment="Poky based distro" test_ref="test_os_release_poky" />
68+ <criterion comment="Poky referenece distribution is installed" test_ref="test_poky" />
69+ </criteria>
70+ </definition>
71+
72+ <unix:file_test check="all" check_existence="all_exist" comment="/etc/os-release exists" id="test_os_release_poky" version="1">
73+ <unix:object object_ref="obj_os_release_poky" />
74+ </unix:file_test>
75+ <unix:file_object comment="check /etc/os-release file" id="obj_os_release_poky" version="1">
76+ <unix:filepath>/etc/os-release</unix:filepath>
77+ </unix:file_object>
78+
79+ <ind:textfilecontent54_test check="all" check_existence="at_least_one_exists" comment="Check OpenEmbedded" id="test_poky" version="1">
80+ <ind:object object_ref="obj_poky" />
81+ </ind:textfilecontent54_test>
82+ <ind:textfilecontent54_object id="obj_poky" version="1" comment="Check Poky">
83+ <ind:filepath>/etc/os-release</ind:filepath>
84+ <ind:pattern operation="pattern match">^ID=poky$</ind:pattern>
85+ <ind:instance datatype="int">1</ind:instance>
86+ </ind:textfilecontent54_object>
87+
88+</def-group>
89--
902.34.1
91
diff --git a/recipes-compliance/scap-security-guide/scap-security-guide_0.1.67.bb b/recipes-compliance/scap-security-guide/scap-security-guide_0.1.67.bb
index a9023ec..3802b1a 100644
--- a/recipes-compliance/scap-security-guide/scap-security-guide_0.1.67.bb
+++ b/recipes-compliance/scap-security-guide/scap-security-guide_0.1.67.bb
@@ -10,6 +10,7 @@ SRCREV = "dad85502ce8da722a6afc391346c41cee61e90a9"
10SRC_URI = "git://github.com/ComplianceAsCode/content.git;branch=master;protocol=https \ 10SRC_URI = "git://github.com/ComplianceAsCode/content.git;branch=master;protocol=https \
11 file://0001-scap-security-guide-add-openembedded.patch \ 11 file://0001-scap-security-guide-add-openembedded.patch \
12 file://0001-standard.profile-expand-checks.patch \ 12 file://0001-standard.profile-expand-checks.patch \
13 file://0001-scap-security-guide-add-Poky-support.patch \
13 file://run_eval.sh \ 14 file://run_eval.sh \
14 " 15 "
15 16