summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2024-03-05 17:05:31 +0800
committerArmin Kuster <akuster808@gmail.com>2024-03-27 12:36:58 -0400
commit40ddb9e5ed71cc8787c929d5011f09e244123ef0 (patch)
tree4cdc9c126f11c57a37dd2194db62f9e799881709
parent60021acffb289d5d99530efb15420b134ea91d28 (diff)
downloadmeta-security-40ddb9e5ed71cc8787c929d5011f09e244123ef0.tar.gz
dm-verity-image-initramfs: Set IMAGE_NAME_SUFFIX to empty
According to the Yocto reference manual [1], the IMAGE_NAME_SUFFIX should be set to empty for the initramfs image. Otherwise, we may incur a build error like following due to the initrd check in live-vm-common.bbclass: ERROR: core-image-minimal-1.0-r0 do_bootimg: build-test/tmp/deploy/images/genericx86-64/dm-verity-image-initramfs-genericx86-64.cpio.gz is invalid. initrd image creation failed. ERROR: core-image-minimal-1.0-r0 do_bootimg: ExecutionError('build-test/tmp/work/genericx86_64-poky-linux/core-image-minimal/1.0/temp/run.build_hddimg.1961965', 1, None, None) ERROR: Logfile of failure stored in: build-test/tmp/work/genericx86_64-poky-linux/core-image-minimal/1.0/temp/log.do_bootimg.1961965 ERROR: Task (poky/meta/recipes-core/images/core-image-minimal.bb:do_bootimg) failed with exit code '1' [1] https://docs.yoctoproject.org/ref-manual/variables.html#term-IMAGE_NAME_SUFFIX Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-core/images/dm-verity-image-initramfs.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-core/images/dm-verity-image-initramfs.bb b/recipes-core/images/dm-verity-image-initramfs.bb
index 78f7b49..4256e19 100644
--- a/recipes-core/images/dm-verity-image-initramfs.bb
+++ b/recipes-core/images/dm-verity-image-initramfs.bb
@@ -18,6 +18,8 @@ PACKAGE_INSTALL = " \
18IMAGE_FEATURES = "" 18IMAGE_FEATURES = ""
19IMAGE_LINGUAS = "" 19IMAGE_LINGUAS = ""
20 20
21IMAGE_NAME_SUFFIX ?= ""
22
21# Can we somehow inspect reverse dependencies to avoid these variables? 23# Can we somehow inspect reverse dependencies to avoid these variables?
22python __anonymous() { 24python __anonymous() {
23 verity_image = d.getVar('DM_VERITY_IMAGE') 25 verity_image = d.getVar('DM_VERITY_IMAGE')