summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-06-22 16:52:45 +0200
committerArmin Kuster <akuster808@gmail.com>2023-06-25 15:05:28 -0400
commit405cca40288d1c44f8cba12513f72dc578364313 (patch)
treef044368d69d95d18b95c3bf6f7eface2bdb4aaaf
parentdf8a1eb479170277de354b73af31601eb6f583be (diff)
downloadmeta-security-405cca40288d1c44f8cba12513f72dc578364313.tar.gz
.patch: remove probably unused patches
There could be some false possitives (the script is far from perfect), so please test it on your QA, I've only double checked with "git grep" (the script looks only in parent directory). @ ~/layers/meta-security $ /OE/extra-layers/meta-ros/scripts/check-patch-files.sh . ./recipes-ids/tripwire/files/add_armeb_arch.patch: not used in any recipe ./dynamic-layers/meta-python/recipes-security/fail2ban/files/0001-To-fix-build-error-of-xrang.patch: not used in any recipe ./recipes-scanners/clamav/files/fix2_libcurl_check.patch: not used in any recipe ./recipes-scanners/arpwatch/files/postfix_workaround.patch: not used in any recipe ./meta-tpm/recipes-tpm/libtpm/files/Use-format-s-for-call-to-dprintf.patch: not used in any recipe ./meta-tpm/recipes-tpm/libtpm/files/fix_signed_issue.patch: not used in any recipe ./meta-tpm/recipes-tpm/libtpm/files/Convert-another-vdprintf-to-dprintf.patch: not used in any recipe ./meta-tpm/recipes-tpm/swtpm/files/fix_lib_search_path.patch: not used in any recipe ./meta-tpm/recipes-tpm/swtpm/files/fix_fcntl_h.patch: not used in any recipe ./recipes-mac/AppArmor/files/disable_perl_h_check.patch: not used in any recipe @ ~/layers/meta-security $ git grep add_armeb_arch.patch @ ~/layers/meta-security $ git grep 0001-To-fix-build-error-of-xrang.patch @ ~/layers/meta-security $ git grep fix2_libcurl_check.patch @ ~/layers/meta-security $ git grep postfix_workaround.patch @ ~/layers/meta-security $ git grep Use-format-s-for-call-to-dprintf.patch @ ~/layers/meta-security $ git grep fix_signed_issue.patch @ ~/layers/meta-security $ git grep Convert-another-vdprintf-to-dprintf.patch @ ~/layers/meta-security $ git grep fix_lib_search_path.patch @ ~/layers/meta-security $ git grep fix_fcntl_h.patch @ ~/layers/meta-security $ git grep disable_perl_h_check.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--dynamic-layers/meta-python/recipes-security/fail2ban/files/0001-To-fix-build-error-of-xrang.patch29
-rw-r--r--meta-tpm/recipes-tpm/libtpm/files/Convert-another-vdprintf-to-dprintf.patch26
-rw-r--r--meta-tpm/recipes-tpm/libtpm/files/Use-format-s-for-call-to-dprintf.patch33
-rw-r--r--meta-tpm/recipes-tpm/libtpm/files/fix_signed_issue.patch48
-rw-r--r--meta-tpm/recipes-tpm/swtpm/files/fix_fcntl_h.patch31
-rw-r--r--meta-tpm/recipes-tpm/swtpm/files/fix_lib_search_path.patch66
-rw-r--r--recipes-ids/tripwire/files/add_armeb_arch.patch18
-rw-r--r--recipes-mac/AppArmor/files/disable_perl_h_check.patch19
-rw-r--r--recipes-scanners/arpwatch/files/postfix_workaround.patch91
-rw-r--r--recipes-scanners/clamav/files/fix2_libcurl_check.patch122
10 files changed, 0 insertions, 483 deletions
diff --git a/dynamic-layers/meta-python/recipes-security/fail2ban/files/0001-To-fix-build-error-of-xrang.patch b/dynamic-layers/meta-python/recipes-security/fail2ban/files/0001-To-fix-build-error-of-xrang.patch
deleted file mode 100644
index 72475e0..0000000
--- a/dynamic-layers/meta-python/recipes-security/fail2ban/files/0001-To-fix-build-error-of-xrang.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From fe3436d65518099d35c643848cba50253abc249c Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@cn.fujitsu.com>
3Date: Thu, 9 May 2019 14:44:51 +0900
4Subject: [PATCH] To fix build error of xrange.
5
6NameError: name 'xrange' is not defined
7
8Upstream-Status: Pending
9Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
10---
11 fail2ban/__init__.py | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/fail2ban/__init__.py b/fail2ban/__init__.py
15index fa6dcf7..61789a4 100644
16--- a/fail2ban/__init__.py
17+++ b/fail2ban/__init__.py
18@@ -82,7 +82,7 @@ strptime("2012", "%Y")
19
20 # short names for pure numeric log-level ("Level 25" could be truncated by short formats):
21 def _init():
22- for i in xrange(50):
23+ for i in range(50):
24 if logging.getLevelName(i).startswith('Level'):
25 logging.addLevelName(i, '#%02d-Lev.' % i)
26 _init()
27--
282.7.4
29
diff --git a/meta-tpm/recipes-tpm/libtpm/files/Convert-another-vdprintf-to-dprintf.patch b/meta-tpm/recipes-tpm/libtpm/files/Convert-another-vdprintf-to-dprintf.patch
deleted file mode 100644
index 9e1021a..0000000
--- a/meta-tpm/recipes-tpm/libtpm/files/Convert-another-vdprintf-to-dprintf.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 09e7dd42e5201d079bad70e9f7cc6033ce1c7cad Mon Sep 17 00:00:00 2001
2From: Stefan Berger <stefanb@linux.vnet.ibm.com>
3Date: Fri, 3 Feb 2017 10:58:22 -0500
4Subject: [PATCH] Convert another vdprintf to dprintf
5
6Signed-off-by: Stefan Berger <stefanb@linux.vnet.ibm.com>
7Upstream-Status: Backport
8Signed-off-by: Armin Kuster <akuster@mvista.com>
9
10---
11 src/tpm_library.c | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14Index: git/src/tpm_library.c
15===================================================================
16--- git.orig/src/tpm_library.c
17+++ git/src/tpm_library.c
18@@ -427,7 +427,7 @@ void TPMLIB_LogPrintfA(unsigned int inde
19 indent = sizeof(spaces) - 1;
20 memset(spaces, ' ', indent);
21 spaces[indent] = 0;
22- vdprintf(debug_fd, spaces, NULL);
23+ dprintf(debug_fd, "%s", spaces);
24 }
25
26 va_start(args, format);
diff --git a/meta-tpm/recipes-tpm/libtpm/files/Use-format-s-for-call-to-dprintf.patch b/meta-tpm/recipes-tpm/libtpm/files/Use-format-s-for-call-to-dprintf.patch
deleted file mode 100644
index a71b5c1..0000000
--- a/meta-tpm/recipes-tpm/libtpm/files/Use-format-s-for-call-to-dprintf.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 6a9b4e5d70f770aa9ca31e3e6d3b1ae72c192070 Mon Sep 17 00:00:00 2001
2From: Stefan Berger <stefanb@linux.vnet.ibm.com>
3Date: Tue, 31 Jan 2017 20:10:51 -0500
4Subject: [PATCH] Use format '%s' for call to dprintf
5
6Fix the dprintf call to use a format parameter that otherwise causes
7errors with gcc on certain platforms.
8
9Signed-off-by: Stefan Berger <stefanb@linux.vnet.ibm.com>
10
11Upstream-Status: Backport
12replaces local patch
13Signed-off-by: Armin Kuster <akuster@mvsita.com>
14
15---
16 src/tpm_library.c | 4 ++--
17 1 file changed, 2 insertions(+), 2 deletions(-)
18
19Index: git/src/tpm_library.c
20===================================================================
21--- git.orig/src/tpm_library.c
22+++ git/src/tpm_library.c
23@@ -405,8 +405,8 @@ int TPMLIB_LogPrintf(const char *format,
24 }
25
26 if (debug_prefix)
27- dprintf(debug_fd, debug_prefix);
28- dprintf(debug_fd, buffer);
29+ dprintf(debug_fd, "%s", debug_prefix);
30+ dprintf(debug_fd, "%s", buffer);
31
32 return i;
33 }
diff --git a/meta-tpm/recipes-tpm/libtpm/files/fix_signed_issue.patch b/meta-tpm/recipes-tpm/libtpm/files/fix_signed_issue.patch
deleted file mode 100644
index fc13aa5..0000000
--- a/meta-tpm/recipes-tpm/libtpm/files/fix_signed_issue.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1Upstream-Status: Pending
2Signed-off-by: Armin kuster <akuster808@gmail.com>
3
4Index: git/src/swtpm/ctrlchannel.c
5===================================================================
6--- git.orig/src/swtpm/ctrlchannel.c
7+++ git/src/swtpm/ctrlchannel.c
8@@ -152,7 +152,8 @@ static int ctrlchannel_receive_state(ptm
9 uint32_t tpm_number = 0;
10 unsigned char *blob = NULL;
11 uint32_t blob_length = be32toh(pss->u.req.length);
12- uint32_t remain = blob_length, offset = 0;
13+ ssize_t remain = (ssize_t) blob_length;
14+ uint32_t offset = 0;
15 TPM_RESULT res;
16 uint32_t flags = be32toh(pss->u.req.state_flags);
17 TPM_BOOL is_encrypted = (flags & PTM_STATE_FLAG_ENCRYPTED) != 0;
18Index: git/src/swtpm_ioctl/tpm_ioctl.c
19===================================================================
20--- git.orig/src/swtpm_ioctl/tpm_ioctl.c
21+++ git/src/swtpm_ioctl/tpm_ioctl.c
22@@ -303,7 +303,7 @@ static int do_save_state_blob(int fd, bo
23 numbytes = write(file_fd, pgs.u.resp.data,
24 devtoh32(is_chardev, pgs.u.resp.length));
25
26- if (numbytes != devtoh32(is_chardev, pgs.u.resp.length)) {
27+ if (numbytes != (ssize_t) devtoh32(is_chardev, pgs.u.resp.length)) {
28 fprintf(stderr,
29 "Could not write to file '%s': %s\n",
30 filename, strerror(errno));
31@@ -420,7 +420,7 @@ static int do_load_state_blob(int fd, bo
32 had_error = true;
33 break;
34 }
35- pss.u.req.length = htodev32(is_chardev, numbytes);
36+ pss.u.req.length = htodev32(is_chardev, (uint32_t) numbytes);
37
38 /* the returnsize is zero on all intermediate packets */
39 returnsize = ((size_t)numbytes < sizeof(pss.u.req.data))
40@@ -863,7 +863,7 @@ int main(int argc, char *argv[])
41 return EXIT_FAILURE;
42 }
43 /* no tpm_result here */
44- printf("ptm capability is 0x%lx\n", (uint64_t)devtoh64(is_chardev, cap));
45+ printf("ptm capability is 0x%llx\n", (uint64_t)devtoh64(is_chardev, cap));
46
47 } else if (!strcmp(command, "-i")) {
48 init.u.req.init_flags = htodev32(is_chardev, PTM_INIT_FLAG_DELETE_VOLATILE);
diff --git a/meta-tpm/recipes-tpm/swtpm/files/fix_fcntl_h.patch b/meta-tpm/recipes-tpm/swtpm/files/fix_fcntl_h.patch
deleted file mode 100644
index 3d16431..0000000
--- a/meta-tpm/recipes-tpm/swtpm/files/fix_fcntl_h.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 8750a6c3f0b4d9e7e45b4079150d29eb44774e9c Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster@mvista.com>
3Date: Tue, 14 Mar 2017 22:59:36 -0700
4Subject: [PATCH 2/4] logging: Fix musl build issue with fcntl
5
6 error: #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.h> [-Werror=cpp]
7 #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.
8
9Upstream-Status: Pending
10Signed-off-by: Armin Kuster <akuster@mvista.com>
11
12---
13 src/swtpm/logging.c | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/swtpm/logging.c b/src/swtpm/logging.c
17index f16cab6..7da8606 100644
18--- a/src/swtpm/logging.c
19+++ b/src/swtpm/logging.c
20@@ -45,7 +45,7 @@
21 #include <errno.h>
22 #include <string.h>
23 #include <sys/types.h>
24-#include <sys/fcntl.h>
25+#include <fcntl.h>
26 #include <sys/stat.h>
27 #include <stdio.h>
28 #include <stdlib.h>
29--
302.11.0
31
diff --git a/meta-tpm/recipes-tpm/swtpm/files/fix_lib_search_path.patch b/meta-tpm/recipes-tpm/swtpm/files/fix_lib_search_path.patch
deleted file mode 100644
index 60958f7..0000000
--- a/meta-tpm/recipes-tpm/swtpm/files/fix_lib_search_path.patch
+++ /dev/null
@@ -1,66 +0,0 @@
1From 672bb4ee625da3141ba6cecb0601c7563de4c483 Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster808@gmail.com>
3Date: Thu, 13 Oct 2016 02:03:56 -0700
4Subject: [PATCH 1/4] swtpm: add new package
5
6Upstream-Status: Inappropriate [OE config]
7
8Signed-off-by: Armin Kuster <akuster808@gmail.com>
9
10Rebased to current tip.
11
12Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
13
14---
15 configure.ac | 34 ++++++++++------------------------
16 1 file changed, 10 insertions(+), 24 deletions(-)
17
18diff --git a/configure.ac b/configure.ac
19index abf5be1..85ed6ac 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -395,31 +395,17 @@ CFLAGS="$CFLAGS -Wformat -Wformat-security"
23 dnl We have to make sure libtpms is using the same crypto library
24 dnl to avoid problems
25 AC_MSG_CHECKING([the crypto library libtpms is using])
26-dirs=$($CC $CFLAGS -Xlinker --verbose 2>/dev/null | \
27- sed -n '/SEARCH_DIR/p' | \
28- sed 's/SEARCH_DIR("\(@<:@^"@:>@*\)"); */\1 /g' | \
29- sed 's|=/|/|g')
30-for dir in $dirs $LIBRARY_PATH; do
31- if test -r $dir/libtpms.so; then
32- if test -n "`ldd $dir/libtpms.so | grep libcrypto.so`"; then
33- libtpms_cryptolib="openssl"
34- break
35- fi
36- if test -n "`ldd $dir/libtpms.so | grep libnss3.so`"; then
37- libtpms_cryptolib="freebl"
38- break
39- fi
40+dir="$SEARCH_DIR"
41+if test -r $dir/libtpms.so; then
42+ if test -n "`ldd $dir/libtpms.so | grep libcrypto.so`"; then
43+ libtpms_cryptolib="openssl"
44+ break
45 fi
46- case $host_os in
47- cygwin|openbsd*)
48- if test -r $dir/libtpms.a; then
49- if test -n "$(nm $dir/libtpms.a | grep "U AES_encrypt")"; then
50- libtpms_cryptolib="openssl"
51- fi
52- fi
53- ;;
54- esac
55-done
56+ if test -n "`ldd $dir/libtpms.so | grep libnss3.so`"; then
57+ libtpms_cryptolib="freebl"
58+ break
59+ fi
60+fi
61
62 if test -z "$libtpms_cryptolib"; then
63 AC_MSG_ERROR([Could not determine libtpms crypto library.])
64--
652.11.0
66
diff --git a/recipes-ids/tripwire/files/add_armeb_arch.patch b/recipes-ids/tripwire/files/add_armeb_arch.patch
deleted file mode 100644
index 2379d66..0000000
--- a/recipes-ids/tripwire/files/add_armeb_arch.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1tripwire: Add armeb support
2
3Upstream-Status: Submitted to tripwire-dev
4
5Signed-off-by: Armin Kuster <akuster@mvista.com>
6
7diff -Naurp tripwire-2.4.2.2-src_org/config.sub tripwire-2.4.2.2-src/config.sub
8--- tripwire-2.4.2.2-src_org/config.sub 2015-07-20 15:03:04.161452573 +0530
9+++ tripwire-2.4.2.2-src/config.sub 2015-07-20 15:06:07.077673139 +0530
10@@ -268,7 +268,7 @@ case $basic_machine in
11 # FIXME: clean up the formatting here.
12 vax-* | tahoe-* | i*86-* | i860-* | ia64-* | m32r-* | m68k-* | m68000-* \
13 | m88k-* | sparc-* | ns32k-* | fx80-* | arc-* | c[123]* | aarch64-* | aarch64be-* \
14- | arm-* | armbe-* | armle-* | armv*-* | strongarm-* | xscale-* \
15+ | arm-* | armeb-* | armbe-* | armle-* | armv*-* | strongarm-* | xscale-* \
16 | mips-* | pyramid-* | tron-* | a29k-* | romp-* | rs6000-* \
17 | power-* | none-* | 580-* | cray2-* | h8300-* | h8500-* | i960-* \
18 | xmp-* | ymp-* \
diff --git a/recipes-mac/AppArmor/files/disable_perl_h_check.patch b/recipes-mac/AppArmor/files/disable_perl_h_check.patch
deleted file mode 100644
index 7ffdf2f..0000000
--- a/recipes-mac/AppArmor/files/disable_perl_h_check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3Remove file check for $perl_includedir/perl.h. AC_CHECK_FILE will fail on
4cross compilation. Rather than try and get a compile check to work here,
5we know that we have what's required via our metadata so remove only this
6check.
7
8Signed-off-by: Tom Rini <trini@konsulko.com>
9
10--- a/libraries/libapparmor/configure.ac.orig 2017-06-13 16:41:38.668471495 -0400
11+++ b/libraries/libapparmor/configure.ac 2017-06-13 16:41:40.708471543 -0400
12@@ -58,7 +58,6 @@
13 AC_PATH_PROG(PERL, perl)
14 test -z "$PERL" && AC_MSG_ERROR([perl is required when enabling perl bindings])
15 perl_includedir="`$PERL -e 'use Config; print $Config{archlib}'`/CORE"
16- AC_CHECK_FILE($perl_includedir/perl.h, enable_perl=yes, enable_perl=no)
17 fi
18
19
diff --git a/recipes-scanners/arpwatch/files/postfix_workaround.patch b/recipes-scanners/arpwatch/files/postfix_workaround.patch
deleted file mode 100644
index 95213f2..0000000
--- a/recipes-scanners/arpwatch/files/postfix_workaround.patch
+++ /dev/null
@@ -1,91 +0,0 @@
1Sendmail exists after the system boots. We are using postfix
2so no need to check if it exists.
3
4Upstream-Status: Inappropriate [embedded specific]
5
6Signed-off-by: Armin Kuster <akuster808@gmail.com>
7
8Index: arpwatch-3.0/configure
9===================================================================
10--- arpwatch-3.0.orig/configure
11+++ arpwatch-3.0/configure
12@@ -636,7 +636,6 @@ LBL_LIBS
13 HAVE_FREEBSD_TRUE
14 HAVE_FREEBSD_FALSE
15 PYTHON
16-V_SENDMAIL
17 LIBOBJS
18 INSTALL_DATA
19 INSTALL_SCRIPT
20@@ -5573,53 +5572,6 @@ fi
21 done
22
23
24-# Extract the first word of "sendmail", so it can be a program name with args.
25-set dummy sendmail; ac_word=$2
26-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
27-$as_echo_n "checking for $ac_word... " >&6; }
28-if ${ac_cv_path_V_SENDMAIL+:} false; then :
29- $as_echo_n "(cached) " >&6
30-else
31- case $V_SENDMAIL in
32- [\\/]* | ?:[\\/]*)
33- ac_cv_path_V_SENDMAIL="$V_SENDMAIL" # Let the user override the test with a path.
34- ;;
35- *)
36- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
37-as_dummy="$PATH:/usr/sbin:/usr/lib:/usr/bin:/usr/ucblib:/usr/local/etc"
38-for as_dir in $as_dummy
39-do
40- IFS=$as_save_IFS
41- test -z "$as_dir" && as_dir=.
42- for ac_exec_ext in '' $ac_executable_extensions; do
43- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
44- ac_cv_path_V_SENDMAIL="$as_dir/$ac_word$ac_exec_ext"
45- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
46- break 2
47- fi
48-done
49- done
50-IFS=$as_save_IFS
51-
52- ;;
53-esac
54-fi
55-V_SENDMAIL=$ac_cv_path_V_SENDMAIL
56-if test -n "$V_SENDMAIL"; then
57- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $V_SENDMAIL" >&5
58-$as_echo "$V_SENDMAIL" >&6; }
59-else
60- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
61-$as_echo "no" >&6; }
62-fi
63-
64-
65-
66-if test -z "${V_SENDMAIL}" ; then
67- as_fn_error $? "Can't find sendmail" "$LINENO" 5
68-fi
69-
70-
71 python=${PYTHON:-python}
72 # Extract the first word of "${python}", so it can be a program name with args.
73 set dummy ${python}; ac_word=$2
74Index: arpwatch-3.0/configure.in
75===================================================================
76--- arpwatch-3.0.orig/configure.in
77+++ arpwatch-3.0/configure.in
78@@ -76,13 +76,6 @@ AC_LBL_UNION_WAIT
79 AC_CHECK_LIB(resolv, res_query)
80 AC_LBL_LIBPCAP(V_PCAPDEP, V_INCLS)
81
82-AC_PATH_PROG(V_SENDMAIL, sendmail,,
83- $PATH:/usr/sbin:/usr/lib:/usr/bin:/usr/ucblib:/usr/local/etc)
84-
85-if test -z "${V_SENDMAIL}" ; then
86- AC_MSG_ERROR([Can't find sendmail])
87-fi
88-
89 dnl AC_LBL_CHECK_TYPE(int32_t, int)
90 dnl AC_LBL_CHECK_TYPE(u_int32_t, u_int)
91
diff --git a/recipes-scanners/clamav/files/fix2_libcurl_check.patch b/recipes-scanners/clamav/files/fix2_libcurl_check.patch
deleted file mode 100644
index 8b500f3..0000000
--- a/recipes-scanners/clamav/files/fix2_libcurl_check.patch
+++ /dev/null
@@ -1,122 +0,0 @@
1clamav .102.2 tries to find clamav using culf_config. Use EO pkg_config instead
2
3Upstream-Status: Inappropriate [OE specific]
4Signed-off-by: Armin Kuster <akuster808@gmail.com>
5
6Index: git/configure
7===================================================================
8--- git.orig/configure
9+++ git/configure
10@@ -28850,39 +28850,14 @@ $as_echo_n "checking for libcurl install
11 if test "${with_libcurl+set}" = set; then :
12 withval=$with_libcurl;
13 find_curl="no"
14-if test "X$withval" = "Xyes"; then
15- find_curl="yes"
16-else
17- if test "X$withval" != "Xno"; then
18- if test -f "${withval}/bin/curl-config"; then
19- LIBCURL_HOME="$withval"
20- have_curl="yes"
21- fi
22- fi
23-fi
24-
25-else
26- find_curl="yes"
27-fi
28-
29-
30-if test "X$find_curl" = "Xyes"; then
31- for p in /usr/local /usr ; do
32- if test -f "${p}/bin/curl-config"; then
33- LIBCURL_HOME=$p
34- have_curl="yes"
35- fi
36- done
37-fi
38-
39-if test "X$have_curl" = "Xyes"; then
40- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $LIBCURL_HOME" >&5
41-$as_echo "$LIBCURL_HOME" >&6; }
42- if test -f "$LIBCURL_HOME/bin/curl-config"; then
43+ #save_LDFLAGS="$LDFLAGS"
44+ if test "X$withval" != "Xno"; then
45+ LIBCURL_HOME="$withval"
46+ if test "${PKG_CONFIG} libcurl --exists"; then
47 CURL_LDFLAGS="$LDFLAGS"
48- CURL_LIBS=$($LIBCURL_HOME/bin/curl-config --libs)
49- CURL_CPPFLAGS=$($LIBCURL_HOME/bin/curl-config --cflags)
50- else
51+ CURL_LIBS=$($PKG_CONFIG libcurl --libs)
52+ CURL_CPPFLAGS=$($PKG_CONFIG libcurl --cflags)
53+ else
54 if test "$LIBCURL_HOME" != "/usr"; then
55 CURL_LDFLAGS="-L$LIBCURL_HOME/lib"
56 CURL_CPPFLAGS="-I$LIBCURL_HOME/include"
57@@ -28891,60 +28866,12 @@ $as_echo "$LIBCURL_HOME" >&6; }
58 CURL_CPPFLAGS=""
59 fi
60 CURL_LIBS="-lcurl"
61- fi
62- save_LDFLAGS="$LDFLAGS"
63- LDFLAGS="$CURL_LDFLAGS $CURL_LIBS"
64- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for curl_easy_init in -lcurl" >&5
65-$as_echo_n "checking for curl_easy_init in -lcurl... " >&6; }
66-if ${ac_cv_lib_curl_curl_easy_init+:} false; then :
67- $as_echo_n "(cached) " >&6
68-else
69- ac_check_lib_save_LIBS=$LIBS
70-LIBS="-lcurl $CURL_LIBS
71- $LIBS"
72-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
73-/* end confdefs.h. */
74-
75-/* Override any GCC internal prototype to avoid an error.
76- Use char because int might match the return type of a GCC
77- builtin and then its argument prototype would still apply. */
78-#ifdef __cplusplus
79-extern "C"
80-#endif
81-char curl_easy_init ();
82-int
83-main ()
84-{
85-return curl_easy_init ();
86- ;
87- return 0;
88-}
89-_ACEOF
90-if ac_fn_c_try_link "$LINENO"; then :
91- ac_cv_lib_curl_curl_easy_init=yes
92-else
93- ac_cv_lib_curl_curl_easy_init=no
94-fi
95-rm -f core conftest.err conftest.$ac_objext \
96- conftest$ac_exeext conftest.$ac_ext
97-LIBS=$ac_check_lib_save_LIBS
98-fi
99-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_curl_curl_easy_init" >&5
100-$as_echo "$ac_cv_lib_curl_curl_easy_init" >&6; }
101-if test "x$ac_cv_lib_curl_curl_easy_init" = xyes; then :
102-
103- curl_msg="";
104- have_curl="yes";
105- CLAMSUBMIT_LIBS="$CLAMSUBMIT_LIBS $CURL_LDFLAGS $CURL_LIBS";
106- CLAMSUBMIT_CFLAGS="$CLAMSUBMIT_CFLAGS $CURL_CPPFLAGS";
107- FRESHCLAM_LIBS="$FRESHCLAM_LIBS $CURL_LDFLAGS $CURL_LIBS";
108- FRESHCLAM_CPPFLAGS="$FRESHCLAM_CPPFLAGS $CURL_CPPFLAGS"
109-
110-else
111-
112- as_fn_error $? "Your libcurl is misconfigured. libcurl (e.g. libcurl-devel) is required in order to build freshclam and clamsubmit." "$LINENO" 5
113+ fi
114
115-fi
116+ have_curl="yes"
117+ LDFLAGS="$save_LDFLAGS"
118+ LDFLAGS="$CURL_LDFLAGS $CURL_LIBS"
119+ fi
120
121 LDFLAGS="$save_LDFLAGS"
122 else