summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2023-09-17 14:35:57 -0400
committerArmin Kuster <akuster808@gmail.com>2023-09-25 09:45:11 -0400
commit0d47c43dcec2f0118229924bc1f4a0458d4752e6 (patch)
tree9b642a482c2f7d7308ee43106c1fac712d734a77
parentff8d871caf2616028dcba08cd67e4b6297f37bfd (diff)
downloadmeta-security-0d47c43dcec2f0118229924bc1f4a0458d4752e6.tar.gz
openscap: update to 1.3.9
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-compliance/openscap/files/0003-CMakeLists.txt-make-2-variables-configurable.patch37
-rw-r--r--recipes-compliance/openscap/openscap_1.3.9.bb (renamed from recipes-compliance/openscap/openscap_1.3.8.bb)6
2 files changed, 2 insertions, 41 deletions
diff --git a/recipes-compliance/openscap/files/0003-CMakeLists.txt-make-2-variables-configurable.patch b/recipes-compliance/openscap/files/0003-CMakeLists.txt-make-2-variables-configurable.patch
deleted file mode 100644
index 953b0d9..0000000
--- a/recipes-compliance/openscap/files/0003-CMakeLists.txt-make-2-variables-configurable.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From f99c3f1f516a84d33794f8e3da59adea1a12ef54 Mon Sep 17 00:00:00 2001
2From: Kai Kang <kai.kang@windriver.com>
3Date: Tue, 20 Jun 2023 22:42:51 +0800
4Subject: [PATCH] CMakeLists.txt: make 2 variables configurable
5
6Variables PREFERRED_PYTHON_PATH and PYTHON3_PATH are set with
7${PYTHON_EXECUTABLE}. For cross compile, ${PYTHON_EXECUTABLE} may point
8to other path rather than standard dir such as /usr/bin. Then the
9generated library file contains such path which should NOT. Update to
10make variables PREFERRED_PYTHON_PATH and PYTHON3_PATH configurable to
11avoid such issue.
12
13Upstream-Status: Submitted [https://github.com/OpenSCAP/openscap/pull/1990]
14
15Signed-off-by: Kai Kang <kai.kang@windriver.com>
16---
17 CMakeLists.txt | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/CMakeLists.txt b/CMakeLists.txt
21index 5db014e77..74628cdd4 100644
22--- a/CMakeLists.txt
23+++ b/CMakeLists.txt
24@@ -125,8 +125,8 @@ endif()
25 find_package(PythonInterp 3)
26 find_package(PythonLibs 3)
27
28-set(PREFERRED_PYTHON_PATH "${PYTHON_EXECUTABLE}")
29-set(PYTHON3_PATH "${PYTHON_EXECUTABLE}")
30+set(PREFERRED_PYTHON_PATH "${PYTHON_EXECUTABLE}" CACHE PATH "Path to preferred Python")
31+set(PYTHON3_PATH "${PYTHON_EXECUTABLE}" CACHE PATH "Path to Python3")
32
33 find_package(RPM)
34 if(RPM_FOUND)
35--
362.34.1
37
diff --git a/recipes-compliance/openscap/openscap_1.3.8.bb b/recipes-compliance/openscap/openscap_1.3.9.bb
index 5abd5a6..97261df 100644
--- a/recipes-compliance/openscap/openscap_1.3.8.bb
+++ b/recipes-compliance/openscap/openscap_1.3.9.bb
@@ -10,10 +10,8 @@ DEPENDS = "dbus acl bzip2 pkgconfig gconf procps curl libxml2 libxslt libcap swi
10DEPENDS:class-native = "pkgconfig-native swig-native curl-native libxml2-native libxslt-native libcap-native libpcre-native xmlsec1-native" 10DEPENDS:class-native = "pkgconfig-native swig-native curl-native libxml2-native libxslt-native libcap-native libpcre-native xmlsec1-native"
11 11
12#Jun 22th, 2023 12#Jun 22th, 2023
13SRCREV = "a81c66d9bc36612dd1ca83a8c959a59e172eb4b9" 13SRCREV = "9b3e7563575f7e5b419f8a09999b40f30e3e7c29"
14SRC_URI = "git://github.com/OpenSCAP/openscap.git;branch=maint-1.3;protocol=https \ 14SRC_URI = "git://github.com/OpenSCAP/openscap.git;branch=maint-1.3;protocol=https"
15 file://0003-CMakeLists.txt-make-2-variables-configurable.patch \
16 "
17 15
18S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
19 17