summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Davies <charles.davies@whitetree.xyz>2020-10-07 02:20:06 +0100
committerArmin Kuster <akuster808@gmail.com>2020-10-09 07:29:08 -0700
commit52e83e6b7e57bf352fd6770466996530dece3da5 (patch)
tree0332e91cd6e1cfe771672cfe5a7e1ce28be370c8
parent440c37f0b623ccc0aa0328613908608d6362adda (diff)
downloadmeta-security-zeus.tar.gz
clamav: add INSTALL_CLAMAV_CVD flag to do_installzeus
Recipe provides INSTALL_CLAMAV_CVD flag to bypass clamav cvd db creation. During do_install this flag should be used to conditionally skip install of cvd db if needed. Signed-off-by: Charlie Davies <charles.davies@whitetree.xyz> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/clamav/clamav_0.99.4.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-security/clamav/clamav_0.99.4.bb b/recipes-security/clamav/clamav_0.99.4.bb
index a340b48..1ee3f58 100644
--- a/recipes-security/clamav/clamav_0.99.4.bb
+++ b/recipes-security/clamav/clamav_0.99.4.bb
@@ -102,7 +102,10 @@ do_install_append_class-target () {
102 install -m 0644 ${WORKDIR}/volatiles.03_clamav ${D}${sysconfdir}/default/volatiles/volatiles.03_clamav 102 install -m 0644 ${WORKDIR}/volatiles.03_clamav ${D}${sysconfdir}/default/volatiles/volatiles.03_clamav
103 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/libclamav.pc 103 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/libclamav.pc
104 rm ${D}/${libdir}/libclamav.so 104 rm ${D}/${libdir}/libclamav.so
105 install -m 666 ${S}/clamav_db/* ${D}/${localstatedir}/lib/clamav/. 105 if [ "${INSTALL_CLAMAV_CVD}" = "1" ]; then
106 bbnote "CLAMAV installing cvd"
107 install -m 666 ${S}/clamav_db/* ${D}/${localstatedir}/lib/clamav/.
108 fi
106 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then 109 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
107 install -D -m 0644 ${WORKDIR}/clamav.service ${D}${systemd_unitdir}/system/clamav.service 110 install -D -m 0644 ${WORKDIR}/clamav.service ${D}${systemd_unitdir}/system/clamav.service
108 install -d ${D}${sysconfdir}/tmpfiles.d 111 install -d ${D}${sysconfdir}/tmpfiles.d