summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-06-04 15:51:27 -0700
committerArmin Kuster <akuster@mvista.com>2016-06-26 11:51:41 -0700
commita7ae942a5d2e5a41d4caf653ed074949a80a381e (patch)
tree8bfc1b3394c4f178bb6b68835ba36e3e19740995
parent05e71050f0602805533052d34a7f6bc2235de585 (diff)
downloadmeta-security-krogoth.tar.gz
nmap: fix several new QA warnings.krogoth
WARNING: nmap-7.12-r0 do_package: QA Issue: nmap: Files/directories were installed but not shipped in any package: /usr/lib /usr/bin/ndiff /usr/bin/nping /usr/bin/ncat /usr/lib/python2.7 /usr/lib/python2.7/site-packages /usr/lib/python2.7/site-packages/ndiff.pyc /usr/lib/python2.7/site-packages/ndiff.py Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. nmap: 8 installed and not shipped files. [installed-vs-shipped] remove crazyness and let the system figure out packaging info remove ndiff.py* as the compiled version is installed in /usr/bin and remove the leftover python site-package cruft. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--recipes-security/nmap/nmap_7.12.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/recipes-security/nmap/nmap_7.12.bb b/recipes-security/nmap/nmap_7.12.bb
index 47cd7b6..dadff3d 100644
--- a/recipes-security/nmap/nmap_7.12.bb
+++ b/recipes-security/nmap/nmap_7.12.bb
@@ -10,10 +10,10 @@ SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2"
10SRC_URI[md5sum] = "0764f4dabe7cccda3c49fc3990b62a8a" 10SRC_URI[md5sum] = "0764f4dabe7cccda3c49fc3990b62a8a"
11SRC_URI[sha256sum] = "63df082a87c95a189865d37304357405160fc6333addcf5b84204c95e0539b04" 11SRC_URI[sha256sum] = "63df082a87c95a189865d37304357405160fc6333addcf5b84204c95e0539b04"
12 12
13inherit autotools-brokensep pkgconfig distro_features_check 13inherit autotools-brokensep pkgconfig python-dir distro_features_check
14 14
15PACKAGECONFIG = "ncat nping ndiff pcap" 15PACKAGECONFIG ?= "ncat nping ndiff pcap"
16PACKAGECONFIG += " ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "zenmap", "", d)}" 16PACKAGECONFIG += " ${@bb.utils.contains('IMAGE_FEATURES', 'x11-base', 'zenmap', '', d)}"
17 17
18PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap" 18PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
19PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl" 19PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
@@ -38,19 +38,14 @@ do_configure() {
38 oe_runconf 38 oe_runconf
39} 39}
40 40
41do_install_append () {
42 # remove python dir, its not used or installed
43 rm -fr ${D}/${libdir}
44}
41 45
42PACKAGES = "${PN} ${PN}-dbg ${PN}-doc" 46PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'zenmap', '${PN}-zenmap', '', d)}"
43
44FILES_${PN} = "${bindir}/nmap ${datadir}/nmap/* ${bindir}/uninstall_ndiff"
45
46# append packages if enabled
47FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "ncat", "${bindir}/ncat ${target_datadir}/ncat", "", d)}"
48FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "nping", "${bindir}/nping", "", d)}"
49FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "ndiff", "${bindir}/ndiff ${libdir}/python${PYTHON_BASEVERSION}/site-packages/ndiff.py*", "", d)}"
50
51PACKAGES += "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${PN}-zenmap", "", d)}"
52 47
53FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${libdir}/python${PYTHON_BASEVERSION}/site-packages/radialnet/* ${libdir}/python${PYTHON_BASEVERSION}/site-packages/zenmap*", "", d)}" 48FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${PYTHON_SITEPACKAGES_DIR}/radialnet/* ${PYTHON_SITEPACKAGES_DIR}/zenmap*", "", d)}"
54 49
55RDEPENDS_${PN} = "python" 50RDEPENDS_${PN} = "python"
56RDEPENDS_${PN}-zenmap = "nmap" 51RDEPENDS_${PN}-zenmap = "nmap"