summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-08-09 17:30:50 +0800
committerJia Zhang <zhang.jia@linux.alibaba.com>2021-08-09 18:51:13 +0800
commit0e475df858503a8b30febe99c1c422e4c7cdca9a (patch)
treeaaa11582f2c82016e39b397f4f66a8ebd18a45bd
parent9f03a89db867e1838bd07e4d8620101de09f0cd8 (diff)
downloadmeta-secure-core-0e475df858503a8b30febe99c1c422e4c7cdca9a.tar.gz
secure-core-image: pass encrypted password rather than plaintext password to usermod
In oe-core commit 759df7395908f18b3b68f28d043ac9ebd42dd0c8, the plaintext password setting function was dropped because of the security issue. So the plaintext password setting method "usermod -P 'password' user" is not available. Now we should pass the encrypted password to usermod via -p option. Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
-rw-r--r--meta/recipes-core/images/secure-core-image.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/images/secure-core-image.bb b/meta/recipes-core/images/secure-core-image.bb
index 3621b2d..9c0ede8 100644
--- a/meta/recipes-core/images/secure-core-image.bb
+++ b/meta/recipes-core/images/secure-core-image.bb
@@ -5,4 +5,5 @@ IMAGE_INSTALL += "\
5" 5"
6 6
7inherit extrausers 7inherit extrausers
8EXTRA_USERS_PARAMS += "usermod -P toor root;" 8# Set the root password to toor
9EXTRA_USERS_PARAMS += "usermod -p '\$6\$cnS1MQVd07.jLdkj\$NgXwgR.LWtbi4qD3Drn6x0AQtVtX/CdfKPy1eJzuUC0YdD8s54fLAlsLm8vaoacAoqq6BHYGTAbUnAUNJKTOb1' root;"