summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-02-04 14:10:46 +0800
committerJia Zhang <zhang.jia@linux.alibaba.com>2021-02-04 18:07:53 +0800
commit032e3b77401ff7c3e911ff5b3fabc89e6d9380e8 (patch)
treed03b46a96cb62b347e1deee1213b8e754349c153
parent3704b99169d97ff8067e14d7e40c2c535a7a065a (diff)
downloadmeta-secure-core-032e3b77401ff7c3e911ff5b3fabc89e6d9380e8.tar.gz
tpm2simulator-native: fix native inheritance order
Classes native/nativesdk must be inherited last to prevent unexpected behaviour. Fixes QA warning: QA Issue: tpm2simulator-native: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: cmake.bbclass lib_package.bbclass python-dir.bbclass pythonnative.bbclass [native-last] Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
-rw-r--r--meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb b/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb
index d1205ff..3cbb594 100644
--- a/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb
+++ b/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb
@@ -22,7 +22,7 @@ SRCREV = "e45324eba268723d39856111e7933c5c76238481"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25inherit native pythonnative lib_package cmake 25inherit pythonnative lib_package cmake native
26 26
27EXTRA_OECMAKE = "\ 27EXTRA_OECMAKE = "\
28 -DCMAKE_BUILD_TYPE=Debug \ 28 -DCMAKE_BUILD_TYPE=Debug \