summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Folkesson <marcus.folkesson@gmail.com>2022-05-27 09:14:36 +0200
committerMarcus Folkesson <marcus.folkesson@gmail.com>2022-05-27 09:14:36 +0200
commitb44889b7bbaf9f2b88322b6989833712a17dcc6a (patch)
treedd8e4a228bb740dbdbed4285aee32d1411a235b5
parent735aba8682471193d631eb08602b772b6c41cbb7 (diff)
downloadmeta-readonly-rootfs-overlay-b44889b7bbaf9f2b88322b6989833712a17dcc6a.tar.gz
Adapt to Honister
Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-core/images/core-image-rorootfs-overlay-initramfs.bb2
-rw-r--r--recipes-core/initrdscripts/files/init-readonly-rootfs-overlay-boot.sh10
-rw-r--r--recipes-core/initrdscripts/initramfs-readonly-rootfs-overlay_1.0.bb4
-rw-r--r--recipes-core/initrdscripts/readonly-rootfs-overlay-init-script.inc2
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_%.bbappend2
-rw-r--r--recipes-kernel/linux/linux-yocto_%.bbappend2
7 files changed, 12 insertions, 12 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 37c2a90..de377f2 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "readonly-rootfs-overlay"
9BBFILE_PATTERN_readonly-rootfs-overlay = "^${LAYERDIR}/" 9BBFILE_PATTERN_readonly-rootfs-overlay = "^${LAYERDIR}/"
10BBFILE_PRIORITY_readonly-rootfs-overlay = "6" 10BBFILE_PRIORITY_readonly-rootfs-overlay = "6"
11 11
12LAYERSERIES_COMPAT_readonly-rootfs-overlay = "sumo" 12LAYERSERIES_COMPAT_readonly-rootfs-overlay = "honister"
diff --git a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
index 4c21555..497e9d4 100644
--- a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
+++ b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
@@ -13,7 +13,7 @@ IMAGE_LINGUAS = ""
13 13
14LICENSE = "MIT" 14LICENSE = "MIT"
15 15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}.u-boot"
17inherit core-image 17inherit core-image
18 18
19IMAGE_ROOTFS_SIZE = "8192" 19IMAGE_ROOTFS_SIZE = "8192"
diff --git a/recipes-core/initrdscripts/files/init-readonly-rootfs-overlay-boot.sh b/recipes-core/initrdscripts/files/init-readonly-rootfs-overlay-boot.sh
index be62db0..66f0cdc 100644
--- a/recipes-core/initrdscripts/files/init-readonly-rootfs-overlay-boot.sh
+++ b/recipes-core/initrdscripts/files/init-readonly-rootfs-overlay-boot.sh
@@ -101,11 +101,11 @@ mount_and_boot() {
101 101
102 # Mount root file system to new mount-point, if unsuccessful, try bind 102 # Mount root file system to new mount-point, if unsuccessful, try bind
103 # mounting current root file system. 103 # mounting current root file system.
104 if ! $MOUNT $ROOT_ROMOUNTPARAMS "$ROOT_ROMOUNT" 2>/dev/null && \ 104 if ! $MOUNT $ROOT_ROMOUNTPARAMS "$ROOT_ROMOUNT" 2>/dev/null ; then
105 [ "x$ROOT_ROMOUNTPARAMS_BIND" == "x$ROOT_ROMOUNTPARAMS" ] || \ 105 log "Could not mount $ROOT_RODEVICE, bind mounting..."
106 log "Could not mount $ROOT_RODEVICE, bind mounting..." && \ 106 if ! $MOUNT $ROOT_ROMOUNTPARAMS_BIND "$ROOT_ROMOUNT"; then
107 ! $MOUNT $ROOT_ROMOUNTPARAMS_BIND "$ROOT_ROMOUNT"; then 107 fatal "Could not mount read-only rootfs"
108 fatal "Could not mount read-only rootfs" 108 fi
109 fi 109 fi
110 110
111 # Remounting root file system as read only. 111 # Remounting root file system as read only.
diff --git a/recipes-core/initrdscripts/initramfs-readonly-rootfs-overlay_1.0.bb b/recipes-core/initrdscripts/initramfs-readonly-rootfs-overlay_1.0.bb
index 164d394..8f12a29 100644
--- a/recipes-core/initrdscripts/initramfs-readonly-rootfs-overlay_1.0.bb
+++ b/recipes-core/initrdscripts/initramfs-readonly-rootfs-overlay_1.0.bb
@@ -1,8 +1,8 @@
1require readonly-rootfs-overlay-init-script.inc 1require readonly-rootfs-overlay-init-script.inc
2 2
3do_install_append() { 3do_install:append() {
4 install -d ${D}/dev 4 install -d ${D}/dev
5 mknod -m 622 ${D}/dev/console c 5 1 5 mknod -m 622 ${D}/dev/console c 5 1
6} 6}
7 7
8FILES_${PN} += "/dev" 8FILES:${PN} += "/dev"
diff --git a/recipes-core/initrdscripts/readonly-rootfs-overlay-init-script.inc b/recipes-core/initrdscripts/readonly-rootfs-overlay-init-script.inc
index 947246b..fcfefcf 100644
--- a/recipes-core/initrdscripts/readonly-rootfs-overlay-init-script.inc
+++ b/recipes-core/initrdscripts/readonly-rootfs-overlay-init-script.inc
@@ -12,7 +12,7 @@ do_install() {
12 install -d "${D}/media/rfs/rw" 12 install -d "${D}/media/rfs/rw"
13} 13}
14 14
15FILES_${PN} += " /init /media/rfs" 15FILES:${PN} += " /init /media/rfs"
16 16
17# Due to kernel dependency 17# Due to kernel dependency
18PACKAGE_ARCH = "${MACHINE_ARCH}" 18PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-kernel/linux/linux-yocto-tiny_%.bbappend b/recipes-kernel/linux/linux-yocto-tiny_%.bbappend
index cc2bfe6..cae6b66 100644
--- a/recipes-kernel/linux/linux-yocto-tiny_%.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny_%.bbappend
@@ -1 +1 @@
KERNEL_FEATURES_append = " features/overlayfs/overlayfs.scc" KERNEL_FEATURES:append = " features/overlayfs/overlayfs.scc"
diff --git a/recipes-kernel/linux/linux-yocto_%.bbappend b/recipes-kernel/linux/linux-yocto_%.bbappend
index cc2bfe6..cae6b66 100644
--- a/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1 +1 @@
KERNEL_FEATURES_append = " features/overlayfs/overlayfs.scc" KERNEL_FEATURES:append = " features/overlayfs/overlayfs.scc"